Forum>Hardware>Frage an PiHole Experten

Frage an PiHole Experten

aggi
aggi14.07.2008:59
Hallo, seit gestern Abend funktioniert mein geliebter PiHole nicht mehr. Besser geschrieben er läuft, aber er blockiert keine Werbung mehr. Einzige Änderung gestern war, dass ich einen neuen Link in die Whitelist eingetragen habe, der mir Sport1 freigeben sollte. Diesen Link hatte ich aus dem Pi Hole Forum (acdn.adnxs.com). Da ich dann dachte, dass dies der Übeltäter ist, habe ich ihn gleich wieder rausgeschmissen, aber trotzdem wird jetzt nichts mehr blockiert.
Alle Einstellungen sind gleich geblieben:
- in der 7590 ist die ip des PiHole bei IP4 als DNS Server hinterlegt
- in IP6 ist nichts hinterlegt

Habe bereits PiHole und Fritzbox neu gestartet. Brachte alles nix. Habe ein weiteres Image auf einer anderen SD ausprobiert, auch hier wird nicht mehr geblockt.

Daher weiß ich nun gar nicht mehr, wo ich den Hebel ansetzen soll. Würde ja PiHole neu aufsetzen, aber ob das was bringt, wenn ein anderes Image auch nicht geht!?

Schicke gerne Screenshots für eine bessere Fehlersuche.

Danke 🙏🏼
0

Kommentare

matze4dot014.07.2009:37
Etwas anderes Problem bei mir, aber vielleicht hilfts: Bei mir war es letztens so, dass ich in der Fritzbox das Pi-hole als bevorzugten DNSv4-Server eingestellt hatte und als alternativen DNSv4-Server irgendwas anderes (ich glaub Google - 8.8.8.8). Gleiches für DNSv6. Weil auf einmal nix mehr gefiltert wurde, hab ich dann als alternative Server einfach nochmal die gleiche Adresse wie für den bevorzugten Server eingestellt. Und dann ging’s.
0
aggi
aggi14.07.2010:38
matze4dot0

Bei mir wird gar keine Alternative verlangt.
IP4 bevorzugt nur der PiHole.
+1
DTP
DTP14.07.2010:49
Gibt doch mal auf der Kommandozeile (= Terminal) deines Macs folgendes ein:

scutil --dns | grep nameserver | sort -u

Was steht dann da?
0
aggi
aggi14.07.2011:54
DTP
Gibt doch mal auf der Kommandozeile (= Terminal) deines Macs folgendes ein:

scutil --dns | grep nameserver | sort -u

Was steht dann da?

nameserver[0] : 192.168.178.1
0
DTP
DTP14.07.2011:58
aggi
nameserver[0] : 192.168.178.1
Und, ist das die IP Adresse deines piHoles?

Wenn nicht, ist etwas in den DNS Settings deines DHCP Servers falsch eingestellt. Oder du hast einen DNS manuell auf dem Mac eingetragen?
0
aggi
aggi14.07.2012:04
Nein, das ist die Adresse der FB!
Diese Adresse ist im Mac hinterlegt und die PiHole IP ist als bevorzugter in der FB hinterlegt.
So war es und funktionierte ja auch.
Verstehe ich nicht.... Was sollte ich tun?
0
aggi
aggi14.07.2012:09
IP des PiHole steht in der FB:


IP der FB ist im Mac hinterlegt:


So funktionierte es bis gestern Abend noch.
0
aggi
aggi14.07.2012:13
Ich hatte auch schon umgestellt.
DNS Server vom Anbieter zugewiesen und im Mac die IP des PiHole als DNS Server hinterlegt. Das Ergebnis war das selbe. Keine Werbung wird geblockt.
0
DTP
DTP14.07.2012:14
Bezieht dein Mac seine Adresse per DHCP?

Dann muss in den Fritzbox-Einstellungen für den DHCP Server folgendes stehen:
  • ipv4 Adresse (der Fritzbox): 192.168.178.1
  • Subnetzmaske: 255.255.255.0 (wahrscheinlich oder?)
  • Gateway/Router: 192.168.178.1
  • DHCP Server: JA
  • Adressen von bis: egal (aber im obigen Schema. also zB 192.168.178.5 bis 192.168.178.199)
  • DNS Server: <hier die IP Adresse des piHole Geräts eintragen, also zB 192.168.178.2>
(sorry, Labels geraten, habe keine Fritzbox)
Das pihole Gerät sollte dabei eine FESTE IP adresse haben, in meinem Beispiel 192.168.178.2
+1
DTP
DTP14.07.2012:16
aggi
Kannst du die Screenshots ohne Maskierung posten?
Die verraten nichts geheimnisvolles oder legen deine Daten offen und sind kritisch für die Fehlersuche.

Und da du zwei Netzwerk-Interfaces hast (Ethernet und WLAN), können die Ergebnisse unterschiedlich sein, je nachdem, welches du gerade nutzt.
+1
aggi
aggi14.07.2013:10
0
DTP
DTP14.07.2013:44
Ok, und der .59er ist dann dein pihole, oder?

Trenn mal den Thunderbolt-Adapter, so dass du erstmal für WLAN das Problem behebst.

Dann gib mal im Terminal ein:
sudo killall -HUP mDNSResponder

und mach einen Neustart.

Was steht nun beim DNS (auf dem Mac)?
0
aggi
aggi14.07.2014:35
DTP

Muss ich nachher mal probieren. Bin gerade unterwegs.
192.168.178.59 ist der PiHole und beim Mac ist die FB (192.168.178.1) hinterlegt.
Melde mich...Danke
0
Bierbauchmann14.07.2014:41
Aus meiner Sicht wäre der richtige Weg den Pi-Hole als DNS Server über die FritzBox bekannt zu geben.

Heimnetz - Netzwerk - Netzwerkeinstellungen - IP-Adressen - IPv4 Adressen.
0
DTP
DTP14.07.2014:48
aggi
und beim Mac ist die FB (192.168.178.1) hinterlegt.
Was heißt das bitte? Dass du die .1 als DNS auf dem Mac händisch eingetragen hast? Genau das sollte ja nicht sein, deine FB teilt deinem Mac ja die DNS Adresse mit. Also beim Mac NICHTS mehr einstellen.
0
KoGro14.07.2015:49
Die Fehlersuche auf Ebene der DNS-Einträge in allen Ehren, aber können wir mal kurz an den Anfang zurückgehen? Was heißt „der pi-hole läuft, aber blockiert nichts mehr?“ Dass die blocking-Funktionalität auf dem pi-hole eingeschaltet (und nicht z.B. pausiert) ist und er prinzipiell läuft und eine blocking list nutzt? Das könntest Du über die admin-Oberfläche ja mal kontrollieren. Falls da alles rund ist, wäre die nächste Frage, ob die FB den pi-hole richtig eingetragen hat, das scheint mir aber der Fall zu sein. Die Frage, wie der Mac konfiguriert ist, spielt ja eigentlich erst dann eine Rolle, wenn Du nur auf dem Mac Werbung bekommst, auf anderen Endgeräten (z.B. smartphone) die über die FB ins wlan gehen aber alles rundläuft und der pi-hole sauber filtert... just my 2 cents, aber so würde ich mit der Fehlersuche anfangen...
+1
DTP
DTP14.07.2015:56
KoGro
Die Fehlersuche auf Ebene der DNS-Einträge in allen Ehren, aber können wir mal kurz an den Anfang zurückgehen?
Das ist ja der Anfang.

Wenn der Mac die falsche DNS bekommt (Adresse der Fritzbox und nicht die des piholes), dann spricht der Mac nie mit pihole. Da kann der pihole noch so gut konfiguriert sein…
-1
KoGro14.07.2016:14
DTP
Wenn der Mac die falsche DNS bekommt (Adresse der Fritzbox und nicht die des piholes), dann spricht der Mac nie mit pihole. Da kann der pihole noch so gut konfiguriert sein…

Das stelle ich gar nicht in Frage, aber nachdem aggi ja geschrieben hat, dass gestern an der Konfiguration des pi-hole rumgedreht und nicht, dass was an der Konfiguration des Macs geändert wurde, halte ich die andere Reihenfolge für angebrachter... Darüberhinaus kann die FB schon als Nameserver eingetragen sein und trotzdem selbst wieder den pi-hole nutzen, d.h. die Konfiguration so muss nicht falsch sein (ob es anders nicht besser wäre, ist Ansichtssache).
0
aggi
aggi14.07.2016:25
DTP

Ja, die IP ist autom. hinterlegt.
0
marcel15114.07.2016:54
Schick uns doch mal einen Screenshot von den DNS-Einstellungen des Macs. Weitere Optionen DNS

Übrigens: Private Adressen zu schwärzen macht wenig Sinn, die können wir auch mit größter Anstrengung nicht über das Internet erreichen. Deine IPv6-Adresse - die Du seltsamerweise nicht geschwärzt hast - ist dagegen theoretisch über das Internet erreichbar (i.d.R. aber geblockt von der FB).
Damit kann man so schon einiges herausfinden, z.B. Deinen ISP: O2 Deutschland
+1
aggi
aggi14.07.2017:02
marcel151
Schick uns doch mal einen Screenshot von den DNS-Einstellungen des Macs. Weitere Optionen DNS

Übrigens: Private Adressen zu schwärzen macht wenig Sinn, die können wir auch mit größter Anstrengung nicht über das Internet erreichen. Deine IPv6-Adresse - die Du seltsamerweise nicht geschwärzt hast - ist dagegen theoretisch über das Internet erreichbar (i.d.R. aber geblockt von der FB).
Damit kann man so schon einiges herausfinden, z.B. Deinen ISP: O2 Deutschland

Da siehst du mal, wieviel Ahnung ich habe.
0
aggi
aggi14.07.2017:05
Das komische ist, bin gerade wieder nach Hause gekommen und die Werbung ist weg. Auf allen Geräten!
Habe nicht verändert und die Werbung ist weg.
Habe jetzt noch den Tipp von Bierbauchmann übernommen und es ist immer noch stabil ohne Werbung.
0
DTP
DTP14.07.2017:08
aggi
Das sieht nicht richtig aus, als DNS sollte da der pihole auftauchen. Ist die Situation beim WLAN die gleiche? Bei deinem iPhone auch?

Zieh doch mal den Strom vom pihole Gerät (also ausschalten). Dann sollte KEINS deiner Geräte mehr eine URL erreichen. Wenn das so ist, dann können wir beim pihole weitersuchen.
0
aggi
aggi14.07.2017:14
KoGro
Die Fehlersuche auf Ebene der DNS-Einträge in allen Ehren, aber können wir mal kurz an den Anfang zurückgehen? Was heißt „der pi-hole läuft, aber blockiert nichts mehr?“ Dass die blocking-Funktionalität auf dem pi-hole eingeschaltet (und nicht z.B. pausiert) ist und er prinzipiell läuft und eine blocking list nutzt? Das könntest Du über die admin-Oberfläche ja mal kontrollieren. Falls da alles rund ist, wäre die nächste Frage, ob die FB den pi-hole richtig eingetragen hat, das scheint mir aber der Fall zu sein. Die Frage, wie der Mac konfiguriert ist, spielt ja eigentlich erst dann eine Rolle, wenn Du nur auf dem Mac Werbung bekommst, auf anderen Endgeräten (z.B. smartphone) die über die FB ins wlan gehen aber alles rundläuft und der pi-hole sauber filtert... just my 2 cents, aber so würde ich mit der Fehlersuche anfangen...

Wie schon beschrieben, hatte ich gestern einen Link in die Whitlist übernommen. Gefühlt kam später die Werbung auf all meinen Geräten. Bin auf die PiHole Admin Seite, weil ich dachte, dass ich vielleicht versehentlich den Pi gestoppt habe. War aber nicht der Fall. Der Pi lief wie gewohnt und ich hatte keinerlei Einstellungen an der FB und am Mac vorgenommen. Dei wirklich einzigste Änderung war dieser Eintrag in die Whitelist.
Kann so ein Link was zerschiessen?
Sollte ich mal die Befehle
pihole -g
pihole -up
laufen lassen?
0
aggi
aggi14.07.2017:15
DTP
aggi
Das sieht nicht richtig aus, als DNS sollte da der pihole auftauchen. Ist die Situation beim WLAN die gleiche? Bei deinem iPhone auch?

Zieh doch mal den Strom vom pihole Gerät (also ausschalten). Dann sollte KEINS deiner Geräte mehr eine URL erreichen. Wenn das so ist, dann können wir beim pihole weitersuchen.

Die Werbung ist jetzt aber weg! Zufall, Glück oder andere Umstände?
0
marcel15114.07.2017:16
aggi
Da siehst du mal, wieviel Ahnung ich habe.
Ok, was man daran sehen kann: Dein DNS wird automatisch bezogen, allerdings wird noch die Fritz!Box als DNS eingetragen.
aggi
Das komische ist, bin gerade wieder nach Hause gekommen und die Werbung ist weg. Auf allen Geräten!
Habe nicht verändert und die Werbung ist weg.
Habe jetzt noch den Tipp von Bierbauchmann übernommen und es ist immer noch stabil ohne Werbung.
Das war der Fehler, da muss die Pi-Hole-Adresse eingetragen werden, sonst gehts nicht.
aggi
IP des PiHole steht in der FB:
Das ist falsch! Das ist die Stelle, an der es weiter geht von der Fritz!Box. Das kommt erst NACH dem PiHole. Dort entweder vom ISP den DNS nehmen oder einen öffentlichen eintragen.

Ja es gibt zwar verschiedene Konfigurationsmöglichkeiten, mein empfohlener Weg aber ist:
Client PiHole Fritz!Box Öffentlicher oder ISP DNS
Alles was der PiHole blockt wird dann schon nicht mehr an die Fritz!Box gegeben. Das muss natürlich auch im PiHole konfiguriert werden.
0
aggi
aggi14.07.2017:17
DTP
Das sieht nicht richtig aus, als DNS sollte da der pihole auftauchen. Ist die Situation beim WLAN die gleiche? Bei deinem iPhone auch?

Zieh doch mal den Strom vom pihole Gerät (also ausschalten). Dann sollte KEINS deiner Geräte mehr eine URL erreichen. Wenn das so ist, dann können wir beim pihole weitersuchen.

WLAN der gleiche Eintag. Ziehe jetzt den Stecker und melde mich....
0
aggi
aggi14.07.2017:21
marcel151
aggi
Da siehst du mal, wieviel Ahnung ich habe.
Ok, was man daran sehen kann: Dein DNS wird automatisch bezogen, allerdings wird noch die Fritz!Box als DNS eingetragen.
aggi
Das komische ist, bin gerade wieder nach Hause gekommen und die Werbung ist weg. Auf allen Geräten!
Habe nicht verändert und die Werbung ist weg.
Habe jetzt noch den Tipp von Bierbauchmann übernommen und es ist immer noch stabil ohne Werbung.
Das war der Fehler, da muss die Pi-Hole-Adresse eingetragen werden, sonst gehts nicht.
aggi
IP des PiHole steht in der FB:
Das ist falsch! Das ist die Stelle, an der es weiter geht von der Fritz!Box. Das kommt erst NACH dem PiHole. Dort entweder vom ISP den DNS nehmen oder einen öffentlichen eintragen.

Ja es gibt zwar verschiedene Konfigurationsmöglichkeiten, mein empfohlener Weg aber ist:
Client PiHole Fritz!Box Öffentlicher DNS
Alles was der PiHole blockt wird dann schon nicht mehr an die Fritz!Box gegeben. Das muss natürlich auch im PiHole konfiguriert werden.

Sollte es so aussehen:


0
aggi
aggi14.07.2017:26
Nach dem Neustart steht jetzt im Mac bei LAN und WLAN:


Das scheint doch jetzt korrekt zu sein oder!?
0
marcel15114.07.2017:28
Genau, im PiHole muss aber noch wie unten in meiner Konfig gezeigt die Fritz!Box als Upstream DNS-Server gesetzt werden (angepasst an deine IP-Adressen der FB natürlich).

IPv6-Adresse ist zwar Lokal, wurde aber unkenntlich gemacht da dort die MAC-Adresse der FB enthalten ist (Unique local address).


Übrigens, IPv6-Seitig scheint immer noch deine Fritz!Box als DNS eingetragen zu sein ohne PiHole als Zwischenschritt. Falls du IPv6-Seiten ansteuerst und DNSv6 genutzt wird kann es sein, dass Werbung angezeigt wird.
0
aggi
aggi14.07.2017:32
marcel151
Genau, im PiHole muss aber noch wie unten gezeigt die Fritz!Box als Upstream DNS-Server gesetzt werden.IPv6-Adresse ist zwar Lokal, wurde aber unkenntlich gemacht da dort die MAC-Adresse der FB enthalten ist (Unique local address).

Custom 1 trage ich meine FB ein (192.168.178.1) und
Custom 3 die IP6 Adresse? Wo steht die? Danke...
0
aggi
aggi14.07.2017:35
marcel151
Übrigens, IPv6-Seitig scheint immer noch deine Fritz!Box als DNS eingetragen zu sein. Falls du IPv6-Seiten ansteuerst und DNSv6 genutzt wird kann es sein, dass Werbung angezeigt wird.

Wo und wie löse ich das? Kannst du mich ein wenig lenken? Danke...
0
aggi
aggi14.07.2017:40
muss ich hier noch was einstellen? Hier sehe ich auch eine IP6 Adresse. Muss die im PiHole in Custom 3 eingetragen werden?


0
marcel15114.07.2017:45
aggi
Custom 1 trage ich meine FB ein (192.168.178.1) und
Custom 3 die IP6 Adresse? Wo steht die? Danke...
Du warst doch schon bei den IPv4-Adressen. Die IPv6-Adressen findest Du direkt daneben.
aggi
marcel151
Übrigens, IPv6-Seitig scheint immer noch deine Fritz!Box als DNS eingetragen zu sein. Falls du IPv6-Seiten ansteuerst und DNSv6 genutzt wird kann es sein, dass Werbung angezeigt wird.

Wo und wie löse ich das? Kannst du mich ein wenig lenken? Danke...
Unter den IPv6-Adressen in der FB manuell den PiHole als DNSv6-Server angeben.
aggi
muss ich hier noch was einstellen? Hier sehe ich auch eine IP6 Adresse. Muss die im PiHole in Custom 3 eingetragen werden?
Ja genau, ich lasse zusätzlich noch die Unique-Local-Adresse immer zuweisen. DHCPv6 kannst Du ausschalten, die IPv6-Adressen bekommst Du normalerweise über SLAAC.
0
aggi
aggi14.07.2017:56
@marcel151

mein Post darüber ist mit den Screenshots der IP6 Konfiguration.
Schreibe ich die IP6 Adresse (2 Schreibweisen, mit und ohne "0") in das Custom 3 Feld kommt folgende Meldung:


Wo soll ich da die IP des PiHole eintragen?

Sorry, ist mir alles viel zu kompliziert! Danke...
0
aggi
aggi14.07.2018:13
aggi
@marcel151

mein Post darüber ist mit den Screenshots der IP6 Konfiguration.
Schreibe ich die IP6 Adresse (2 Schreibweisen, mit und ohne "0") in das Custom 3 Feld kommt folgende Meldung:


Wo soll ich da die IP des PiHole eintragen?

Sorry, ist mir alles viel zu kompliziert! Danke...

Habe ich gelöst. Die /64 war zu viel!
0
aggi
aggi14.07.2018:26
@all
Danke an alle, die mir geholfen haben. Es scheint jetzt korrekt zu funktionieren.
Wenn ich jetzt noch einmal darüber nachdenke hatte ich viel Glück, dass es überhaupt bei mir geklappt hat. Gibt es wirklich so viele verschiedene Wege und diese funktionieren nicht korrekt, wenn man sie noch vermischt!?
Gibt es irgendwo eine Anleitung, am besten in Verbindung mit einer FritzBox, so dass ich auch mal genauer erforschen kann, was ich anscheinend zufällig aber funktionierend erstellt habe?

Danke...
0
aggi
aggi14.07.2019:27
@marcel151

mit deiner Einstellung kam wieder teilweise Werbung und teilweise weiße Platzhalter.
Nun habe ich trotz allem auf der FB den DNS Server auf dieser Seite aktiviert:

Deine restlichen Einstellungen habe ich dabei gelassen!
Seitdem ist die komplette Werbung weg und die Platzhalter verschwinden auch. So war es früher auch und so gefällt es mir viel besser. Gibt es dafür eine Erklärung?
0
marcel15114.07.2019:35
Eigentlich wird dadurch eine Schleife erzeugt, so fragt nämlich PiHole die Fritz!Box und die Fritz!Box wieder PiHole nach DNS. Kann so auf Dauer eigentlich nicht funktionieren. Wird vielleicht IPv6 genutzt (und die Werbetreiber über IPv4 nicht erreicht)? Ansonsten testweise mal IPv6 abschalten auf dem Mac.
Komplett wird bei mir übrigens auch nicht geblockt. Ist halt je nachdem wie viele Listen Du implementiert hast.
0
KoGro14.07.2020:05
marcel151
Eigentlich wird dadurch eine Schleife erzeugt, so fragt nämlich PiHole die Fritz!Box und die Fritz!Box wieder PiHole nach DNS. Kann so auf Dauer eigentlich nicht funktionieren.

Wieso? Wenn er im pi-hole als DNS was anderes als die Fritzbox eingerichtet hat, kann es prima genau so funktionieren. Das wäre m.E. eh der schlaueste Weg. Noch schlauer wäre vielleicht, dann auch gleich noch unbound einzurichten, aber das führt wohl zu weit...
+1
aggi
aggi14.07.2020:07
@all

so sehen jetzt bebildert meine Einstellungen aus:
Mac

WLAN + LAN gleicher Eintrag!

FritzBox





PiHole


So wird die Werbung auch exzellent ausgeblendet. Werde jetzt mal die Whitelist versuchen, damit Sport1 geht und das Anhalten auf Zeit.

Wir bzw. ihr könnt auch gern über die Einstellung diskutieren, ob die Sinn machen oder was vielleicht noch besser wäre.

Danke @all
0
john
john14.07.2020:14
KoGro
marcel151
Eigentlich wird dadurch eine Schleife erzeugt, so fragt nämlich PiHole die Fritz!Box und die Fritz!Box wieder PiHole nach DNS. Kann so auf Dauer eigentlich nicht funktionieren.

Wieso? Wenn er im pi-hole als DNS was anderes als die Fritzbox eingerichtet hat, kann es prima genau so funktionieren. Das wäre m.E. eh der schlaueste Weg. Noch schlauer wäre vielleicht, dann auch gleich noch unbound einzurichten, aber das führt wohl zu weit...

hab mich ueber die aussage auch etwas gewundert.

im pihole kann man prima cloudflare, google oder seinen eigenen upstream dns festlegen.

ich betreibe ebenfalls meinen eigenen dns server mit unbound und hyperlocal

@aggi
hab an deinen einstellungen aus den screenshots nichts auszusetzen 😉
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
+1
aggi
aggi14.07.2020:24
Verständnisfrage:
was ist hier der Unterschied? Also was bewirken die Eintragungen auf der jeweiligen Seite bzw. in beiden?

vs.


Möchte mich mal an die Sache herantasten!
0
oblak14.07.2020:54
Die obere Einstellung legt fest, welche DNS-Server die Fritzbox zur Namensauflösung nutzen soll, wenn sie selbst den Namen nicht kennt. In dem Screenshot ist aktuell eingestellt, dass die Fritzbox den DNS-Server des Providers nutzen soll, z.B. Telekom, Vodafone, whatever.

Deine Fritzbox agiert in allen Fällen als DNS-Forwarder für alle in Deinem Heimnetz befindlichen Geräte. Nur Einträge der Domäne fritz.box werden abgefangen und direkt beantwortet. Alle anderen Anfragen werden einfach an den hinterlegten DNS-Server weitergeleitet.

Beispiel 1:
- PC1 will "google.de" auflösen und fragt die Fritzbox
- Fritzbox leitet die Anfrage weiter an Deinen Provider, der meldet 1.2.3.4 zurück und die Fritzbox reicht die Antwort zurück

Also: PC1 Fritzbox Provider

Beispiel 2:
- PC1 will "pc2.fritz.box" auflösen
- Fritzbox kennt pc2 aus der Heimnetzliste und antwortet direkt mit z.B. 192.178.1.45

Also: PC1 Fritzbox

Wenn Du dich für die Option "Andere DNSv4-Server verwenden" entscheidest, wird die Fritzbox nicht den Provider befragen, sondern einen der anderen hinterlegten Server.

Wenn Du hier nun den Pihole einträgst, dann würde sich Beispiel 1 so ändern:

PC1 Fritzbox Pihole ?

Fragezeichen deshalb, weil bis hierhin noch offen ist, wohin Pihole die Anfrage weiterleitet, wenn die Domain unbekannt ist. Hier könnte z.B. google, cloudlfare oder auch der eigene Provider stehen, muss man halt in Pihole richtig hinterlegen.

Falsch wäre es nur, in diesem Fall die Fritzbox zu hinterlegen, denn da kommt die ursprüngliche Anfage ja her:
PC1 Fritzbox Pihole Fritzbox Pihole Fritzbox Pihole ...
Keine gute Idee.

Es kann sein, dass dann der sekundäre DNS-Server abgefragt wird und wenn da z.B. direkt google hinterlegt ist, dann wird genau gar nichts mehr gefiltert, dann hast Du dich selbst ausgehebelt.

Die untere Einstellung legt fest, welchen DNS-Server die Fritzbox an alle Geräte in Deinem Heimnetz aussenden soll (per DHCP).

Normalerweise trägt die Fritzbox sich da selbst ein, sodass dann die oben genannte Kette läuft.

Wenn Du hier nun den PiHole einträgst, so sparst Du dir den Umweg über die Fritzbox, alle Rechner und Geräte werden direkt den PiHole nutzen.

Effektiv gesehen, erreichst Du also mit beiden Einstellungen dasselbe Ziel, solange Du keine Schleifen baust.
Es dürfte keinen Unterschied machen, ob Du nur die erste, nur die zweite oder beide Einstellungen setzt, solange wir von "normalen" DHCP-Clients sprechen. Bei der ersten Einstellungen würde noch jeglicher Traffic der Fritzbox selbst auch von PiHole gefiltert werden, bei der zweiten Einstellungen nur der Traffic der Geräte hinter der Fritzbox.

Aus diesem Grund würde ich beide Einstellungen setzen.

Im Übrigen kommt es auch in Mode, dass Smartdevices und Apps den per DHCP konfigurierten DNS-Server ignorieren und hart verdrahtet eigene DNS-Server nutzen, macht z.B. Google Chromecast so. Da kriegst Du also immer Werbung aufs Auge, egal was Du machst.

Das kann man dann mit einer SNAT-Regel lösen und jeglichen ins Internet gerichteten DNS-Traffic abfangen und zum PiHole umleiten (außer natürlich den eigenen DNS-Traffic des PiHole). Das kann die Fritzbox aber nicht leisten. Da braucht man dann schonen eine Firmware oder einen Router, der solch fortgeschrittenen Einstellungen ermöglicht, z.B. einen Ubiquiti EdgeRouter.
+2
marcel15114.07.2021:08
john
KoGro
marcel151
Eigentlich wird dadurch eine Schleife erzeugt, so fragt nämlich PiHole die Fritz!Box und die Fritz!Box wieder PiHole nach DNS. Kann so auf Dauer eigentlich nicht funktionieren.

Wieso? Wenn er im pi-hole als DNS was anderes als die Fritzbox eingerichtet hat, kann es prima genau so funktionieren. Das wäre m.E. eh der schlaueste Weg. Noch schlauer wäre vielleicht, dann auch gleich noch unbound einzurichten, aber das führt wohl zu weit...

hab mich ueber die aussage auch etwas gewundert.

im pihole kann man prima cloudflare, google oder seinen eigenen upstream dns festlegen.

ich betreibe ebenfalls meinen eigenen dns server mit unbound und hyperlocal

@aggi
hab an deinen einstellungen aus den screenshots nichts auszusetzen 😉
Wie gesagt gibt es mehrere Wege die hierbei nach Rom führen.
1. PiHole als "alleiniger" DNS-Server im LAN.
2. PiHole vor der Fritz!Box als DNS-Server im LAN

Ich wollte ihm ja den Weg zeigen den ich nutze weil er Vorteile hat wie z.B. die Anzeige der Hostnames in PiHole und, dass das DNS grundsätzlich trotzdem noch von der Fritz!Box (bzw. dem nächsten übergeordneten DNS-Server) gehändelt wird.
Der Weg von Dir funktioniert weil Du ja trotzdem einen externen Upstream DNS-Server (Google) konfiguriert hast. Ich habe dort garkeinen Haken gesetzt, die externen DNS-Server sind in der Fritz!Box konfiguriert.
aggi
Verständnisfrage:
was ist hier der Unterschied? Also was bewirken die Eintragungen auf der jeweiligen Seite bzw. in beiden?
Möchte mich mal an die Sache herantasten!
Das obere Bild sind die externen DNS-Server, die die Fritz!Box anfragt wenn sie eine DNS-Anfrage nicht selber beantworten kann (in der Regel DNS vom IPS).
Das untere Bild ist die Konfiguration von DHCP und damit welche IP-Adressen, Gateway und DNS-Server deine Clients beziehen..
Dein DNS Weg aktuell: Client PiHole Google DNS
Mein DNS Weg: Client PiHole Fritz!Box externer DNS der in der FB konfiguriert ist
PiHole ist quasi in meinem Fall ein "Filter", DNS-Anfragen von geblacklisteten Hosts werden in dem Fall garnicht erst an die Fritz!Box weiter geleitet.

Bei Pi-Hole selber findet man gute Anleitungen die das ganze nochmal verdeutlichen(, siehe "Konfigurationen / Konzepte"), wie es letzlich konfiguriert wird ist egal. Ich finde meinen Weg am saubersten.
0
marcel15114.07.2021:42
Sorry kann meinen Beitrag leider nicht bearbeiten. Habe mich auch mal wieder etwas mehr damit beschäftigt, meine Konfiguration habe ich ja auch schon länger am laufen, vielleicht gibt es ja Verbesserungen.
Ich habe es quasi genau so konfiguriert wie hier
Siehe auch die Kommentare dazu weiter unten, auch da wird diese Config als "robust" angesehen.

Im Grunde genommen ist das ganze aber immer noch Geschmackssache, Nachteile hat diese Konfiguration nämlich auch:
-- Theoretisch kein Ausfallschutz, da nur ein DNS-Server per DHCP der Fritz!Box verteilbar Habe ich damit gelöst, dass ich manuell die Fritz!Box als zweiten in den Clients eingetragen habe. So werden bei Ausfall des Pi-Holes die Anfragen ganz normal über die FB beantwortet.

-- 4 statt 3 Hops Merke soweit keine Performanceprobleme

-- Gast W-LAN und VPN werden über Fritz!Box beantwortet Gast W-LAN nutze ich nicht und VPN ist bei mir nur für Site-2-Site notwendig, bleibt also lokal
0
aggi
aggi15.07.2000:16
@ marcel151 + oblak

Danke für diese ausführlichen Erläuterungen. Ich muss es mir noch ein paar mal durchlesen, damit ich es dann mal irgendwann wirklich verstehe.
Ich lasse es erst einmal so, wie es oben in meinen Bildern zu sehen ist, da es funktioniert.
Ein bisschen Tuning kann man immer wieder mal machen aber erst, wenn ich es richtig verstanden habe.

Danke...
0
aggi
aggi15.07.2001:02
Irgendwie geht das alles nicht. Kommt immer wieder mal Werbung.
Sollte ich jetzt am Besten in beiden Fällen den PiHole hinterlegen?
In meiner alten Einstellung hatte ich die von marcel151 vorgeschlagene Einstellung im PiHole gar nicht hinterlegt:

Auch so lief es mindestens das letze 3/4 Jahr mit meinen Einstellungen völlig reibungslos.
Ich weiß leider nicht mehr, wie das alles war. Habe damals auch ein Backup des PiHole gemacht, jedoch schlägt der Import immer fehl.
Es muss eigentlich ein Problem in den Einstellungen von der Fritzbox sein. Ich habe ja noch eine andere SD-Karte, mit einer älteren aber funktionierenden Version. Auch diese funktioniert nicht.

Danke...
0
aggi
aggi15.07.2001:36
So, ich mal wieder und das zum letzen mal für heute.....(ist ja noch lang! )
Ich habe es jetzt so eingespielt wie es in der eingebetteten Konfiguration von marcel151 steht.
Mal schauen, ob es so i.O. ist.

Gott sei Dank ist der Schlaf werbefrei......Gute Nacht!
+1
john
john15.07.2007:39
Ich finde meinen Weg am saubersten
ich moechte weder den dns server meines providers noch google noch cloudflare nach aufloesung fragen.
meine dns anfragen stelle ich selbst und direkt an die autoritativen nameserver mit meinem eigenen dns server (unbound, hyperlocal)
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
+1

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.