Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Netzwerke>FRITZ!Box 7490 schläfert Mac mini ein!?!

FRITZ!Box 7490 schläfert Mac mini ein!?!

Weia
Weia14.09.1502:13
Hallo an alle,

ich stehe vor einem extrem seltsamen Problem und wollte mal hören, ob das irgendjemandem hier bekannt oder nachvollziehbar vorkommt.

Mein alter Router ist abgerauscht und da die Telekom mich bald auf IP-Telefonie zwingen wird und ich dann einen S0-Anschluss für meine ISDN-Telefonanlage benötige, habe ich mich beim Neukauf für eine FRITZ!Box 7490 entschieden, die dieses Feature als einer von ganz wenigen Routen bietet.

Ich muss gestehen, dass ich diesem Produkt mit einem solch unsäglichen Namen, dem potthässlichen Design und der offensichtlichen Dummie-Zielgruppe mehr als skeptisch gegenüberstand, aber die Alternativen konnten alle noch weniger.

Leider bestätigen sich meine Vorbehalte von Tag zu Tag an etlichen Stellen mehr. Nun aber bin ich auf ein derart kurioses Phänomen gestoßen, dass ich vor einem Rätsel stehe:

Ich betreibe einen Mac mini (2011) mit Mountain Lion 10.8.5 als Heimkino-Rechner. Am Wochenende wollte ich den seit längerer Zeit erstmals wieder nutzen, weil ich endlich mal wieder Zeit hatte, einen Film zu gucken. Aus dem erhofften gemütlichen Filmabend wurde aber nichts, weil der Mac mini alle paar Minuten (zwischen 3 und 15) in den Schlaf fiel, obwohl gerade ein Film lief oder ich anderen Aktivitäten nachging. Natürlich dachte ich zunächst an ein SMC- oder NVRAM-Problem des Mac mini oder ein Konfigurationsproblem in den Energiespar- oder Netzwerkeinstellungen von OS X. Aber alle einschlägigen Maßnahmen, Resets etc. änderten überhaupt nichts.

Bei näherer Betrachtung fiel auf, dass zwar der Videoprojektor kein Videosignal mehr bekam und Remote Desktop auf einem anderen Mac anzeigte, der Mac mini sei in den Ruhezustand gegangen, der Lüfter des Mac mini im vermeintlichen Ruhezustand aber noch lief und auch die Front-LED nicht pulsierte wie im Ruhezustand üblich, sondern nach wie vor kontinuierlich leuchtete. Die üblichen Möglichkeiten zum Aufwecken aus dem Ruhezustand funktionierten aber alle wie bei einem tatsächlichen, vollständigen Ruhezustand.

Wie auch immer, eine Nutzung des Mac mini war vollkommen unmöglich, und nach stundenlanger Fehlersuche war ich mit meinem Latein am Ende.

Dann fiel mir auf, dass dies mein erster Betrieb des Mac mini nach Erwerb der FRITZ!Box war. Ich konnte mir zwar überhaupt keinen Zusammenhang vorstellen, aber weil mir absolut nichts anderes mehr einfiel, klemmte ich die FRITZ!Box vom lokalen Netzwerk ab – und siehe da, das Problem war verschwunden!

Aber jetzt habe ich eigentlich nur noch vor Augen:
  • Wie zum Teufel kann ein Router einen Mac überhaupt in den Ruhezustand „zwingen“, selbst inmitten reger Aktivität des Macs? Es gibt Wake-On-LAN, aber doch nicht Sleep-On-LAN …
  • Was hat es mit diesem „halben Ruhezustand“ auf sich, in dem Display-Ausgang und Remote-Desktop-Status den Ruhezustand indizieren, zumindest Front-LED und Lüfter aber nicht?

Ich stehe wirklich vor einem Rätsel und wäre daher an jeder Idee interessiert, was es mit all dem auf sich haben könnte.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0

Kommentare

Weia
Weia15.09.1522:17
MacRudi
Mit anderen OS X hattest Du aber nicht ausprobiert?
Nö, weil ich wegen Front Row eben eigentlich an Mountain Lion „klebe“. Hätte sich das Problem durch die neuen Switches aber nicht erledigt, wäre das sicher der nächste Schritt geworden. Gottseidank ist er mir erspart geblieben.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
john
john15.09.1522:54
Weil es wie schon gesagt gar keine höherwertige Alternative dazu gibt (wenn man wie ich einen S0-Anschluss braucht).
so so. ich behaupte doch. evtl tatsächlich nicht im consumerbereich. kein plan.
aber als "experte von berufswegen" dürftest du dich doch eigentlich auch darüber hinaus auskennen.
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
0
Weia
Weia15.09.1523:07
john
Weil es wie schon gesagt gar keine höherwertige Alternative dazu gibt (wenn man wie ich einen S0-Anschluss braucht).
so so. ich behaupte doch.
Ich bin ganz Ohr.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
john
john15.09.1523:10
lancom.
der 1781vaw zb.
irgendwas um die 600€ glaub ich
gibt auch schicke rackhalterungen für den serverschrank.
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
0
Weia
Weia15.09.1523:31
john
lancom.
der 1781vaw zb.
1:0 für Dich.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
steinb_i16.09.1500:09
Was für Kabel sind denn zwischen FritzBox und Netgear Router verwendet worden? Hatte hier ein ähnliches Problem was nur auftauchte wenn zwischen beiden ein schlechtes und langes Kabel hing.
0
Weia
Weia16.09.1500:59
steinb_i
Was für Kabel sind denn zwischen FritzBox und Netgear Router verwendet worden? Hatte hier ein ähnliches Problem was nur auftauchte wenn zwischen beiden ein schlechtes und langes Kabel hing.
Beim einen Netgear-Router waren es ca. 30 m, beim anderen nur 4 m.

Die größte Strecke davon festverlegt (Neubau 2011, ich hoffe doch, dass der Elektriker ordentliches Kabel verwendet hat; der Auftrag war für 1 GBit/s spezifiziert).

Aber mit den D-Link-Switches funzt es ja wunderprächtig.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
Hannes Gnad
Hannes Gnad16.09.1501:27
Kann man an den Netgear-Switches eventuell ein Firmware-Update einspielen?
0
Weia
Weia16.09.1506:24
Hannes Gnad
Kann man an den Netgear-Switches eventuell ein Firmware-Update einspielen?
Wäre mir nicht bekannt; solche einfachen Switches sind ja praktisch „black boxes“, mit denen Du nicht interagieren kannst.

Abgesehen davon meine ich ja nach wie vor, dass es die FRITZ!Box ist, die das Firmware-Update bräuchte – mit diversen Routern außer der FRITZ!Box funktionieren die Netgear-Switches ja. (AVM hat von mir einen Fehler-Log, vielleicht finden die ja was.)
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
steinb_i16.09.1508:34
Joa, also bei 4m sollte es eigentlich auch egal sein. Aber du kannst ja aus Spaß mal schauen ob ein kurzes patchkabel zwischen FritzBox und Switch funktioniert.
0
MikeMuc16.09.1509:38
Defekte Netgearswitche soll es ja schon öfters gegeben haben. Gerne auch im Dutzend
Aber dachten wir nicht alle das du da was "größeres" dran hast, in deiner professionelle Umgebung 😇
Die wirkliche Ursache werden wir wohl leider nie erfahren weil das wohl nur Netgear, AVM und Apple unter sich wirklich klären können was da nun wirklich passiert ist
0
Weia
Weia16.09.1510:21
MikeMuc
Defekte Netgearswitche soll es ja schon öfters gegeben haben. Gerne auch im Dutzend
Wieso defekte Netgear-Switches? Die funktionieren wunderbar mit 3 Routern, nur mit dem 4., der FRITZ!Box, nicht. Ich würde immer noch sagen, das deutet auf die FRITZ!Box als Problemverursacher.
Aber dachten wir nicht alle das du da was "größeres" dran hast, in deiner professionelle Umgebung 😇
Bloß weil ich IT-Profi bin, muss ich in meiner Privatwohnung jetzt keine superschweren Geschütze auffahren.
Die wirkliche Ursache werden wir wohl leider nie erfahren weil das wohl nur Netgear, AVM und Apple unter sich wirklich klären können was da nun wirklich passiert ist
Das steht zu befürchten. Ich werde aber noch ein paar Tage ein Auge drauf haben …
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
MikeMuc16.09.1511:31
Auch halt mal nach Netgear und defekten Switches und die wirst feststellen das du weder allein noch der Erste damit bist.
Und nur weil du auf den ersten Blick keinen Fehler erkennen kannst / willst heißt das nich das da nicht doch auch was im Argen liegen kann. Kann ja sein das der Fehler nur im Zusammenspiel mit einer FB unter bestimmten Bedingungen (wie bei dir) auftritt.
Oder arbeitest du bei Netgear und kannst das definitiv ausschließen weil du die "Innereien" deiner Netgears überprüft hast?
0
john
john16.09.1511:36
hochprofessionelle infrastruktur, aufgezäumt von berufsexperten und dann switches aus dem supermarkt und wenn was nicht funktioniert hat definitiv der router schuld... klingt wie die alte firma, für die ich mal gearbeitet habe
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
0
FritzS16.09.1512:11
Weia
Das einzige, was sich mit dem Abstecken der FRITZ!Box auch ändert, ist also das Fehlen der Internetverbindung. Aber warum sollte eine Internetverbindung zu dem beschriebenen Problem auf dem Mac mini führen? Solange ich einen anderen Router als die FRITZ!Box benutzte, tat sie das ja auch nicht.

Ist beim MacMini DHCP eingestellt oder hat er eine fixe IP?

PS: Das hat sich nun wohl erledigt ....

Da ich auch NETGEAR Switches verwende ist das auf jeden Fall 'im Hinterstübchen zu merken'
0
Weia
Weia16.09.1513:48
MikeMuc
Auch halt mal nach Netgear und defekten Switches und die wirst feststellen das du weder allein noch der Erste damit bist.
Und nur weil du auf den ersten Blick keinen Fehler erkennen kannst / willst heißt das nich das da nicht doch auch was im Argen liegen kann. Kann ja sein das der Fehler nur im Zusammenspiel mit einer FB unter bestimmten Bedingungen (wie bei dir) auftritt.
Das ist logisch doch einfach unsinnig. Wie der Geisterfahrer, der sich wundert, warum alle anderen verkehrt herum fahren.

Zu einer Inkompatibilität gehören immer zwei, das ist klar.

Aber wenn Gerät A mit etlichen Geräten B funktioniert, nur mit einem Gerät B nicht, wie kann man dann sagen, dass Gerät A Schuld hat? Zuallermindest sind dann doch alle funktionierenden Geräte B offenbar fehlertoleranter als das eine, mit dem es nicht funktioniert, und zumindest in diesem Sinne ist dieses Gerät B dann sehr wohl der Verursacher.

Wenn wir genaue Fehlerprotokolle hätten und einen vorgegebenen Standard, dem alle Geräte genügen müssen, dann könnte es im Extremfall so sein, dass Gerät A diesem Standard nicht genügt, alle Geräte B bis auf eines das aber tolerieren können. Dann könnte man in einem gewissen Sinne zumindest sagen, Gerät A sei schuld.

Aber das ist hier nicht der Fall – wir haben diese Fehlerprotokolle nicht. Und dann ist es bei dieser Kombination von Testergebnissen einfach unsinnig, von der Annahme auszugehen, Gerät A (der Netgear-Switch) sei schuld.
john
hochprofessionelle infrastruktur, aufgezäumt von berufsexperten und dann switches aus dem supermarkt und wenn was nicht funktioniert hat definitiv der router schuld...
Der logisch-kombinatorischen Überlegung, wer angesichts der Testergebnisse der Verursacher ist, ist es aber völlig Wurscht, ob die Switches aus dem Supermarkt sind – im übrigen, der Router ist auch aus dem Super(Media)Markt …

Und jetzt höre bitte mal auf, auf der „hochprofessionellen Infrastruktur“ herumzureiten – wie oft soll ich noch sagen, es geht um eine Privatwohnung mit vielleicht 15 Netzwerkgeräten und ohne irgendwelche nach meinem Verständnis besonderen Ansprüche, was das Netzwerk betrifft. Da sollten solche Geräte sehr wohl funktionieren, finde ich. Abgesehen davon, der WAN-Anschluss ist ein TDSL-Business-Anschluss, und der Router, den mir die Telekom von sich aus dafür hinstellen wollte, der war ganz sicher noch supermarktiger.

Ich kann in diesem Fall nur zwei Verdächtige entdecken – die FRITZ!Box, denn nur mit ihr tritt das Problem überhaupt auf, und den Mac mini, denn eigentlich sollte ein Mac nicht urplötzlich erratisch in Schlaf fallen, ganz egal, was im Netzwerk gerade abgeht. Der einzige rundum Unschuldige ist aus meiner Sicht der Netgear-Switch.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
Weia
Weia16.09.1513:50
Ist beim MacMini DHCP eingestellt oder hat er eine fixe IP?
Beides. DHCP mit fester IP-Adresse. Ich hatte aber auch manuelle Konfiguration ohne DHCP ausprobiert, hatte nichts geändert.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
john
john16.09.1513:54
mit supermarkt meinte ich tatsächlich supermarkt. oder "lebensmitteldiscounter" oder wie auch immer der fachlich korrekte terminus ist.. keine ahnung.
Und jetzt höre bitte mal auf, auf der „hochprofessionellen Infrastruktur“ herumzureiten
na du warst es doch dem es mehrfach wichtig war klarzustellne, dass er ein absoluter auskenner und oberprofi ist.
Ich kann in diesem Fall nur zwei Verdächtige entdecken – die FRITZ!Box, denn nur mit ihr tritt das Problem überhaupt auf
dann weiss ich nach wie vor nicht wieso wir uns hier die xte runde im kreis drehen und du nicht einfach die eingekreiste fehlerquelle eleminierst.
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
0
Weia
Weia16.09.1513:57
john
mit supermarkt meinte ich tatsächlich supermarkt.
Aber da sind die Switches nun wiederum nicht her …
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
john
john16.09.1513:59
Weia
john
mit supermarkt meinte ich tatsächlich supermarkt.
Aber da sind die Switches nun wiederum nicht her …

da sind sie aber zu finden. zwischen dem ultraergonomischen gelmauspad von hama und dem tipp-ex der "schreibwarenabteilung".
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
0
Weia
Weia16.09.1514:04
john
Was es in Deinem Supermarkt alles gibt …
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
john
john16.09.1514:10
Weia
john
Was es in Deinem Supermarkt alles gibt …
sofern du zugang zu einem real oder famila hast, dürfte es das auch in deinem geben.
bei anderen weiss ichs nicht. noch nie drauf geachtet.
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
0
Weia
Weia16.09.1514:14
john
sofern du zugang zu einem real oder famila hast, dürfte es das auch in deinem geben.
Ich kauf ab und an Lebensmittel beim real ein, aber es hat mich dort noch nie in die „Schreibwarenabteilung“ verschlagen – muss ich mal drauf achten.
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
Peacekeeper2000
Peacekeeper200018.09.1510:28
Ich will jetzt hier nicht für AVM eine Lanze brechen, weil die z.B. die Domain fritz.box. in keiner Doku erwähnen und ich hatte auf FreeBSD Ebene das gleiche Problem wie Du. Hab auch schon mal als VB eingereicht, dass man die Domain ändern können sollte.

ABER, ich habe HP Switches (unterschiedlicher Generationen) und die Box, da gibt's auch keine Probleme. Wenn es bei Dir mit den D-Link Switches und der Box funktioniert, aber mit Netgear nicht, dann liegt's wohl eher an den Netgear switches. Da wird wohl auf der Switch Ebene was ge-trunct. Die Fritzbox hat eben nur den Fehler sichtbar gemacht.

Vermutlich liegt's aber neben den Switches auch am Mac Mini mit der alten Software ( mDNSResonder)
0
Peacekeeper2000
Peacekeeper200018.09.1510:33
Oh, bezgl. des DNS der Fritzbox und UX. Du musst eben immer full-qualified hostnames angeben beim MTA, dann geht das sehr wohl mit dem DNS von der Fritz.box. ich habe allerdings als MTA den klassischen sendmail.
0
Weia
Weia18.09.1515:19
Peacekeeper2000
Ich will jetzt hier nicht für AVM eine Lanze brechen, weil die z.B. die Domain fritz.box. in keiner Doku erwähnen und ich hatte auf FreeBSD Ebene das gleiche Problem wie Du.
Ärgerlich ist daran vor allem auch, dass dieses nicht abschaltbare DNS-Setting eigentlich ein Missbrauch der Suchdomain-Funktion ist, nur damit DAUs die FRITZ!Box gleich problemlos adressieren können.

Die normkonforme Lösung hierfür wäre mDNS. Jedes kleine RaspberryPi- oder Arduino-Board kann das, da sollte das auch die FRITZ!Box schaffen.
Wenn es bei Dir mit den D-Link Switches und der Box funktioniert, aber mit Netgear nicht, dann liegt's wohl eher an den Netgear switches. Da wird wohl auf der Switch Ebene was ge-trunct.
Diese Logik erschließt sich mir nach wie vor nicht angesichts der Tatsache, dass drei andere Router keinerlei Probleme mit den Netgear-Switches haben.

Aber ich sehe schon, ein Fehler, der bei AVM und nicht bei Netgear liegt, das geht irgendwie gar nicht …
Die Fritzbox hat eben nur den Fehler sichtbar gemacht.
Soooo kann man das natürlich auch formulieren … 
Vermutlich liegt's aber neben den Switches auch am Mac Mini mit der alten Software ( mDNSResonder)
Was den Koma-Schlaf betrifft, kann das gut sein. Was die 100 Mbit/s statt 1 GBit/s zwischen Router und Switch betrifft, eher weniger …
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
Weia
Weia18.09.1515:25
Peacekeeper2000
Oh, bezgl. des DNS der Fritzbox und UX. Du musst eben immer full-qualified hostnames angeben beim MTA, dann geht das sehr wohl mit dem DNS von der Fritz.box.
Nur geht das nicht mit meiner Mail-Konfiguration, die zunächst alle Mailadressen im lokalen Netzwerk als user@host.local adressiert für die lokale Kommunikation und erst bei Weiterleitung an den SMTP-Relay-Host ein Adress-Rewriting vornimmt. Denn host.local wird ohne Möglichkeit der Gegenwehr gnadenlos mit host.fritz.box überschrieben. (Also jedenfalls habe ich keine Möglichkeit der Gegenwehr gefunden ohne stundenlange Suche, auf die ich null Bock hatte. Da war es deutlich schneller, den DNS-Server der FRITZ!Box als DNS-Server in den OS-X-Netzwerkeinstellungen auszutragen.)
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.