Forum>Hardware>MacBook Pro 2009 – Batterie oder MagSafe-Stecker kaputt?

MacBook Pro 2009 – Batterie oder MagSafe-Stecker kaputt?

macblum07.11.1812:29
Moin,
ich habe hier ein älteres MacBook Pro (Mid 2009) eines Freundes, dass ich nochmal aufpäppeln möchte.

Hier gibt es ein kurioses Problem mit der Stromversorgung.
Laut System soll die Batterie gewartet werden, obwohl sie erst 580 Ladezyklen abbekommen hat (laut Apple sind wenigstens 1000 vorgesehen). Der Ladezustand ist bei 100%. Mein Freund hatte den Akku schon mal ausgetauscht, ohne dadurch eine Verbesserung zu erreichen.

Das eigentliche Problem ist nämlich dieses: das MacBook schaltet sich sofort ab, sobald man das MagSafe-Kabel zieht. Und ich meine sofort, als ob gar kein Akku eingebaut wäre!

Mein erster Tipp war natürlich auch ein neuer Akku (der ist ja immerhin auch schon ein paar Jahre alt), aber dann hätte der Batterietausch, den mein Freund schon mal durchgeführt hatte, zu einem Ergebnis führen müssen. Aber da war das Phänomen genau so: Stecker raus – Rechner aus!

Das Netzteil funktioniert grundsätzlich. Hier fällt mir nur auf, dass die Ladeanzeige im MagSafe-Stecker nicht nur grün oder orange zeigt, sondern auch mal ganz aus geht. Reproduzierbar war das aber nicht. Vielleicht ein Wackler?

Ich tippe nun auf die interne MagSafe-Ladebuchse.
(https://eustore.ifixit.com/Ersatzteile/MacBook-Ersatzteile/ Macbook-Pro/13/Unibody/Mid-2009/MacBook-Pro-Unibody-13-Model -A1278-and-15-Mid-2009-through-Mid-2012-MagSafe-DC-In-Board- Neu.html?utm_source=google&utm_medium=mc&utm_campaign=gshopp ing&gclid=CjwKCAiAt4rfBRBKEiwAC678Kair-J1cSI8TVligewRKNtmH_I 08TLKZCLg-uhK5qGuWDCRXrTueehoCE34QAvD_BwE).

Irgendwoher muss das MBP doch ein Signal bekommen, dass das Netzteil angeschlossen ist, bzw. dass es ansonsten auf den Akku umschalten muss. Und dieser Schalter muss doch in der Buchse vrbaut sein (evtl. magnetisch?). Leider ist das Kabel ganz, ganz unten verbaut und ein Tausch auf Verdacht ist mir zu aufwändig. Zumal könnte der Fehler ja auch auf dem Logic Board sein, dann wäre das ganze Gebastel umsonst.

Daher die Frage an Euch:
Ist das Problem bekannt? Welche Ursachen wären noch möglich? Habt ihr Tipps zur Fehlersuche/-behebung?

Danke,
macblum
0

Kommentare

Fucko07.11.1813:20
Also die Lade-LED ist am Stecker meines alten MBP-Netzteils auch ganz gerne einfach mal ausgegangen.
Und wenn die Kiste aus ist, dann kannst du auch nicht ohne Netzteil starten? Also schmiert er einfach beim kurzfristigen Wechsel von Netz zu Akku ab, oder liefert der Akku einfach null Saft?
0
Deichkind07.11.1814:14
Der interne MagSafe-Adapter leitet lediglich den vom Netzteil gelieferten Strom an das Mainboard weiter. Fünf Kontakte rein. Fünf Leitungen raus. Vier Leitungen übergeben paarweise Plus und Minus vom Netzteil an das Mainboard. Über die mittlere Leitung kommuniziert das Mainboard mit dem Netzteil und steuert es die LED im Stecker.

Die Frage ist, ob das Mainboard eine funktionierende Verbindung zur Batterie hat.

Was liefert denn der Befehl pmset -g rawbatt im Terminal?
Beispiel:
10/08/18 00:16:23
AC; Not Charging; 97%; Cap=7074: FCC=7244; Design=7150; Time=0:00; 0mA; Cycles=13/1000; Location=0;
Polled boot=10/07/18 16:19:44; Full=10/08/18 00:14:52; User visible=10/08/18 00:15:52

Prozentzahl = Cap/FCC * 100 %
Cap = aktueller Ladezustand (Restkapazität)
FCC = Kapazität, wenn vollgeladen.
Design = Designkapazität (serientypischer Wert des Batterietyps)

Der Prozentwert darf nicht über Tage hinweg bei 100 % stehen. Normal ist, dass der Wert nach dem Aufladen auch bei weiterhin angeschlossenem Netzteil langsam innerhalb von wenigen Tagen von 100 % auf 95 % abfällt, ehe der Ladevorgang wieder einsetzt.
0
macblum08.11.1819:27
Hallo,

der Rechner startet auch nicht ohne Netzkabel. Ich vermute, dass der Akku zwar Energie leifern könnte, die aber nicht ankommt. Das verraten zumindest die Werte.

Danke für den Tipp mit den Terminal-Befehlen. Ich checke das, wenn ich das Gerät wieder vor mir habe.
0
Konni08.11.1820:01
Also mein 2013 MacBook hat sich auch immer mir nichts dir nichts ausgeschaltet, Akku hatte grad mal 300 Zyklen, ist für teures Geld ein neues Mainboard reingekommen, letztendlich war auch nur der Akku defekt, zuletzt hat sich das Book sofort "ausgeschaltet" (also nix geordnetes runterfahen, also aus im Sinne von aus ), sobald der MagSafe Stecker mal keinen Kontakt hatte.

Ich würde daher vermuten Akku.
+1
macblum12.11.1813:03
Moin Konni,

ja, das dachte der Besitzer ja auch und hatte den schon mal getauscht. Aber das Problem blieb das gleiche. Okay, falls der Ersatzakku (sicher kein Original) Murks war, dann hätte man zweimal Pech gehabt. Der wurd in jedem Fall wieder zurückgebaut und zum Verkäufter geschickt ... da jetzt also wieder der alte Originale drin ist und der ja auch schon 10 Jahre als ist, kann es natürlich immer auch daran liegen. Ein Mainboard-Tausch kommt bei der alten Möhre natürlich nicht mehr in Betracht ... ich muss jetzt mal das Terminal befragen ... Danke.
0
Deichkind12.11.1813:37
Auf dem MacBook Pro von 2009 läuft wohl El Capitan? Bei diesem System stimmt der Prozentwert der Menüzeile mit jenem Prozentwert überein, den das Terminal meldet. Beginnend mit macOS Sierra meldete die Menüzeile einen geschönten Wert: "100 %", solange der Terminalwert über 94% lag. Auf dem MacBook Pro 2010 mit macOS 10.13.6 liefert die Menüzeile neuerdings (seit dem jüngsten Update?) wieder den wahren Wert. Das MacBook Air von 2014 zeigt mit demselben Systemstand dagegen weiterhin den geschönten Wert.

In dem Akkupaket des MacBook Pro von 2009 sind vermutlich zwei Li-Ion-Zellen in Serie geschaltet so wie im MacBook Pro von 2010. Damit ist bei angeschlossenem Netzteil eine Batteriespannung von 8100 bis 8500 mV zu erwarten. Den Wert erfährt man durch die Auflistung "Über diesen Mac/Systembericht/Stromversorgung".
0
virk
virk12.11.1813:49
Hat Dein Kumpel nach dem Akku-Tausch einen SMC-Reset gemacht. Eventuell (ich weiß das nicht) ist das nämlich erforderlich, um dem Rechner begreiflich zu machen, dass ein neuer Akku dranhängt?
„Schön fand ich damals: Auf die Dauer hilft nur Power!“
0

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.

OK MacTechNews.de verwendet Cookies unter anderem für personalisierte Inhalte, Seitenanalyse und bei der Auslieferung von Google-Anzeigen. Dies war zwar schon immer so, auf Wunsch der EU muss nun jedoch explizit darauf hingewiesen werden. Durch Nutzung der Website erklären Sie sich damit einverstanden. Weitere Informationen