Forum>Software>iMac Pro geht ständig in "Dark-Wake" – Wozu verdammt?

iMac Pro geht ständig in "Dark-Wake" – Wozu verdammt?

sonorman
sonorman18.11.1810:37
Sorry für die etwas gereizt klingende Überschrift, aber das ist hier eine Sache, die sich zur Never-Ending-Story entwickelt und die zum Teil echt lästig ist.

Seit ich den iMac Pro Anfang des Jahres bekommen habe, ist mir aufgefallen, dass dieser – abhängig von bestimmten Netzwerkparametern – alle paar Minuten, aber mindestens alle zwei Stunden, in den sogenannte "Dark Wake" geht.

Wenn man keine externen Festplatten oder andere extern angeschlossene Devices mit Statuslampen hat, würde man das gar nicht merken, weil der Bildschirm aus bleibt und auch die (sowieso fast unhörbaren) Lüfter den iMP nicht anlaufen. Während des ca. 2 Minuten andauernden Dark Wake geht die Energieaufnahme von knapp über 5W (Ruhezustand) auf über 50W hoch, was beinahe der Leistungsaufnahme im normalen Betrieb entspricht. Angeschlossene Festplatten fahren hoch. Wenn es sich um lautere Desktopplatten handelt, hört man also alle 2 Stunden irgend eine Platte anlaufen und eine Weile rattern. Andere Peripheriegeräte (z.B. meine Sonnet Fusion SSD) verraten die heimliche Aktivität des Mac durch ihre Status-LED.

Wer ebenfalls einen iMac Pro hat, und wem das noch nicht aufgefallen ist, der sollte mal im Terminal den Befehl

pmset -g log

eingeben. Ihr werdet höchstwahrscheinlich sehen, dass dort (während der Ruhezustand-Phasen) spätestens alle 2 Stunden eine der folgenden Meldungen auftaucht:
DarkWake from Normal Sleep [CDN] due to EC.RTC/Maintenance: Using AC (Charge:0%) 600 secs

oder
DarkWake from Normal Sleep [CDN] due to EC.WoL XGBE/Network: Using AC (Charge:0%) 600 secs

Die zweite Meldung taucht nur auf, wenn das WLAN am Router aktiv ist. (Nachts ist es bei mir aus.)

Als ich den iMP neu hatte, habe ich während der kostenlosen 90 Tage Supportzeit in zahlreichen Telefonaten versucht, das mit Apple zu klären. Die waren sehr bemüht, konnten mir aber letztlich keine Erklärung liefern. Es lief letztlich darauf hinaus, dass das halt so ist, wie es ist. Punkt.

Immerhin habe ich einige Dinge dazu herausgefunden:

  • 1. Die angeschlossene Peripherie hat NICHTS damit zu tun. Ich kann alles abstöpseln und es passiert trotzdem.
  • 2. Meine macOS-Installation und meine Programme haben NICHTS damit zu tun. Es passiert auch mit einem jungfräulichen System.
  • 3. Systemeinstellungen, die dafür verantwortlich sein könnten, haben NICHTS damit zu tun. Also Wake on Lan, Power Nap etc. – Alles aus!
  • 4. Die Häufigkeit der Dark-Wake-Vorgänge hängt mit der Netzwerkverbindung zusammen. Mit aktiviertem WLAN passiert es unregelmäßig, manchmal alle 10-15 Minuten. Schaltet man WLAN vor dem Ruhezustand aus und hat nur das LAN-Kabel mit dem Router verbunden, passiert es nur alle 2 Stunden. Auch wenn der Router wie bei mir nachts das WLAN per Zeitschaltung ausschaltet, verringert sich die Frequenz auf alle zwei Stunden.
  • 5. Nur wenn man WLAN ausschaltet UND das LAN-Kabel abzieht, bleiben die Dark Wakes aus!
  • 6. Auch andere Sachen, wie verschiedene Einstellungen des T2-Chip, konnte ich schon als Verursacher ausschließen.

Die einzige Sache, die ich noch nicht testen konnte, ist, ob das auch mit anderen Routern als der Firtz!Box (hier 7490) passiert. Hier könnten gerade die iMP-User mit anderen Routern behilflich sein und mal mit dem obigen Terminal-Befehl nachsehen, ob es regelmäßig Dark Wake Ereignisse gibt.

Es ist natürlich nicht besonders praktisch, jedes Mal das LAN-Kabel abziehen zu müssen, bevor man den Mac schlafen legt. WLAN habe ich schon standardmäßig ausgeschaltet, um die Dark-Wake-Ereignisse auf alle 2 Stunden zu begrenzen. Aber das ist auch doof, weil man WLAN unbedingt für Hand-Off-Funktionen oder AirDrop benötigt. Dafür muss ich es dann immer manuell einschalten und darf nicht vergessen, es anschließend wieder zu deaktivieren. Auf LAN abstöpseln verzichte ich und finde mich mit Dark Wakes alle 2 Stunden ab.

Das alles ist trotzdem irgendwie suboptimal und so ziemlich das Einzige, was mich am iMac Pro stört. Ansonsten ist das eine richtig tolle Maschine.

Die Frage ist also: Was zum Teufel soll dieser blöde Dark Wake?? Und: Kann man das nicht doch irgendwie auf praktische Weise verhindern?

Ich hoffe hier eigentlich nicht auf eine echte Lösung. Das habe ich inzwischen aufgegeben. Aber vielleicht finden sich ja zumindest noch ein paar Antworten, was der Mac im Dark Wake eigentlich genau macht und wozu dafür externe Festplatten etc. anspringen müssen.

Ansonsten allen erst mal einen schönen Sonntag! – Winter is coming!
+1

Kommentare

Deichkind18.11.1811:14
Mehr dazu liefert vielleicht das komplette Protokoll der auf das Gerät bezogenen Meldungen in der Konsole. Vermutlich genügt es, die Konsole kurz vor dem Herunterfahren zu öffnen und zu minimieren, um eine Fortsetzung der Berichterstattung in das Konsolenfenster zu erzwingen. Ich habe selbst aber keine Erfahrung mit diesem Vorgehen. Falls nicht, helfen vielleicht die bei Heise Mac & I genannten Methoden zum Zugriff auf vergangene Protokolle: .

Auch mein (altes) MacBook Air erlebt "Dark Wake"-Momente, allerdings wohl in Intervallen, die größer als zwei Stunden sind.
0
Deichkind18.11.1812:23
Jemand bei Ask Different (StackExchange) beobachtet einen Zusammenhang zwischen "EC.RTC/Maintenance" und "Find My Mac": . Inklusive dem Zwei-Stunden-Intervall.
0
sonorman
sonorman18.11.1812:36
Deichkind
Danke, das werde ich mal checken!

Was mir eben aufgefallen ist: Nach dem letzten macOS-Update hat mir Apple heimlich wieder die Funktion „Wake on Bluetooth“ aktiviert! (Systemeinstellungen > Bluetooth > Weitere Optionen) Das war vorher 100% sicher ausgeschaltet.


Früher kam es auch häufig vor, dass nach einem Update die Einstellungen „Energie“ verändert waren. Daher habe ich nach dem letzten Update nur diese überprüft, aber nicht Bluetooth.
0
sonorman
sonorman18.11.1812:46
Toll. Gerade eben ist er schon wieder in DarkWake gegangen. Trotz ausgeschaltetem Find my Mac u.s.w. Und aus irgend einem unerfindlichen Grund dauern die Dark-Wake-Zyklen seit gestern deutlich länger als sonst.
0
sonorman
sonorman18.11.1812:53
Und schon wieder! Jetzt dreht der völlig durch.
0
Schnitter
Schnitter18.11.1813:01
Das hier schon gelesen?

Abhilfe: Ein USB-Ethernet-Adapter. Wäre einen Versuch wert.
„Jeder ist ein Planet und wird von einem Menschen bewohnt.“
0
Peter Eckel18.11.1813:13
Aus Deiner Beschreibung geht auf jeden Fall hervor, daß das Aufwachen des Rechners in unmittelbarer Verbindung mit dem Netzwerk steht. Kein Netzwerk - kein Dark Wake.

Das ist schon mal ein Ansatzpunkt. Es stellt sich also die Frage, was auf dem Netz passiert, wenn ein Dark Wake erfolgt. Mein erster Ansatz wäre es also, mit einem Netzwerk-Analysetool zu schauen, was da im fraglichen Moment übers Netz geht.

Das ist relativ einfach, wenn man einen geeigneten Router oder Switch hat, der es ermöglicht, einen Mirror- oder Monitor-Mode einzuschalten (dabei wird der gesamte Netzwerkverkehr eines Ports auf einen anderen gespiegelt). Einige Fritzboxen scheinen das zumindest auf einem Umweg zu können:

Die Analyse der Daten erfolgt in beiden Fällen (Mirror-Port und Datenmitschnitt der FB) mit Wireshark. Im ersten Fall hängt man einen Rechner an den Mirror-Port und schaut sich die Daten live an, im zweiten öffnet man die von der Fritzbox erhaltene Datei damit.

Eine Alternative wäre ein Tap, aber das ist bei Gigabit-Ethernet ziemlich teuer - wobei für den Test auch ein vorübergehender Downgrade auf 100 MBit zu verschmerzen ist. Bauanleitung z.B. hier: . Wieder kommt ein Rechner mit Wireshark an den Tap-Port.

Was natürlich immer noch dabei herauskommen kann ist, daß die Verbindung vom Mac Pro ausgeht und halt nur passiert, wenn er eine Netzwerkverbindung hat. Dann kannst Du dem Protokoll aber zumindest entnehmen, mit wem er da spricht - das kann bei der Suche ja auch schon helfen.
0
sonorman
sonorman18.11.1813:22
Schnitter
Das hier schon gelesen?

Abhilfe: Ein USB-Ethernet-Adapter. Wäre einen Versuch wert.
Hmm, mal sehen was passiert, wenn ich das LAN-Kabel an mein Thunderbolt-Dock anschließe. Derzeit habe ich es direkt am Mac.

Im Moment ist da echt der Wurm drin. Über die Logs wird mir der Grund ja auch genannt, nur ist der meist zu kryptisch und/oder zu vage. Zum Beispiel wie eben gerade:
DarkWake from Normal Sleep [CDN] due to XHC1/: Using AC (Charge:0%) 75 secs



Ich bin kurz davor, den Ruhezustand komplett aufzugeben und den Mac stattdessen immer herunter zu fahren. Das dauert zwar etwas länger und hat ein paar andere Nachteile, aber für die Zeit, die ich jetzt schon in die Ursachenforschung investiert habe, könnte ich den Mac wahrscheinlich tausend mal runterfahren und neu booten.


Neuer Versuch: Ich lege in JETZT (13:27) schlafen (LAN steckt jetzt am Thunderbolt-Dock). Mal sehen, wann der nächste Dark Wake kommt…
0
sonorman
sonorman18.11.1813:57
13:57 Uhr: Dark Wake.
0
McErik18.11.1814:03
Bei mir wacht mein MBP genauso immer kurzzeitig auf. Es liegt also wohl nicht am Gerätetyp.
Gemerkt hatte ich es zunächst, als ich vergessen hatte, Theine auszuschalten. Dann wacht der Mac nämlich richtig auf und schläft nicht wieder ein. Etwa alle 2 Stunden!
Ich habe genau auch die Fritzbox 7490. Aber wenn das WLAN vom Airport Extreme kommt, ist es genauso.
Einmal beobachtete ich zufällig, dass ich auf dem ansonsten dunklen Bildschirm die Mitteilung bekam, dass das Passwort zu einem E-Mail-Account nicht bestätigt wurde. Das Verrückte daran, dass mein Mac im Ruhezustand gar keine Mails empfängt. Er scheint aber ab und zu schon mal nachzufragen, ob er denn könnte, wenn er denn dürfte. Ziemlich verrückt!
Ich weiß gar nicht, seit wann das so ist. Ich hatte es Apple auch schon als Fehler gemeldet.
Ich fahre meinen Rechner jetzt öfter herunter. Das mit der langen Startzeit ist wenigstens verschwunden (oder deutlich seltener?)!
0
sonorman
sonorman18.11.1814:15
Während des letzten Dark Wake habe ich einfach mal das Netzwerkkabel abgezogen. Die externe Festplatte hat daraufhin 10 Min. wie bekloppt rumgerödelt. Nun ist sie aus und auch die LED an der SSD ist aus. Er schläft. Mal sehen, ob er jetzt – ganz ohne Netzwerkverbindung – auch wirklich Ruhe gibt.
0
Whip18.11.1814:20
Ich drück die Daumen..... Bei sowas (Fehler suchen und nicht finden) kann man verrückt werden
0
FelixE18.11.1814:40
Hallo Sonorman,
das Problem kenne ich von meinem MacMini 2012: abends startete die Backup Festplatte in regelmäßigen Abständen mit dem typischen, mich störenden Geräusch. Nachdem meine Versuche dem Mac das Aufwachen abzugewöhnen erfolglos blieben habe ich mir folgendermaßen beholfen: die Festplatte abends unmounten und morgens wieder mounten. Das ist einerseits etwas unbefriedigend andererseits ist damit Ruhe.
0
dam_j
dam_j18.11.1815:00
Ich kann dieses Verhalten nur 1:1 von meinem MacMini 2018 und meinem Hackintosh bestätigen.

Störend aber für mich nicht behebbar...
„Das Leben ist Scheiße aber die Grafik ist geil !“
0
chb18.11.1817:58
Ich meine mal wo gelesen zu haben, dass es mit der Lease-Dauer der IP-Adresse zu tun hat. Der Mac versucht nach der halben Lease Zeit die IP-Adresse zu erneuern.
Versuch mal in deinem Router/DHCP-Server die Lease-Dauer auf eine Woche oder mehr zu stellen. (Oder alternativ die IP-Adresse fix vergeben)
0
sonorman
sonorman18.11.1818:27
Also ich will das heute Abend noch mal beobachten, aber seit dem das Netzwerkkabel ab ist, gab‘s bis jetzt auch keinen Dark Wake mehr. Es muss also tatsächlich mit dem Netzwerk zu tun haben.
chb

Versuch mal in deinem Router/DHCP-Server die Lease-Dauer auf eine Woche oder mehr zu stellen. (Oder alternativ die IP-Adresse fix vergeben)
Das sagt mir jetzt nichts. Muss ich mal nachforschen, ob ich da a der FritzBox was drehen kann.

Peter Eckel
Das ist auch nicht so ganz meine Baustelle, aber ich werde mich mal einlesen. Danke!

Den Power-Logs nach zu urteilen ist es wohl eine vom Mac ausgehende Aktion, weil da meistens steht „due to Maintanance …“. Die Frage ist nur, warum der überhaupt andauernd im Ruhezustand was machen muss. Kann der nicht einfach mal die Füße still halten?
+1
sonorman
sonorman18.11.1818:35
chb
Hab mal schnell gegoogelt und nachgesehen: Die Gültigkeit der IPv4-Adressen ist in der Fritzbox standardmäßig auf 10 Tage eingestellt.
0
shadow_2_
shadow_2_18.11.1818:49
Wie siehts aus mit Energie-Settings =>
"Wenn möglich Ruhezustand für Festplatten aktivieren"
und
"Ruhezustand bei Netzwerkzugriff beenden"
0
sonorman
sonorman18.11.1818:58
shadow_2_
Wie siehts aus mit Energie-Settings =>
"Wenn möglich Ruhezustand für Festplatten aktivieren"
und
"Ruhezustand bei Netzwerkzugriff beenden"
Wenn‘s sooo einfach wäre…
Siehe auch den Anfangsbeitrag.
0
Weia18.11.1818:59
sonorman
Ich hoffe hier eigentlich nicht auf eine echte Lösung.
Es gibt prinzipiell sehr wohl eine „echte“ Lösung im Sinne eines genau dafür vorgesehenen Eintrags in der entsprechenden Konfigurationsdatei; es gibt halt keine GUI dafür, und Du kannst die Datei auch nur verändern, nachdem Du die System Integrity Protection ausgeschaltet hast (kannst Du nach Beendigung des Editierens der Konfigurationsdatei ja wieder einschalten, wenn Du willst).

Datei und Eintrag lauten:

/Library/Preferences/SystemConfiguration/com.apple.Boot.plis t:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel Flags</key>
<string>darkwake=0</string>
</dict>
</plist>


Ich hatte Dir das vor Monaten schon mal geschrieben, hast Du das denn nicht gemacht? In Deinem neuen Beitrag oben erwähnst Du nichts davon.

Ich kenne keinen Mac – iMac Pro und Mojave eingeschlossen – der daraufhin das zweitstündliche Aufwachen nicht einstellt. Wenn Dein iMac Pro das nicht tut, dann scheint da etwas ganz Spezifisches verhunzt zu sein.

PS: das Leerzeichen am Ende des Plist-Pfades setzt die Forensoftware ein, warum auch immer.
+7
sonorman
sonorman18.11.1819:35
weia

Oh sorry, da hab ich wohl tatsächlich irgendwas verpennt.

Ich probiere das morgen gleich mal aus. Irgendwelche anderen Probleme im Betrieb dürfte sich dadurch ja eigentlich nicht ergeben. Aber mal schaun.

Danke jedenfalls für den Tipp!
0
Weia18.11.1819:47
sonorman
Irgendwelche anderen Probleme im Betrieb dürfte sich dadurch ja eigentlich nicht ergeben.
Nein, tun sie nicht. Es ist schließlich kein Workaround, sondern schlicht der offizielle Ausschalter für das, was Du ausschalten willst.
+1
sonorman
sonorman18.11.1820:15
So, ich habe mich doch noch mal schnell an den Mac gesetzt und die plist wie beschrieben editiert – wobei ich hoffentlich nichts falsch gemacht habe:


Jetzt wird der Mac schlafen gelegt…
+1
SPmaniac
SPmaniac19.11.1806:45
@ dam_j
Beim Hackintosh kann man darkwake=0 mit einem Häkchen im Clover Configurator einstellen. Danach war bei mir Ruhe und er schläft nachts schön durch
0
Weia19.11.1806:49
sonorman
Jetzt wird der Mac schlafen gelegt…
Ich hoffe, Du hast zuvor einen Neustart gemacht – com.apple.Boot.plist wird, wie der Name schon sagt, nämlich nur beim Booten gelesen.
+3
sonorman
sonorman19.11.1809:34
Weia
sonorman
Jetzt wird der Mac schlafen gelegt…
Ich hoffe, Du hast zuvor einen Neustart gemacht – com.apple.Boot.plist wird, wie der Name schon sagt, nämlich nur beim Booten gelesen.
Ja, ich habe vorher einen Neustart gemacht, um die System Integrity Protection auszuschalten. Dann habe ich die Änderung vorgenommen, anschließend einen weiteren Neustart gemacht um System Integrity Protection wieder einzuschalten. Und siehe da: es funktioniert!

Also besten Dank noch mal dafür. Keine Ahnung, wie ich das letztes Mal übersehen konnte.

Jedenfalls hat der Mac von gestern 20:17 Uhr bis heute Morgen – trotz LAN-Verbindung und aktiviertem WLAN – keinen einzigen Dark Wake gehabt und in diesem Zeitraum auch keine Meldungen in den Logs! – Ich bin begeistert.

Er kam heute morgen beim Aufwecken ein wenig langsamer in die Puschen, also sonst. Bis der Bildschirm an war und ich mich einloggen konnte, hat es so ca. 10 Sekunden gedauert. Mal sehen, wie sich das die nächsten Tage so verhält.

Und einen Wermutstropfen hat die Sache insofern, als dass nicht geklärt ist, warum Apple diese Dark Wakes eigentlich will und was da genau da passiert. Aber das kratzt mich keinesfalls so sehr, wie diese dämlichen Dunkelstarts.
+2
Peacekeeper2000
Peacekeeper200019.11.1810:40
Ich habe hier das problem nicht (und habe auch nichts gepatched). Ich habe auch eine FritzBox (7590) und das LAN ist ständig drann. Einzig per Bluetooth wurde der Dark Wake aufgerufen - den Haken im Kontrollfeld hatte und habe ich noch. Diese Bluetooth Dar Wakes kamen vom iPhone. Dass hatte ich zum Energiesparen kürzlich von Bluetooth genommen und schon kamen auch diese Dark Wakes nicht.

Die erste Meldung ist wohl eine RealTimeClock (RTC) und du holst z.B. die Zeit aus dem Internet per ntp. Ich hole die Zeit von der FritzBox die als NTP Server dient. Eventuell hast Du da was direktes eingetragen ? Wobei das bei mir auch manchmal vorkommt ( aber sehr selten).

Deine zweite LogMeldung ist ja ein Wake-On-Lan und damit klar, dass irgen etwas WOL Pakete schickt. DIe Fritzbox kann das auch machen. (Unter Details kann man da ein Häckchen setzen, dass der Rechner startet sobald aus dem Internet ..... ) Eventuell hast du da was sitzen ?
Oder im Netzwerk ist ein NAS/Server - der dir das WOL schickt ?
0
sonorman
sonorman19.11.1810:56
Peacekeeper2000
… Eventuell hast Du da was direktes eingetragen ? Wobei das bei mir auch manchmal vorkommt ( aber sehr selten).
In den Systemeinstellungen habe ich unter "Datum und Uhrzeit" time.euro.apple.com als Timeserver angehakt. In der Fritzbox habe ich eingestellt, dass diese als Zeitserver im Heimnetz fungieren soll. Vielleicht gibt es da tatsächlich einen Konflikt.
Deine zweite LogMeldung ist ja ein Wake-On-Lan und damit klar, dass irgen etwas WOL Pakete schickt. DIe Fritzbox kann das auch machen. (Unter Details kann man da ein Häckchen setzen, dass der Rechner startet sobald aus dem Internet ..... ) Eventuell hast du da was sitzen ?
Nein. Ist nicht angehakt.
Oder im Netzwerk ist ein NAS/Server - der dir das WOL schickt ?
Nope.

Na jedenfalls ist das Problem jetzt mit abgeschalteten Dark Wake so oder so Geschichte. – Hoffe ich.
0
aqua01
aqua0119.11.1812:02
Betreffend des schnellen Aufwachens: Mein iMac (ohne Pro) ist sofort da, wenn ich die Powertaste drücke. Wenn ich hingegen eine Taste auf der Tastatur betätige, dauert es auch einige Sekunden bis er da ist.
War nicht immer so, und warum das so ist weiß ich nicht. Kannst aber bei dir auch ausprobieren, ob das einen Unterschied macht.
0
sonorman
sonorman19.11.1812:17
aqua01
Danke, das mache ich!

PS: Meine Sonnet Fusion SSD verfügt über eine Status-LED, die dem iMac ja fehlt. Daran kann ich sehen, dass der Mac nicht immer gleich beim ersten Versuch mit BT-Tastatur reagiert. Manchmal erst beim zweiten oder dritten mal Taste drücken. Aber auch wenn die LED an geht, dauert es manchmal noch ein paar Sekunden, bis der Bildschirm da ist. Mal sehen, wie die Reaktion aussieht, wenn ich die Powertaste drücke.
0
Weia19.11.1814:54
sonorman
Und siehe da: es funktioniert!

Also besten Dank noch mal dafür. Keine Ahnung, wie ich das letztes Mal übersehen konnte.
Wenn ich das richtig mitbekomme, hättest Du dir da eine Menge Zeit und vor allem Nerven sparen können.
Jedenfalls hat der Mac von gestern 20:17 Uhr bis heute Morgen – trotz LAN-Verbindung und aktiviertem WLAN – keinen einzigen Dark Wake gehabt
Wenn der Dark Wake ausgeschaltet ist, ist er eben ausgeschaltet.
Und einen Wermutstropfen hat die Sache insofern, als dass nicht geklärt ist, warum Apple diese Dark Wakes eigentlich will und was da genau da passiert.
Auch das ist bekannt. Der zwingende ursprüngliche Grund für den Dark Wake ist, dass Apple wollte, dass Macs bei Netzwerkzugriff nicht nur über LAN, sondern auch über WLAN auf Wunsch aufgeweckt werden können. Aufgrund der Funktionsdetails von WLAN muss sich ein WLAN-Gerät aber spätesten alle paar Stunden beim Router melden und seine Existenz bestätigen, sonst „vergisst“ der Router das Gerät und kann dann Netzwerkzugriffe für den Mac nicht mehr als Proxy entgegennehmen und an den (schlafenden) Mac weiterleiten, um ihn aufzuwecken. (Diese Proxy-Funktion ist erforderlich, weil Du via WLAN ja anders als via LAN nicht die MAC-Adresse (= Hardware-Netzwerkadresse) des Macs ansprechen kannst, was für das normale Wake-on-LAN aber erforderlich ist.)

Nachdem Dark Wake deshalb aber einmal eingeführt war, und weil im SSD-Zeitalter aus Apples Sicht auch generell kein Grund mehr bestand, die Geräte nicht alle 2 Stunden kurz aufzuwecken, wurde diese Wachzeit dann auch zunehmend für andere Aufgaben genutzt. Z.B. wird abgefragt, ob es Software-Aktualisierungen gibt, und falls ja, werden die (falls der Nutzer das so eingestellt hat) bereits automatisch heruntergeladen (so lange bleibt der Mac dann wach), so dass der Nutzer sie beim nächsten Aufwecken seines Macs bereits installiert/fertig zur Installation vorfindet. Unix-Wartungsskripte, die in bestimmten Zeitabständen fällig sind, werden durchgeführt, neue Emails geholt usw. usw. Im Prinzip geht es darum, dass der Mac nicht erst lauter Dinge erledigen muss, wenn man ihn aufweckt und eigentlich gleich mit der Arbeit beginnen möchte.

Weil die Aufgaben, die beim Dark Wake erledigt werden, mittlerweile so zahlreich sind (und tendenziell mit jeder macOS-Version mehr werden), wollte Apple auch nicht, dass das der Nutzer überhaupt ausschalten kann. Daher gibt es wie bei vergleichbaren Optionen eben keine GUI dafür, sondern nur einen Eintrag in der Konfigurationsdatei. Im Kernel selbst ist die Option aber eben sehr wohl vorgesehen und wird auch berücksichtigt.

Von der Sache her zwingend erforderlich ist Dark Wake nur, wenn Du Deinen Mac via Netzwerk aufwecken können willst, der Mac aber nur via WLAN, nicht via LAN am Netzwerk hängt.

TinkerTool System hatte auf meine Anregung hin übrigens eine GUI für diese Funktion integriert, aber da der Autor Marcel Bresink etwas zur Überkorrektheit neigt und niemandem anempfehlen wollte, die System Integrity Protection auszuschalten (das erste, was ich an einem neuen Mac tue …), ist sie dort mittlerweile leider wieder entfernt worden.
+16
sonorman
sonorman19.11.1815:13
Weia

Danke für die ausführliche Erklärung. Leuchtet soweit auch ein. Nur eine Sache nicht: Die von Dir genannten Hintergrundaktivitäten sind quasi allesamt Dinge, für die Power Nap eingeführt würde. Dazu gibt es in den Systemeinstellungen auch eine Option, die bei mir abgeschaltet ist. Genau wie die für Wake on Lan. Also frage ich mich: wozu hat Apple diese Funktionen in der Systemsteuerung, wenn sie wirkungslos sind?
+2
Weia19.11.1815:20
sonorman
Die von Dir genannten Hintergrundaktivitäten sind quasi allesamt Dinge, für die Power Nap eingeführt würde.
Die Beziehung zwischen Dark Wake und Power Nap kann ich Dir im Detail aus dem Kopf jetzt auch nicht sagen. Vielleicht werden die Funktionen bei Dark Wake quasi auf ein Minimum reduziert (also halt jedenfalls den WLAN-Proxy), sobald der Nutzer das Power-Nap-Zeugs ausschaltet. Aber wie gesagt, genauer weiß ich das auf Anhieb jetzt auch nicht.
0
Hot Mac
Hot Mac19.11.1815:24
Ich traue mich schon gar nicht mehr zu fragen, weil ich nicht wieder verbal eins um die Ohren gehauen haben möchte ...

Ich sollte den DarkWake wohl lieber nicht unterbinden, nehme ich mal an.

Mein iMac Pro ist schnurlos mit dem Netzwerk verbunden und muss unterwegs, aus der Ferne, aufgeweckt werden können.
0
Weia19.11.1815:27
Hot Mac
Ich sollte den DarkWake wohl lieber nicht unterbinden, nehme ich mal an.

Mein iMac Pro ist schnurlos mit dem Netzwerk verbunden und muss unterwegs, aus der Ferne, aufgeweckt werden können.
In der Tat, dann darfst Du Dark Wake keinesfalls ausschalten, denn diese Erreichbarkeit ist seine Kernfunktionalität.
+2
Hot Mac
Hot Mac19.11.1815:35
Weia

Herzlichen Dank für die Information.

Ich hatte keinen Schimmer ...
Man kann ja nicht alles wissen.
Man muss nur wissen, wen man fragen kann. 👍
+4
Weia19.11.1818:50
Weia
Die Beziehung zwischen Dark Wake und Power Nap kann ich Dir im Detail aus dem Kopf jetzt auch nicht sagen.
Ich habe mich da jetzt noch ein wenig schlau gemacht; wie so oft in der IT ist das quasi ein Schichtenmodell mit einer „Nutzerschicht“ und einer darunter.

Die untere Schicht ist Dark Wake, ja ein ganz Hardware-naher Prozess, der (ohne die Änderung in der Konfigurationsdatei) immer stattfindet und das absolut Notwendige ungefragt macht, nämlich (jedenfalls zumindest) den WLAN-Proxy lebendig halten.

Darüber hinaus kann Dark Wake auch noch andere Aktivitäten auslösen, wenn der Nutzer das will und so einstellt. Und diese für den Nutzer sicht- und einstellbaren Aktivitäten werden dem Nutzer gegenüber als „Power Nap“ kommuniziert; technisch sind das einfach die Aktivitäten, die Dark Wake nur auf Nutzerwunsch hin ausführt, also zuzusagen die GUI-Schicht über Dark Wake.
+2
sonorman
sonorman19.11.1819:26
Alles gut und schön. Aber das erklärt längst nicht alles, bzw. es verleiht dem Verhalten in der Praxis keinen Sinn. Warum zum Beispiel müssen sämtliche externen Laufwerke anspringen, nur weil der WLAN-Proxy am Leben erhalten werden muss oder eine Synchronisation zum Time Server erfolgt? Wieso rattert die angeschlossene Backup-Festplatte manchmal minutenlang, wenn doch kein Backup gemacht werden soll (Power Nap aus) und ein Backup auch gar keinen Sinn macht, weil sich sowieso nichts geändert hat?

Ich kann ja noch verstehen, dass der Mac einen Dark Wake initiiert, wenn während des Ruhzustands eine USB-Platte angesteckt oder abgezogen wird, weil ein vernünftiger mount/unmount erfolgen muss. Aber sonst?

Was ich damit sagen will: Wenn solche Hintergrundprozesse wirklich einen Sinn haben oder irgendwie notwendig sind, dann müsste Apple das besser dokumentieren. Scheinbar geht es ja auch ohne die ganzen Dark Wakes.
0
Peacekeeper2000
Peacekeeper200019.11.1823:05
sonorman
Peacekeeper2000
… Eventuell hast Du da was direktes eingetragen ? Wobei das bei mir auch manchmal vorkommt ( aber sehr selten).
In den Systemeinstellungen habe ich unter "Datum und Uhrzeit" time.euro.apple.com als Timeserver angehakt. In der Fritzbox habe ich eingestellt, dass diese als Zeitserver im Heimnetz fungieren soll. Vielleicht gibt es da tatsächlich einen Konflikt.

Ist kein Konflikt, aber läßt sich verbessern: Die FritzBox holt sich die Zeit und dient als Zeitserver - das ist ok. Auf allen Geräten im lokal LAN sollte jetzt die Fritzbox eingetragen werden als Zeitserver. Das spart Anfragen ins Internet und Datenabluss in diese Richtung.
sonorman
Wieso rattert die angeschlossene Backup-Festplatte manchmal minutenlang, wenn doch kein Backup gemacht werden soll
Hmm, das könnte jetzt aber was ganz anderes sein: damit die Köpfe der HD nicht festkleben machen diese ab und zu diese "Gymnastik". Das hängt auch mit der Anzahl der Wake-Ups der HD zusammen.
0
sonorman
sonorman20.11.1809:50
aqua01
Heute auf die Powertaste gedrückt > nach 2 Sekunden konnte ich mich einloggen. Mal sehen, wie sich das in den nächsten Tagen verhält.

Peacekeeper2000
Ich werde die FirtzBox mal als Zeitserver in macOS eintragen. Danke!
0
Foti
Foti20.11.1813:17
Bei meinem MBP welches auch über Ethernet im Netz hängt und zwei externe Platten hat zeigt sich das Verhalten ebenfalls. Auf eine Taste gedrückt braucht es um die 25 sec. um "Aufzuwachen", auf den Powerknopf gedrückt ist es sofort da. Seltsam?
0
sonorman
sonorman20.11.1815:49
Verfluchte Axt! Hab vor einer halben Stunde den Mac schlafen gelegt, um noch ein wenig am iPad zu brainstormen. Plötzlich ein Dark Wake!!

Das einzige, was ich seit gestern geändert habe, war, die Fritzbox als Timeserver anzugeben. Habe ich jetzt gleich wieder geändert. Mal sehen, ob es noch weitere Dark Wakes gibt.

Eigentlich sollte das ja nach dem „abschalten“ (darkwake=0) gar nicht mehr passieren können.
0
ÄNDY
ÄNDY20.11.1816:31
sonorman
Ich bin kurz davor, den Ruhezustand komplett aufzugeben und den Mac stattdessen immer herunter zu fahren.
Was spricht eigentlich dagegen, seinen Rechner nach Gebrauch immer herunter zu fahren?
Mach ich eigentlich grundsätzlich. 15 Sek., jetzt wieder mit Mojave, und ich habe das MBP am Start.
+2
Assassin20.11.1817:12
sonorman
Verfluchte Axt! Hab vor einer halben Stunde den Mac schlafen gelegt, um noch ein wenig am iPad zu brainstormen. Plötzlich ein Dark Wake!!

Das einzige, was ich seit gestern geändert habe, war, die Fritzbox als Timeserver anzugeben. Habe ich jetzt gleich wieder geändert. Mal sehen, ob es noch weitere Dark Wakes gibt.

Eigentlich sollte das ja nach dem „abschalten“ (darkwake=0) gar nicht mehr passieren können.

Ich denke hier hilft nur noch ein Exorzist.
0
sonorman
sonorman20.11.1820:48
Nachdem ich die Fritzbox als Timeserver in den Systemeinstellungen>Uhr wieder rausgeschmissen habe, keine weiteren Dark Wakes… bis jetzt.

Lektion: Bloß nicht die Fritzbox als Timeserver eintragen!
+1
MikeMuc20.11.1823:57
sonorman
Hoffentlich meldest du das als Bug bei AVM. Was stand diesmal im Log?
0
sonorman
sonorman21.11.1809:32
An dem Dark-Wake-Vorfall gestern Nachmittag muss definitiv die Time-Server-Einstellung auf die Fritzbox Schuld gewesen sein. Es gab da allerdings mehrere Dark Wakes kurz nacheinander:

2018-11-20 15:40:18 +0100 Assertions PID 252(mDNSResponder) Created MaintenanceWake "mDNSResponder:maintenance" 00:00:00 id:0x0xd00009f10 [System: DeclUser BGTask SRPrevSleep kCPU kDisp]

[…]

2018-11-20 15:40:37 +0100 DarkWake DarkWake from Normal Sleep [CDN] due to EC.RTC/SleepService: Using AC (Charge:0%) 45 secs

[…]

2018-11-20 15:41:39 +0100 DarkWake DarkWake from Normal Sleep [CDN] due to XHC1/: Using AC (Charge:0%) 28 secs


Danach habe ich den Mac eingeschaltet, den Timeserver in den Systemeinstellungen wieder auf euro.apple.com gestellt und anschließend den Mac wieder schlafen gelegt. Das Protokoll enthält danach keine einzige Meldung mehr bis zum Aufwecken heute morgen.
0
sonorman
sonorman25.11.1815:25
Das „Abschalten“ von Dark Wake funktioniert nicht. Zumindest nicht richtig.

An einem Tag lege ich den Mac schlafen und er schläft durch, ohne das kleinste Zucken (und ohne irgend einen Eintrag im Log). Am nächsten Tag lege ich ihn schlafen und spätestens alle 2 Stunden gibt es einen Dark Wake. Tags darauf dann wieder keinen…

Heute ist wieder so ein Tag mit Dark Wakes. Dabei aktualisiert er übrigens auch die E-Mails im Hintergrund. Also ein Feature, das eigentlich über Power Nap laufen sollte, was aber angeschaltet ist.

Es ist zum 🤮☠️🤯😡😖🥺😤
+1
Weia25.11.1816:50
sonorman
Das „Abschalten“ von Dark Wake funktioniert nicht. Zumindest nicht richtig.
Vielleicht ist der iMac Pro ja ein vernunftbegabtes Gerät und straft diejenigen Nutzer ab, die USB-Audio für eine sinnvolle Sache halten.

Ehrlich, keine Ahnung, was da bei Dir ist. Ich selbst habe keine Erfahrung mit einem iMac Pro, habe aber gerade nochmal extra bei 2 Leuten nachgefragt, die iMac Pros haben und bei denen ich das Dark Wake wie beschrieben ausgeschaltet habe, und bei beiden funktioniert das zu 100%.
+1
wurzelmac
wurzelmac25.11.1817:12
sonorman, bitte vielmals um Entschuldigung, aber das muss ich jetzt mal loswerden:

Ausgerechnet du hast jetzt deine liebe Not mit deinem iMacPro. Wenn ich deine Statements der letzten Jahre bezüglich Apple Hardware an mir vorüberziehen lasse, war alles aber schon sowas von toll, was Apple gebaut hat.

Wie gesagt, ich entschuldige mich vorbeugend für diesen Post.
„You have to keep busy. After all, no dog has ever pissed on a moving car. (Tom Waits)“
+1

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.

OK MacTechNews.de verwendet Cookies unter anderem für personalisierte Inhalte, Seitenanalyse und bei der Auslieferung von Google-Anzeigen. Dies war zwar schon immer so, auf Wunsch der EU muss nun jedoch explizit darauf hingewiesen werden. Durch Nutzung der Website erklären Sie sich damit einverstanden. Weitere Informationen