Forum>iPhone>Mail zieht enorm viel Saft

Mail zieht enorm viel Saft

camaso
camaso13.04.1913:34
Moin Forum
Es gibt Tage, an denen mein iPhone XSMax sehr rasch den Akku leert, bis zu 50% an einem Nachmittag. An anderen Tagen ist das nicht der Fall, der Verbrauch ist unauffällig. Ich komme idR mit einer Ladung 2 Tage bequem über die Runden. Wenn man dann in die Systemeinstellungen - Batterie kuckt, sieht man, dass es sich um Mail handelt, welches aus irgend einem Grund zuviel saugt. Mail ist so eingestellt, dass es alle 15 Minuten die ca. 10 Accounts abgrast, es ist also kein Push aktiv. Da an den meisten Tagen kein übermässiger Verbrauch festzustellen ist, dürfte es nicht an dieser Einstellung liegen.

Auf dem Screenshot sieht man dieses Verhalten gut (wobei auch Werte jenseits von 90% vorkommen). An besagtem Tag habe ich >2 Stunden über WeChat telefoniert und gechattet und etwa 1 Stunde über Skype, teilweise mit Video. Mail wurde kaum überhaupt geöffnet, blieb also quasi immer im Hintergrund.

Was könnten die Gründe sein, und wie kann ich das Problem beheben?
+1

Kommentare

tobias.reichert13.04.1914:21
10 Accounts alle 15 Minuten ist halt ordentlich, Push würde Dir das ersparen.
+1
camaso
camaso13.04.1920:09
Bringt wenig, weil nicht alle Anbieter pushen können. Da muss trotzdem alle 15 Minuten nachgeschaut werden. Ich behaupte mal, dass dadurch der Stromverbrauch noch weiter ansteigen würde.
Zudem wollte ich mich vom Diktat der dauernden Mail-Benachrichtigung befreien. Alle 15 Minuten reichen mir dicke...
0
john
john13.04.1921:22
was tobias.reichert dir sagen will, ist dass ein 15 min intervall nicht „wenig“ ist, sondern enorm viel und du dich da über den stromverbrauch nicht wundern brauchst.
stells auf stündlich oder 2 stündlich.
„biete support. kostenlos, kompetent und freundlich. wähle zwei.“
+3
camaso
camaso13.04.1922:12
Nein John, das ist nicht enorm viel, das steckt das XSMax fast täglich problemlos weg. Wie geschrieben: 2 Tage reicht der Akku normalerweise. GELEGENTLICH zieht Mail extrem viel mehr, ohne an den Einstellungen was geschraubt zu haben, dann ist der Akku INNERT STUNDEN platt. Stromverbrauch von >90% durch Mail im Hintergrund bei gleichzeitiger Benutzung des Geräts für alles mögliche wie Fotografie, Bildbearbeitung, Safari etc. PLUS 1-2 Stunden lange Sprach- und Video-Chats, die im Vergleich den Akku bloss mit je 2-5% belasten. Das Verhalten von Mail ist an diesen AUSSERGEWÖHNLICHEN Tagen nicht normal.
0
Wiesi
Wiesi14.04.1909:06
Nur mal zum Eingrenzen des Fehlers: Schalte "Entfernte Bilder laden" und "Vollständige Konversationen" ab und verdopple Dein Abfrage-Intervall.
0
promac
promac14.04.1909:21
camaso
Was könnten die Gründe sein, und wie kann ich das Problem beheben?

In Kurzform:
Die Gründe sind "höchstwahrscheinlich" die vielen Mail Accounts.

Das Problem kannst du nicht beheben (außer einem Clean Install oder das Löschen der Mail Accs) da du weder über "Root Rechte" (sprich JB) noch über die "benötigten Werkzeuge" verfügst um:
1. den verursachenden Prozess zu identifizieren
2. und diesen Prozess dann auch zu killen/beenden

Meine Vermutung:
Die "Mail App" ist bei iOS eigentlich nur das Frontend (sprich die Gui), alles wichtige (z.B. Audio, Video, Kamera, Bildbetrachter) sind systemweite Prozesse (die du aber nicht siehst) welche im Hintergrund für alle Apps die Arbeit erledigen. Diese laufen aber scheinbar bei dir nicht "Amok", sonst hätte die "Mail App" nicht den immens hohen Stromverbrauch.

Ich schätze das bei einem oder mehreren Mail Accounts bei dir die Authentifizierung "zeitweise" nicht reibungslos klappt und im Hintergrund ein "Loop" entsteht der immer wieder versucht die Daten abzufragen ABER nicht alle bekommt und es somit immer weiter versucht (bis dann der Akku irgendwann leer ist).
+3
HuHaHanZ
HuHaHanZ14.04.1909:30
Ich würde auch auf die Vermutung von promac tippen, dazu kam mir eine Idee, keine Ahnung ob das praktikabel ist für dich: Vielleicht kannst du zur Abfrage ja auch einen Mailsammeldienst einrichten, dann muss nur noch ein Account abgefragt werden?
0
promac
promac14.04.1910:26
camaso

Tipp von mir:
Da du ja nur sehr bescheidene Möglichkeiten hast, sende dir doch mal selber von einem "Webmailer" eine Testmail (mit Bild und Audioanhang) an alle deine Accounts und schaue welcher sie korrekt und sofort zustellt. Sollte dann die Mail bei einem oder mehreren nicht ankommen, dann hast du deinen Übeltäter recht schnell gefunden.

Wenn du wieder einen erhöhten Stromverbrauch feststellst (siehst du ja an der Akkuanzeige) dann "deaktiviere" doch mal temporär den betreffenden Account und beobachte weiter was passiert.

Eine andere Möglichkeit hast du leider nicht ....
+2
camaso
camaso14.04.1910:53
promac
Ich schätze das bei einem oder mehreren Mail Accounts bei dir die Authentifizierung "zeitweise" nicht reibungslos klappt und im Hintergrund ein "Loop" entsteht der immer wieder versucht die Daten abzufragen ABER nicht alle bekommt und es somit immer weiter versucht (bis dann der Akku irgendwann leer ist).
Dieser Hinweis könnte zur Lösung oder besser zum Verständnis beitragen. Einer der Accounts ist an Microsoft China angebunden, da läuft vieles nicht reibungslos. Ich schalte den mal ab und schaue, was passiert. Dauerhaft geht das leider nicht, aber dann wüsste ich wenigstens, woran es liegt.
+1
camaso
camaso14.04.1910:53
HuHaHanZ
Ich würde auch auf die Vermutung von promac tippen, dazu kam mir eine Idee, keine Ahnung ob das praktikabel ist für dich: Vielleicht kannst du zur Abfrage ja auch einen Mailsammeldienst einrichten, dann muss nur noch ein Account abgefragt werden?
Das getraue ich mich aus Datenschutzgründen nicht.
+1
promac
promac14.04.1911:04
camaso
Das getraue ich mich aus Datenschutzgründen nicht.

Du musst dem "Sammeldienst" dann auch ALLE Zugangsdaten sämtlicher Accounts "mitteilen" .... m.M.n. die "schlechteste" aller Varianten !!!
camaso
Einer der Accounts ist an Microsoft China angebunden, da läuft vieles nicht reibungslos.

Mach doch mal bei diesem Speziellen eine "Mailweiterleitung" an einen von deinen anderen Accounts und deaktiviere diesen mal "temporär", so weißt du das eine Mail gekommen ist musst aber diesen nicht über iOS abfragen.
+2
promac
promac14.04.1911:05
camaso
Das getraue ich mich aus Datenschutzgründen nicht.

Du musst dem "Sammeldienst" dann auch ALLE Zugangsdaten sämtlicher Accounts "mitteilen" .... m.M.n. die "schlechteste" aller Varianten !!!
camaso
Einer der Accounts ist an Microsoft China angebunden, da läuft vieles nicht reibungslos.

Mach doch mal bei diesem Speziellen eine "Mailweiterleitung" an einen von deinen anderen Accounts und deaktiviere diesen mal "temporär", so weißt du das eine Mail gekommen ist musst aber diesen nicht über iOS abfragen.
0
HuHaHanZ
HuHaHanZ14.04.1911:13
camaso
HuHaHanZ
Ich würde auch auf die Vermutung von promac tippen, dazu kam mir eine Idee, keine Ahnung ob das praktikabel ist für dich: Vielleicht kannst du zur Abfrage ja auch einen Mailsammeldienst einrichten, dann muss nur noch ein Account abgefragt werden?
Das getraue ich mich aus Datenschutzgründen nicht.
Ja, dachte ich auch dran, war ja auch nur ein schneller Gedanke.
0
camaso
camaso15.04.1908:41
promac
Mach doch mal bei diesem Speziellen eine "Mailweiterleitung" an einen von deinen anderen Accounts und deaktiviere diesen mal "temporär", so weißt du das eine Mail gekommen ist musst aber diesen nicht über iOS abfragen.
Genau das hatte ich vor.
0
camaso
camaso18.04.1908:56
Noch habe ich keine Zeit gefunden, die Vorschläge umzusetzen, kommt aber bald.

Gestern sah es so aus, das Fon wurde heiss...

0
liGhun
liGhun18.04.1909:19
Nutzt Du S/MIME? Ich habe das bei mir im Verdacht, denn auch mein Mail dreht immer mal wieder durch und muss abgeschossen werden, damit es Ruhe gibt. Geht schon seit zwei Jahren so über mehrere Telefon mit und Restore aus Backup
0
tbaer
tbaer18.04.1910:22
Auf meinem iPhone habe ich das so eingestellt, dass ein Abruf aller Emailaccounts erst erfolgt, wenn ich Mail benutze. Der Batterieverbrauch liegt damit bei 1 % und die Mail-App steht an 17. Stelle meiner Verbraucher.

Wenn ich im Betrieb im Firmen-WLAN bin, kann ich keine Mails senden oder empfangen, weil unser Admin diverse Ports gesperrt hat, die Apple offenbar für die Mail-App benötigt. Wenn das bei camaso auch der Fall ist, erfolgen vermutlich diese "Loops" zum Abgleich aller Konten zu den eingestellten Zeiten, ohne dass Daten kommen. Die fehlende Datenkommunikation ist evtl. auch ein Grund, warum es zu den ununterbrochenen "Loops" kommt.

Möglicherweise gibt es aber auch andere Probleme. In der Apple-Community wurde von riesigem Speicherverbrauch der Mail-App berichtet, auch nachdem alle Accounts gelöscht waren. Erst das Löschen und Neuinstallieren von Mail konnte das Problem beheben, offenbar gibt es da irgendwelche Knoten in der App, die sich manchmal nicht lösen lassen. Dann hilft leider nur noch dieser massive Schritt. Leider ist er bei "vielen" Accounts mit erheblicher Arbeit verbunden. Eventuell wäre eine Neuinstallation und Einspielen eines passwortgeschützten Backups über iTunes die einfachere Lösung, auch wenn damit die Gefahr besteht, dass genau dieser Fehler mit in die Neuinstallation synchronisiert wird. Aber danach kann der "aufwändigere" Schritt immer noch gemacht werden.
0
camaso
camaso18.04.1911:41
liGhun
Nutzt Du S/MIME? Ich habe das bei mir im Verdacht, denn auch mein Mail dreht immer mal wieder durch und muss abgeschossen werden, damit es Ruhe gibt. Geht schon seit zwei Jahren so über mehrere Telefon mit und Restore aus Backup
Nein, ist nicht eingeschaltet. Bisher hilft nur das Abschiessen.
0
camaso
camaso18.04.1911:44
tbaer
Auf meinem iPhone habe ich das so eingestellt, dass ein Abruf aller Emailaccounts erst erfolgt, wenn ich Mail benutze. Der Batterieverbrauch liegt damit bei 1 % und die Mail-App steht an 17. Stelle meiner Verbraucher.

Wenn ich im Betrieb im Firmen-WLAN bin, kann ich keine Mails senden oder empfangen, weil unser Admin diverse Ports gesperrt hat, die Apple offenbar für die Mail-App benötigt. Wenn das bei camaso auch der Fall ist, erfolgen vermutlich diese "Loops" zum Abgleich aller Konten zu den eingestellten Zeiten, ohne dass Daten kommen. Die fehlende Datenkommunikation ist evtl. auch ein Grund, warum es zu den ununterbrochenen "Loops" kommt.

Möglicherweise gibt es aber auch andere Probleme. In der Apple-Community wurde von riesigem Speicherverbrauch der Mail-App berichtet, auch nachdem alle Accounts gelöscht waren. Erst das Löschen und Neuinstallieren von Mail konnte das Problem beheben, offenbar gibt es da irgendwelche Knoten in der App, die sich manchmal nicht lösen lassen. Dann hilft leider nur noch dieser massive Schritt. Leider ist er bei "vielen" Accounts mit erheblicher Arbeit verbunden. Eventuell wäre eine Neuinstallation und Einspielen eines passwortgeschützten Backups über iTunes die einfachere Lösung, auch wenn damit die Gefahr besteht, dass genau dieser Fehler mit in die Neuinstallation synchronisiert wird. Aber danach kann der "aufwändigere" Schritt immer noch gemacht werden.
Ich bin mein eigener Admin, will heissen, nichts ist geschlossen, was Mail in den Loop zwingen würde.

Mail löschen? Geht, wie ich grad sehr überrascht sehe, aber wie kann ich es wieder installieren? Ist das im Appstore zu finden? (Edit: Ja... ebenso überrascht).
Die Accounts wären davon ja erstmal nicht betroffen, denke ich. Aber auch andernfalls wäre das kein Beinbruch, denn die Profile, die ich hier bekomme, sollten davon unberührt bleiben.
0
liGhun
liGhun18.04.1911:53
Oha, Profile. Das lässt mich wieder aufhorchen, denn in der Logik von iOS ist sowohl S/MIME als auch diese Einstellungen mit Profilen gelöst. Vielleicht lieber manuell alle Parameter setzen.

Ist wie gesagt nur eine Vermutung, aber ich glaube, dass ein neues Telefon bei mir immer erstmal unauffällig war, bis ich das erste S/MIME-Profil installiert habe (möchte trotzdem nicht drauf verzichten, ich signiere seit vielen Jahren alle E-Mails)
0
camaso
camaso18.04.1912:20
S/MIME ist auf allen Accounts nicht aktiviert.
0
tbaer
tbaer18.04.1913:22
camaso
Mail löschen? Geht, wie ich grad sehr überrascht sehe, aber wie kann ich es wieder installieren? Ist das im Appstore zu finden? (Edit: Ja... ebenso überrascht).
Die Accounts wären davon ja erstmal nicht betroffen, denke ich. Aber auch andernfalls wäre das kein Beinbruch, denn die Profile, die ich hier bekomme, sollten davon unberührt bleiben.

Ja, als ich auf dem iPhone gesehen habe, dass ich Mail plötzlich löschen konnte, war ich auch sehr überrascht, Apple hat ja lange eine andere Strategie verfolgt. Tatsächlich lassen sich alle löschbaren Apps auch im Store wieder neu laden.
Wenn du deinen China-Microsoft-Account im Verdacht hast, kannst du ja mal diesen Account deaktivieren (musst ja nicht gleich löschen) und dann mal beobachten. Eventuell liegt es ja an den Filtern der chinesischen Behörden, dass die Daten nur verzögert verschoben werden und dadurch mehr Strom benötigt wird.
0
liGhun
liGhun18.04.1914:03
Ja, das habe ich gesehen. Aber anscheinend hast Du Profile aktiv?
camaso
S/MIME ist auf allen Accounts nicht aktiviert.
0
camaso
camaso18.04.1915:47
Profile ja. Dank denen hält sich der Installationsaufwand der einzelnen Accounts sehr in Grenzen.
0
camaso
camaso18.04.1915:47
tbaer
camaso
Mail löschen? Geht, wie ich grad sehr überrascht sehe, aber wie kann ich es wieder installieren? Ist das im Appstore zu finden? (Edit: Ja... ebenso überrascht).
Die Accounts wären davon ja erstmal nicht betroffen, denke ich. Aber auch andernfalls wäre das kein Beinbruch, denn die Profile, die ich hier bekomme, sollten davon unberührt bleiben.

Ja, als ich auf dem iPhone gesehen habe, dass ich Mail plötzlich löschen konnte, war ich auch sehr überrascht, Apple hat ja lange eine andere Strategie verfolgt. Tatsächlich lassen sich alle löschbaren Apps auch im Store wieder neu laden.
Wenn du deinen China-Microsoft-Account im Verdacht hast, kannst du ja mal diesen Account deaktivieren (musst ja nicht gleich löschen) und dann mal beobachten. Eventuell liegt es ja an den Filtern der chinesischen Behörden, dass die Daten nur verzögert verschoben werden und dadurch mehr Strom benötigt wird.
Auch das kommt auf die Liste der Dinge, die ich noch ausprobieren werde.
0

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.

OK MacTechNews.de verwendet Cookies unter anderem für personalisierte Inhalte, Seitenanalyse und bei der Auslieferung von Google-Anzeigen. Dies war zwar schon immer so, auf Wunsch der EU muss nun jedoch explizit darauf hingewiesen werden. Durch Nutzung der Website erklären Sie sich damit einverstanden. Weitere Informationen