Forum>Software>Catalina Update in Systemsteuerung-Softwareupdate permanent ausblenden?

Catalina Update in Systemsteuerung-Softwareupdate permanent ausblenden?

Geegah08.10.1916:56
Hi,

hat einer von Euch eine Idee, wie ich unter Systemsteuerung-Softwareupdate das macOS Catalina-Update permanent ausgeblendet bekomme? Ich will nicht die nächsten Jahre mit einer roten "1" leben müssen und auch nicht mal "versehentlich" auf Update klicken können

Gruß,
Geegah
+2

Kommentare

ratz-fatz
ratz-fatz08.10.1917:05
Mir ging das auch auf den Zeiger. Habe mir dafür einen kleinen Script geschrieben.
tell application "Terminal"
    if not (exists window 1) then reopen
    activate
    do script "defaults write com.apple.systempreferences AttentionPrefBundleIDs 0" in first tab of first window
    do script "sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate.plist LastUpdatesAvailable 0" in first tab of first window
    delay 1
    do script "PASSWORT" in first tab of first window
    delay 2
    do script "sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate.plist LastRecommendedUpdatesAvailable 0" in first tab of first window
    do script "sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate.plist RecommendedUpdates" in first tab of first window
    delay 1
    do script "killall Dock" in first tab of first window
end tell
Kannst du in den Script-Editor per Copy/Paste einwerfen. Anstatt "PASSWORT" setzt du dein Passwort für den Admin Account ein, die Anführungszeichen müssen drin bleiben.
+1
Deichkind08.10.1917:30
Seltsam, bei mir erscheint zwar die rote 1, wenn ich die Systemeinstellung Software-Update bis zum Erscheinen des Angebots "macOS Catalina" geöffnet lasse. Nach einer Stunde oder so ist sie aber verschwunden. Dazu kommt es auch ohne Neustart des Rechners.
0
FlyingSloth08.10.1917:32
Geht auch einfacher:
Im Termnial

defaults write com.apple.systempreferences AttentionPrefBundleIDs 0

Und dann

killall Dock

Um das Dock neu zu starten

Enjoy!
+6
McBurK08.10.1918:24
Ich habe das Script benutzt.

Danke ratz-fatz
0
pünktchen
pünktchen09.10.1909:27
Das ist ja alles keine Lösung, sobald automatisch oder manuell nach Updates gesucht wird ist die Benachrichtigung wieder da. Steht hier auch so:

Aber immerhin ist nach

sudo softwareupdate --ignore "macOS Catalina"
(danke @ mikeboss)

bisher keine aufdringlichere Mitteilung erschienen. Ich hoffe das bleibt so und ich muss nur das "1 Update" ignorieren lernen.
+1
Geegah09.10.1910:02
pünktchen
...
sudo softwareupdate --ignore "macOS Catalina"
...
Danke. Genau das hab ich gesucht. Andere Updates werden noch angeboten und sind installierbar, aber Catalina ist einfach ausgeblendet. Mit der roten "1" muss ich dann wohl halt leben...
+1
kde
kde09.10.1911:04
Oder man macht sich im Programme Ordner ein Alias von Systemeinstellungen.app und schiebt die dann ins Dock. Dann hat man halt den Alias-Pfeil.
-1
Weia
Weia09.10.1912:06
Geegah
Ich will nicht die nächsten Jahre mit einer roten "1" leben müssen
Wieso willst Du denn die ganzen nächsten Jahre nicht auf Catalina updaten?

Wenn Dein Mac nicht unterstützt wird, erscheint doch auch keine rote 1?
„Not every story must end with a battle (Ophelia, in der umwerfend guten feministischen Adaption des Hamlet-Stoffes in dem Film „Ophelia“)“
0
struffsky
struffsky09.10.1912:15
Wieso braucht man die Systemeinstellungen im Dock wenn es die im Apfelmenü gibt?
0
pünktchen
pünktchen09.10.1912:17
Ich hab Systemeinstellungen eh nicht im Dock. Das Problem ist für mich kein ästhetisches sondern ein praktisches: es wird ein Update angezeigt wo keins ist. Und ja nicht nur im Dock sondern auch in Systemeinstellungen und im Apfel-Menü. Die --ignore Option funktioniert also praktisch nicht richtig. Allein in Softwareupdate selbst ändert sich die Anzeige.
0
el_duderino
el_duderino09.10.1912:23
Weia
Geegah
Ich will nicht die nächsten Jahre mit einer roten "1" leben müssen
Wieso willst Du denn die ganzen nächsten Jahre nicht auf Catalina updaten?

na zwei jahre bleibt 10.14 noch frisch. wer an seinen alten (unter catalina nicht mehr lauffähigen) apps hängt, der hat bis dahin noch ruhe. zwei jahre lang auf einen roten punkt starren .... würde mich auch nerven.
„sticks and stones may break my bones, but words will never harm me“
+1
RiddleR09.10.1913:36
struffsky
Wieso braucht man die Systemeinstellungen im Dock wenn es die im Apfelmenü gibt?
Klicke mal mit der rechten Maustaste auf das Icon Systemeinstellungen im Dock.
+2
kde
kde09.10.1915:11
struffsky
Wieso braucht man die Systemeinstellungen im Dock wenn es die im Apfelmenü gibt?
Warum zweimal klicken, wenn ichs mit einem Klick öffnen kann?
+2
pünktchen
pünktchen09.10.1915:45
Im Apfelmenü erscheint der Hinweis doch auch, ist also egal wie man lieber in die Systemeinstellungen geht. Ich nehm zB Tastatur und Spotlight.
+1
struffsky
struffsky09.10.1916:20
RiddleR
struffsky
Wieso braucht man die Systemeinstellungen im Dock wenn es die im Apfelmenü gibt?
Klicke mal mit der rechten Maustaste auf das Icon Systemeinstellungen im Dock.
Wieder was gelernt
+1
dr3do09.10.1916:23
struffsky
Wieso braucht man die Systemeinstellungen im Dock wenn es die im Apfelmenü gibt?
…weil, sofern man oft/häufig in die Systemeinstellungen will/muss, es via Dock schneller geht. Zum einen weil es nur ein Klick ist und zum anderen weil man mit Rechtsklick sogar direkt in die passende Kategorie kann.
0
Geegah23.10.1921:35
el_duderino
Weia
Geegah
Ich will nicht die nächsten Jahre mit einer roten "1" leben müssen
Wieso willst Du denn die ganzen nächsten Jahre nicht auf Catalina updaten?

na zwei jahre bleibt 10.14 noch frisch. wer an seinen alten (unter catalina nicht mehr lauffähigen) apps hängt, der hat bis dahin noch ruhe. zwei jahre lang auf einen roten punkt starren .... würde mich auch nerven.
genau das ist der Grund!

Ich habe noch mehrere Anwendungen die unter Catalina nicht mehr/noch nicht laufen, und solange ich unter 10.14 relativ risikoarm arbeiten kann, da es noch mit Sicherheitsupdates versorgt wird, werde ich das tun.
In 2 Jahren kann ich die Situation sicher neu bewerten.
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.