Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Software>Grafiktreiber für Intel HD Graphics 4000 nach "Sicherheitsupdate 2021-007 für macOS Catalina" defekt?

Grafiktreiber für Intel HD Graphics 4000 nach "Sicherheitsupdate 2021-007 für macOS Catalina" defekt?

Wellenbrett03.11.2112:22
Mir ist auf gefallen, dass nach dem "Sicherheitsupdate 2021-007 für macOS Catalina" von letzter Woche bestimmte Software, die OpenGL/WebGL braucht auf einem meiner Macs, einem MacMini (late 2012) mit Intel HD Graphics 4000 GPU nicht mehr funktioniert.

Ich bitte Euch deshalb einen kleinen Test in Safari 15.1 (wurde fast zeitlich mit dem obigen Sicherheitsupdate aktualisiert) zu machen.

Insbesondere die Rückmeldung von diejenigen, die genau obige Hardware/Software-Kombination (Catalina mit besagtem Update "Sicherheitsupdate 2021-007 für macOS Catalina" / Intel HD Graphics 4000) im Einsatz haben, wäre sehr hilfreich.
So könnte Ihr überprüfen, ob Ihr diese Hardware und Software im Einsatz habt:

Im Apfel-Menü "Über diesem Mac" aufrufen: dort steht das Betriebssystem und die Grafik-Hardware; um die Installation des Sicherheitsupdates zu überprüfen, dann einfach in diesem Fenster auf "Systembericht" klicken, unter der Rubrik "Software" auf "Installationen" klicken und nach "Installationsdatum" absteigend sortieren, dann sollte das "Sicherheitsupdate 2021-007 für macOS Catalina" ziemlich weit oben in der Liste auftauchen.

Hier nun der Test. Ihr braucht einfach nur diesen Link der Google Streetview-Ansicht nahe dem Apple Park aufrufen (kleine Stichelei an die Adresse Apples): Wenn Ihr es mit Safari 15.1 macht, stürzt nur der Prozess ab, Mozilla Firefox stürzt komplett ab:

https://goo.gl/maps/eiiUCEBmLJZSeTwg9

(Falls Ihr es mit eigenen Streetview-Ansichten testen wollt. Das Problem tritt nur mit Streetview-Ansichten auf, die Google selber erstellt hat; Streetview-Panoramen von Nutzern führen nicht zum Absturz!)

Falls Ihr eine Rückmeldung postet, wäre sie in dieser Form hilfreich:
Betriebssystem (z.B. 10.15.7)
Grafik-Hardware: (z.B. Intel HD Graphics 4000 1536 MB)
Sicherheitsupdate 2021-007 für macOS Catalina ist installiert/ ist nicht installiert
Problem tritt auf / Problem tritt nicht auf

Vielen Dank für Eure Mithilfe!
+4

Kommentare

Wellenbrett10.11.2113:21
Danke für die Warnung! Ich hatte SIP schon deaktiviert und wollte gerade loslegen...
Die nochmalige Installation des Sicherheitsupdates sollte ja wieder die aktuelle Version von "/System/Library/Extensions/AppleIntelHD4000GraphicsGLDriver.bundle" installieren so dass sein System so weit wieder laufen sollte...
0
miocinq10.11.2115:40
Keine Ahnung wo man die herbekommt. Aber wie gesagt, die VR-Bank-Website geht, Google Streetview geht. Sips bringt allerdings immer noch dieselbe Fehlermeldung, und GLview unterstützt nur den "Apple Software Renderer".

Vielleicht kann man mit Pazifist v Charlessoft das Passende herausfiltrieren und von Hand installieren lassen, gegebenenfalls auch vom 06er Sicherheitsupdate. SIP disabled vorausgesetzt.
0
Wellenbrett10.11.2116:40
miocinq
Keine Ahnung wo man die herbekommt. Aber wie gesagt, die VR-Bank-Website geht, Google Streetview geht. Sips bringt allerdings immer noch dieselbe Fehlermeldung, und GLview unterstützt nur den "Apple Software Renderer".

Vielleicht kann man mit Pazifist v Charlessoft das Passende herausfiltrieren und von Hand installieren lassen, gegebenenfalls auch vom 06er Sicherheitsupdate. SIP disabled vorausgesetzt.
Mir ist unklar, von worauf Du Dich beziehst. Auf die Variante von Wurzenberger oder die von mschue?
miocinq
Sips bringt allerdings immer noch dieselbe Fehlermeldung
...nachdem Du was gemacht hast?
0
miocinq10.11.2117:49
mea culpa,
Wurzenbergers Post (sein letzter Absatz ist mein Intro) nicht "zitiert". Mit dem Pazifist kann man schön in die Install.pkg hineinschauen und nachinstallieren lassen. Könnte eventuell bei der Suche nach den von Wurzenberger genannten Dateien im Sicherheitsupdate 06 helfen. Vielleicht hab ich seinen Ansatz auch nicht ganz verstanden.
0
miocinq10.11.2120:23
Addendum:
Pazifist verweigert (SIP deaktiviert) die Installation mit Hinweis auf fehlende Rechte auf AdminAccount. RootAccount aktiviert - hier wird verhindert Pazifist zu starten mit Hinweis, es wäre am Programm manipuliert und man möge eine neue Version laden. Da passiert es dito. Der Weg ist also ersteinmal per aspera...
0
mschue
mschue10.11.2120:46
Wellenbrett
Danke für die Warnung! Ich hatte SIP schon deaktiviert und wollte gerade loslegen...
Die nochmalige Installation des Sicherheitsupdates sollte ja wieder die aktuelle Version von "/System/Library/Extensions/AppleIntelHD4000GraphicsGLDriver.bundle" installieren so dass sein System so weit wieder laufen sollte...

Ja exakt, bei mir ist nach der erneuten Installation des 007er Updates wieder alles in Ordnung.

In den Apple Foren ist übrigens zu lesen, daß angeblich Autodesk mit Apple "zusammenarbeitet" um den Fehler zu fixen - vielleicht besteht ja doch noch Hoffnung...

Gruß - Matthias
0
miocinq10.11.2121:05
Habe die Methode Wurzemberger, welche unter 11.6.1 wohl funktioniert, unter 10.15.6 probiert. Die VR-Seite läßt sich nicht laden.

Zudem treten karomuster in kleineren Fenstern (Vorlagenauswahl in Pages zb) auf, die beim Größerziehen verschwinden
0
Wurzenberger
Wurzenberger10.11.2121:39
miocinq
Habe die Methode Wurzemberger, welche unter 11.6.1 wohl funktioniert, unter 10.15.6 probiert. Die VR-Seite läßt sich nicht laden.

Zudem treten karomuster in kleineren Fenstern (Vorlagenauswahl in Pages zb) auf, die beim Größerziehen verschwinden
Ach unter Big Sur treten diese Probleme zwar nicht auf, dafür zeigt Aperture keine Bilder mehr an.
0
karstenl
karstenl10.11.2122:09
@Wurzenburger

Merci vielmals fuer den Tip, die Treiber umzukopieren. Funktioniert!
Kannst du mal ausprobieren ob Sips bei dir eine Fehlermeldung bringt?

Einfach irgendein JPG oder so auf den Desktop kopieren und dann im Terminal
sips -c 100 100 ~/Desktop/DATEINAME
eingeben.

Wenn Du die .bundles mit chmod u+x exekutierbar machst, funktioniert es auch mit sips und den kopierten Treibern in /Library/GPUBundles.
~ sips -c 100 100 /Users/User/Desktop/IMG_6123.JPG
/Users/User/Desktop/IMG_6123.JPG
/Users/User/Desktop/IMG_6123.JPG
~

Cheers,

k.
0
Wurzenberger
Wurzenberger10.11.2122:23
Also.

Mit "AppleIntelHD4000GraphicsGLDriver.bundle" in /Library/GPUBundles/ funktionieren die VR-Bank-Website und Google Streetview.

Aber.

Aperture zeigt keine Bilder mehr an und Pixelmator bringt diese Fehlermeldung:
0
karstenl
karstenl10.11.2122:38
Moin Wurzenberger,

Aperture & Pixelmator kann ich nicht testen, aber Pixelmator Pro funktioniert:


(MBP mid 2012, 11.6.1)
0
karstenl
karstenl11.11.2100:22
Unter Catalina funktioniert der Trick mit dem umkopieren der .bundles in /Library/GPUBundles leider nicht

(MBP 13" mid 2012)
0
Wellenbrett11.11.2106:55
mschue
Wellenbrett
... Die nochmalige Installation des Sicherheitsupdates sollte ja wieder die aktuelle Version von "/System/Library/Extensions/AppleIntelHD4000GraphicsGLDriver.bundle" installieren so dass sein System so weit wieder laufen sollte...

Ja exakt, bei mir ist nach der erneuten Installation des 007er Updates wieder alles in Ordnung.

In den Apple Foren ist übrigens zu lesen, daß angeblich Autodesk mit Apple "zusammenarbeitet" um den Fehler zu fixen - vielleicht besteht ja doch noch Hoffnung...

Gruß - Matthias
Gut, dass Dein System wieder funktioniert!
Das mit Autodesk sind gute Nachrichten! Google ist ja ebenfalls betroffen; schließlich kann Streetview in den Browsern nicht dargestellt werden...
0
Wellenbrett11.11.2106:57
miocinq
mea culpa,
Wurzenbergers Post (sein letzter Absatz ist mein Intro) nicht "zitiert". ...
Danke, jetzt verstehe ich, was Du meintest.
0
Wurzenberger
Wurzenberger11.11.2107:51
karstenl
Moin Wurzenberger,

Aperture & Pixelmator kann ich nicht testen, aber Pixelmator Pro funktioniert:
Danke für die Info. Echt schräg. Ich werds weiter versuchen.
0
kabelkanal12.11.2109:43
Bei mir (Mac Mini 2012) das Gleiche, in Safari und Firefox gibt es Probleme mit den Volksbank Seiten. In Firefox kann ich beseitigen, wenn ich unter"about:config" WebGL deaktiviere. Bei Safari, wenn ich im "Entwickler- Menü, Experimentelle Funktionen, WebGL via Metal" aktiviere.
Ansonsten, Pixelmator Pro und alle Affinity Programme funktionieren einwandfrei.
Ich glaube, es wird nach fast 10 Jahren langsam mal Zeit für was neues.
+6
Wellenbrett12.11.2110:10
kabelkanal
Bei mir (Mac Mini 2012) das Gleiche, in Safari und Firefox gibt es Probleme mit den Volksbank Seiten. In Firefox kann ich beseitigen, wenn ich unter"about:config" WebGL deaktiviere. Bei Safari, wenn ich im "Entwickler- Menü, Experimentelle Funktionen, WebGL via Metal" aktiviere.
"WebGL via Metal" in Safari zu verwenden, funktioniert bei mir auch. Danke für den Hinweis!
kabelkanal
Ansonsten, Pixelmator Pro und alle Affinity Programme funktionieren einwandfrei.
Da hast Du Glück, etliche andere Programme funktionieren ja nicht.
kabelkanal
Ich glaube, es wird nach fast 10 Jahren langsam mal Zeit für was neues.
Es ist wirklich ein Fehler oder eine bewußte Entscheidung Apples, mit einem Sicherheitsupdate OpenGL/WebGL auf der HD4000-GPU unter Catalina plötzlich nicht mehr zu unterstützen.
+3
Wurzenberger
Wurzenberger12.11.2110:23
kabelkanal
Bei mir (Mac Mini 2012) das Gleiche, in Safari und Firefox gibt es Probleme mit den Volksbank Seiten. In Firefox kann ich beseitigen, wenn ich unter"about:config" WebGL deaktiviere. Bei Safari, wenn ich im "Entwickler- Menü, Experimentelle Funktionen, WebGL via Metal" aktiviere.
Wie geil ist das denn bitte. Vielen Dank für den Tipp! Damit funktioniert die VR-Bank-Website. Google Streetview kann ich gerade nicht testen, da gibt es irgendwelche Verbindungsprobleme.
+2
Cooper12.11.2111:22
@kabelkanal: von mir auch vielen Dank für den Tipp "WebGL via Metal" in Safari zu aktivieren. Damit funktionieren die Teile der Apple Webseite, die WebGL benutzen bei mir (MacMini 2012, Catalina) wieder
+1
Wurzenberger
Wurzenberger12.11.2112:25
Streetview klappt!
0
Wellenbrett15.11.2109:47
In diesem Zusammenhang ist auch der aktuelle Artikel von Mactechnews interessant: . Apple behebt dem Artikel zufolge mit einem Sicherheitsupdate eines älteren Systems nicht alle bekannten Sicherheitslücken, die in aktuelleren Betriebssystem jedoch behoben werden. Dafür - bitte verzeiht mir den Sarkasmus - werden aber auch mal wertvolle Funktionen abgeschaltet...
+3
Wellenbrett01.12.2113:56
Ich wollte Euch von meiner Lösung berichten, zu der ich mich vor ein paar Tagen durchgerungen habe: viele der Programme, die auf OpenGL/WebGL angewiesen sind, sind plattformübergreifend programmiert; es gibt sie also auch in einer Windows-Version...
Also habe ich auf dem besagtem MacMini mit der Intel HD4000 GPU Bootcamp eingerichtet und in der von dem Bootcamp-Assistenten eingerichteten Partition dann Windows 10 installiert. Dort habe ich dann die ganzen Programme, die unter MacOS nicht mehr liefen installiert.
Klappt einwandfrei. Der Lüfter des MacMini ist auch unter Windows 10 bisher nie zu hören gewesen. Die ganze Lösung wirkt sehr robust. Da die Software, die unter macOS Catalina nach Apples HD4000-Treiberkorrumpierung nicht mehr funktionierte, ohnehin nie besonders gut an macOS angepasst war (als Ausnahme fällt mir da spontan nur Safari ein) hat die Bootcamp-Lösung auch einen ästhetischen Aspekt: diese Software ist jetzt sozusagen ins Boot Camp ausgelagert und unter macOS läuft überwiegend gut angepasste Software. Damit möchte ich aber nicht die ansonsten oftmals wirklich leistungsstarke Software diskreditieren. Die Verantwortung für das Problem liegt bei Apple. Im Ergebnis hat es schon etwas Skurriles: unter Windows wird die Apple-Hardware (übrigens mit dem originalen Intel Treiber für die HD 4000 GPU) problemlos angesprochen, unter macOS nicht (mehr)...
Wenn jemand Fragen zu der Bootcamp-Einrichtung hat, teile ich ich gerne meine Erfahrungen...
+3
Wellenbrett02.12.2116:32
Apple scheint ein Update für macOS Catalina vorzubereiten! Da keimt bei mir Hoffnung auf, dass Apple den Treiberfehler doch noch behebt.
Quelle:
0
Bernhard123402.12.2121:36
Mit Monterey 12.0.1 funktionieren übrigens alle oben beschriebenen Links am MacMini Late 2012 (HD4000). Ist nicht offiziell supported, aber OpenCorePatcher macht's möglich.
+1
uhk
uhk02.12.2121:52
Bin ein bisschen spät bei der Party, aber mein Mac Mini (Ende 2012), 2,3 GHz Quad-Core Intel Core i7 mit Intel HD Graphics 4000 zickt unter 10.15.7 mit dem Sicherheitsupdate ebenfalls rum. Verschieden Webseiten schmierten unter Firefox und Safari einfach ab. Dank des Tips von @kabelkanal ist das zum Glück gefixt.
Unter Aperture, das ich per Retroactive noch am Laufen hatte, tritt das Phänomen der fehlenden Vorschaubilder auch auf. Unter der Nik Collection ist mir bisher nichts aufgefallen - nur dass einmal Color Efex Pro 4 beim Starten hing. Beim zweiten Anlauf klappte es...
0
Wellenbrett03.12.2109:55
Bernhard1234
Mit Monterey 12.0.1 funktionieren übrigens alle oben beschriebenen Links am MacMini Late 2012 (HD4000). Ist nicht offiziell supported, aber OpenCorePatcher macht's möglich.
Danke, das bestätigt auch andere dahingehende Berichte. Wie flott ist der Rechner denn im Vergleich zu Catalina (oder hattest Du vorher Big Sur darauf laufen?). Gibt es irgendwelche Probleme, z.B. mit dem Aufwachen aus dem Ruhemodus, oder übermäßigen Speicherbedarf wie es sogar auf regulären Monterey-Modellen auftritt?
0
Wellenbrett03.12.2110:00
uhk
...Unter Aperture, das ich per Retroactive noch am Laufen hatte, tritt das Phänomen der fehlenden Vorschaubilder auch auf.
Bei Aperture gibt es inzwischen so viele mögliche Ursachen. Ist das Problem mit den Vorschaubildern denn erstmals seit dem Sicherheitsupdate aufgetreten?
0
uhk
uhk04.12.2117:26
Ja, exakt danach. Vorher lief es stabil uns nur minimalen Einschränkungen.
Wellenbrett
uhk
...Unter Aperture, das ich per Retroactive noch am Laufen hatte, tritt das Phänomen der fehlenden Vorschaubilder auch auf.
Bei Aperture gibt es inzwischen so viele mögliche Ursachen. Ist das Problem mit den Vorschaubildern denn erstmals seit dem Sicherheitsupdate aufgetreten?
0
mschue
mschue13.12.2121:15
Heute ist das "Security Update 2021-008 Catalina" herausgekommen und bei mir sind alle WebGL-/HD4000-Probleme dadurch gefixed.

Ist halt doch eine gute Firma...

Gruß - Matthias
+6
Wellenbrett13.12.2122:45

Habe das Update eben auch installiert und wie bei mschue ist jetzt wieder alles ok.
+4
ll14.12.2110:47
Bin erst heute auf das Problem gestoßen, dürfte aber nicht alleine an der HD4000 gelegen sein da die gleichen Fehler auch bei aktivierter Geforce 650m auftraten (MBP Mid 2012 NonRetina; 10.15.7)
Nach dem 2021-008 Security Update ist's wie bereits erwähnt wurde wieder gut.
0
Wellenbrett14.12.2111:03
ll
...dürfte aber nicht alleine an der HD4000 gelegen sein da die gleichen Fehler auch bei aktivierter Geforce 650m auftraten (MBP Mid 2012 NonRetina; 10.15.7)...
Es war ein Software-Problem, kein Hardware-Problem. Bei der HD4000 hatte ich das Auftreten des Problems beobachtet. Es ist durchaus naheliegend, dass mehrere Treiber, gemeinsame Software-Bestandteile verwendet haben, die das Problem verursacht haben.
0
pünktchen
pünktchen14.12.2111:29
Also wenn die Geforce 650 Probleme hat dann ja vielleicht auch die GeForce 320M? Hmm vielleicht bekomm ich den Adventskalender meiner Schwiegermutter doch noch zum laufen.
0
Wellenbrett14.12.2111:54
pünktchen
Also wenn die Geforce 650 Probleme hat dann ja vielleicht auch die GeForce 320M? Hmm vielleicht bekomm ich den Adventskalender meiner Schwiegermutter doch noch zum laufen.
Viel Glück dabei!
0
AppleUser2013
AppleUser201314.12.2114:34
Hat jemand Erfahrungen mit Big Sur 11.6.2 und der HD4000?
0
Wellenbrett14.12.2117:33
AppleUser2013
Hat jemand Erfahrungen mit Big Sur 11.6.2 und der HD4000?
Nicht direkt, aber das Problem um das es in dieser Diskussion ging war sehr spezifisch und betraf meines Wissens nur macOS Catalina mit dem "Sicherheitsupdate 2021-007 für macOS Catalina" und der Intel Iris HD4000 GPU und einigen anderen GPUs. Seit gestern ist das Problem behoben, wenn man das "Sicherheitsupdate 2021-008 für macOS Catalina" einspielt. Big Sur ist nicht betroffen, zumindest nicht in wenn es vom Original-Installer von Apple installiert wird.
0
Wellenbrett14.12.2117:47
Ich wollte in meinem letzten Beitrag schreiben: "... und möglicherweise einigen anderen GPUs. ..." Denn sicher weiß ich es nur von der HD4000.
0

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.