Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Netzwerke>Netzwerkvolume meldet sich ungefragt an

Netzwerkvolume meldet sich ungefragt an

Naquaada
Naquaada29.06.1518:10
Hallo,

ich habe ein merkwürdiges, aber nerviges Problem: Ich habe jetzt ein OS X Leopard auf meinem PowerBook fertiggestellt und komplett neu eingerichtet, also ohne Dateien zu migrieren. Dazu habe ich natürlich Daten von meinem Hauptsystem per Netzwerk übertragen, also per Filecopy. Ich gehe immer über feste IP's rein, dazu wird natürlich das Password im Schlüsselbund gespeichert. Funktioniert ja auch alles problemlos. Nur: Jetzt verbindet er sich immer automatisch dahin, obwohl ich nichts dergleichen eingestellt habe. Wenn mein Hauptsystem aus ist, eiert er natürlich einige Zeit rum, dann poppt ein Fenster auf 'Server nicht gefunden'. Das ist natürlich reichlich nervig.

Hat jemand eine Lösung dafür? Ich habe nichts gefunden, ob es eine Stelle gibt, an der man sich automatische Netzwerkvolumes verwalten lassen. Um meine NAS-Laufwerke automatisch mounten zu können, mußte ich ja sogar erst auf ein Shell-Script zurückgreifen. Im Internet suchen hilft nicht viel, unter 'Mac automount' 'Mac disable automount' bekommt man höchstens Hinweise, wie man ein Laufwerk automatisch mounten kann, aber nicht wie man's abstellt. Vielleicht hat ja jemand eine Idee.

naquaada.
0

Kommentare

promac30.06.1509:05
Naquaada
Dazu habe ich natürlich Daten von meinem Hauptsystem per Netzwerk übertragen, also per Filecopy. Ich gehe immer über feste IP's rein, dazu wird natürlich das Password im Schlüsselbund gespeichert. Funktioniert ja auch alles problemlos. Nur: Jetzt verbindet er sich immer automatisch dahin, obwohl ich nichts dergleichen eingestellt habe. Wenn mein Hauptsystem aus ist, eiert er natürlich einige Zeit rum, dann poppt ein Fenster auf 'Server nicht gefunden'. Das ist natürlich reichlich nervig.

Kannst du dieses mal etwas näher erleutern, so ganz verstanden habe ich es noch nicht.
Normalerweise gibst du am "HauptMac" die Dateifreigabe frei. Dann erscheint am MB im Finder unter Freigaben dein Mac als Freigabe im Netzwerk. Mit dem musst du dich aber "aktiv" erst verbinden, alleine macht der doch nichts !?!

Habe eine ähnliche Konstellation wie du.
MBP > MacMini > Airport Extreme mit Stick als NAS

Vom MBP sieht es "normalerweise" so aus. MacMini an aber nicht verbunden:


MacMini aktiv verbunden:


MacMini im Ruhezustand:
0
jogoto30.06.1509:08
Eventuell einen Alias mit kopiert oder erstellt?
0
RAW10.07.1513:53
Hallo Naquaada

Hast du einen Eintrag in der Startobjekten?
(Systemeinstellungen > Benutzer > Startobjekte)
0
Naquaada
Naquaada15.07.1519:28
Sorry, hatte bisher keine Zeit zu antworten.

Also in den Startobjekten ist natürlich nichts drin. Wenn ich die Kennwörter im Schlüsselbund lösche, versucht er sich anzumelden, hat natürlich kein Passwort. Allerdings versucht er auch, sich zu verbinden, wenn kein Sharing komplett aus ist, Printer- und Screensharing, Unter Filesharing sind AFP, FTP und SMB zusätzlich deaktiviert. Trotzdem versucht er es immer wieder. Ich habe inzwischen auch mal /Library/Preferences/loginwindow.plist gelöscht, kein Erfolg.

DIe Konsole hilft auch nicht viel weiter. Allerdings hat Little Snitch etwas geholfen: Ich habe den Netzwerkcontroller deaktiviert und da gab's dann einige Infos. /System/Library/CoreServices/NetAuthAgent versucht sich über Port 548 (afpovertcp) anzumelden, das ist aber nur die Frage nach dem Passwort. Über den NetAuthAgent gibt's genug im Netz, scheint wohl bei Vielen Probleme zu machen. Auch die Datei /Library/Keychains/login.keychain zu löschen hat nichts gebracht. Auch die Netzwerkeinstellungsdateien in /Library/Preferences/SystemConfiguration zu löschen blieb erfolglos, er meldet sich immer noch an.

Also im Moment habe ich echt keine Ahnung mehr, was ich noch probieren kann. Man kann ja leider auch nicht festellen, von welcher Datei oder so der Aufruf zum Anmelden des Servers kam. Irgendwie scheint er sich ohnehin nicht so recht um die Sharing-Regeln zu kümmern, mein NAS-Laufwerk ist immer noch komplett zugriffsbereit.
0
jogoto15.07.1519:52
Naquaada
Allerdings versucht er auch, sich zu verbinden, wenn kein Sharing komplett aus ist ...
Das hat überhaupt nichts damit zu tun. Dort steuerst Du den Zugriff von außen auf Deinen Mal und nicht den Zugriff vom Mac auf was anderes.
... versucht sich über Port 548 (afpovertcp) anzumelden ...
Zugriff auf eine Netzwerkvolumen per AFP.
Auch die Datei /Library/Keychains/login.keychain zu löschen hat nichts gebracht. Auch die Netzwerkeinstellungsdateien in /Library/Preferences/SystemConfiguration zu löschen blieb erfolglos ...
Warum auch? Der Verbindung das Passwort zu klauen führt nur dazu, dass beim nächsten mal nach dem Passwort gefragt wird. Die Verbindung ist bestimmt auch nicht im System, da Du Startobjekte etc. ausgeschloßen hast.
Die Verbindung wird bestimmt auf Dateiebene versucht, also Alias oder so.
0
MikeMuc15.07.1520:50
Hast du vielleicht mal hiermit experimentiert ? Ansonsten gibt es am Mac keine Startobjekte 8d.h gab es so nur unter OS9. Könnte es sein (Stichwort OS X Leopard) das du Teile von OS 9 welches ja noch unter 10.5 al Classic lief mit kopiert hast? Vielleicht existieren nämlich noch Fragmente im System die die speziellen OS 9 Ordner auswerten...
0
pcbastler15.07.1523:55
Benutzt du (bewusst oder unbewusst) einen Verzeichnisdienst für die Benutzerverwaltung?
0
caMpi
caMpi16.07.1507:21
Wie sieht es denn aus, wenn du auf deinem Powerbook einen neuen Benutzer anlegst?
Wird das Volume auch unter diesem Benutzer automatisch verbunden?
0
Naquaada
Naquaada17.07.1510:24
Ich habe das Problem gelöst: Es lag am Programm 'Mira', damit kann man über einen eHome-kompatiblen IR-Empfänger die Apple Remote nutzen kann. Und das für jedes Programm frei konfigurierbar. Ich hatte die Einstellungen meines alten Rechners übernommen, anscheinend war das nichts. Ich habe also alle Programmteile manuell entfernt, neu gestartet - keine Abfrage mehr nach dem Server. Danach habe ich Mira neu installiert und registriert, alles in Ordnung.

Fragt mich aber nicht, wie ich auf Mira gekommen bin... Entweder bin ich einfach nur alle Prefs durchgegangen, oder ich hatte was in den Protokollen gefunden. Naja, Hauptsache, es geht wieder
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.