Forum>Software>Probleme mit der Schlüsselbundverwaltung.

Probleme mit der Schlüsselbundverwaltung.

looser
looser28.06.0920:45
Innerhalb der Schlüsselbundverwaltung habe ich einen Schlüsselbund X509Anchors, der jede Menge Zertifikate beinhaltet. Diese Zertifikate bereiten mir an anderer Stelle Probleme und ich möchte sie gerne löschen.

Eigentlich eine anscheinend einfache Aufgabe, wäre da nicht das Kennwort, dass ich erstaunlicherweise nicht kenne. Auch kann ich mich nicht mehr daran erinnern, wann oder warum all diese Zertifikate installiert worden sind. Auch ein Zurücksetzen der Schlüsselbund-Kennwörter ergab keinen Erfolg.

Hat jemand eine Idee, wie ich da ran komme? Theoretisch könnte ich über den Pfad die Datei löschen, frage mich nur, ob dann nicht nach den verschwundenen Zertifikaten immer wieder gesucht wird.
„© looser@macbay.de“
0

Kommentare

Rantanplan
Rantanplan28.06.0921:03
Die Zertifikate der Root CAs zu löschen ist eine ... sorry, ziemlich dumme Idee Aber mach mal, danach bist du der Loser (man beachte das "o")
„Wenn ich nicht hier bin, bin ich auf dem Sonnendeck“
0
Wowbagger28.06.0921:20
Was für Probleme verursachen denn die Zertifikate? Welche Version von OS X verwendest Du? Hast Du schon ausprobiert, ob die "Erste Hilfe"-Funktion der Schlüsselbundverwaltung Deine Probleme löst?
0
twilight
twilight28.06.0921:22
Rantanplan
Die Zertifikate der Root CAs zu löschen ist eine ... sorry, ziemlich dumme Idee Aber mach mal, danach bist du der Loser (man beachte das "o")

Durch Zufall (ich glaube ihm) hat neulich ein Freund mal einige Zertifikate gelöscht, die er besser nicht hätte löschen sollen ... manchmal ist Time Machine Gold wert ;D

Peter
„Auch dienstlich tu ich mir garantiert kein Windows an!“
0
looser
looser28.06.0922:03
⌦ Rantanplan:
Das sind keine Roots-Zertifikate (hat nix mit System-Roots zu tun). Diesen Schlüsselbund gibt es separat. Erst lesen, dann bellen, denn ich kann ihn ja nicht löschen! Ach ja, der loser schreibt sich so!

↳ Wowbagger:
Entourage accessing obsolete X509Anchors. Ich denke, da sind nicht mehr gültige Zertifikate in dem Ordner. Erste Hilfe greift hier nicht, auch nicht Zertifikate überprüfen.

↳ twilight.
Keine Sorge, auch wenn ich TM nicht einsetze.
„© looser@macbay.de“
0
Rantanplan
Rantanplan28.06.0922:08
looser
Ach ja, der loser schreibt sich so!

Klar, weiß ich. Du nicht, oder?
Das sind keine Roots-Zertifikate (hat nix mit System-Roots zu tun).

Doch. Aber nach ein wenig Googeln (wo ich auch ne Menge Anleitungen zu deinem Problem gefunden habe), habe ich herausgefunden, daß der Schlüsselbund mit den Zertifikaten der Root CAs bei 10.5 anders heißt. X509Anchors hieß er bis 10.4.

Tschüß, Loser.
„Wenn ich nicht hier bin, bin ich auf dem Sonnendeck“
0
Wowbagger28.06.0922:11
Du verwendest Du 10.5, oder? Dann sollte X509Anchors nur noch aus Kompatibilitätsgründen vorhanden sein:
On Mac OS 10.5 this system wide keychain is called "SystemRootCertificates.keychain" and shows up in Keychain Access as "System Roots". On 10.4 and earlier it's called "X509Anchors" (no filename extension) and shows up as such in Keychain Access. The old file is still present on 10.5, but ignored and only remains for backwards compatibility with third party software.



Mach auf jeden Fall ein Backup der Datei, vor Du irgendwas tust. Versuch mal "X509Anchors" als Kennwort.
0
looser
looser28.06.0922:13
⌦ Rantanplan: Noch was, dieser Schlüsselbund existiert nur an einem Rechner. Und ich frage mich wirklich, wo der her kommt. Loser hast Du ja richtig gedeutet, da habe ich nicht richtig gelesen *sick*
„© looser@macbay.de“
0
Wowbagger28.06.0922:18
Ach so, Entourage, dann schau mal hier rein:

unter "Entourage 2004 unable to connect securely to Exchange 2003 server. Error "Unable to establish a secure connection to <servername> because the root certificate is not installed."
0
looser
looser28.06.0922:19
Rantanplan
Doch. Aber nach ein wenig Googeln (wo ich auch ne Menge Anleitungen zu deinem Problem gefunden habe), habe ich herausgefunden, daß der Schlüsselbund mit den Zertifikaten der Root CAs anders heißt. X509Anchors hieß er bis 10.4.

Glaube mir, dieser Ordner hat auch nix mit 10.4 zu tun. Zeige mir doch bitte die Anleitungen, denn ich habe keine gefunden, wie ich Zugang zu dem Schlüsselbund erhalte.

„© looser@macbay.de“
0
looser
looser28.06.0922:27
Wowbagger
Mach auf jeden Fall ein Backup der Datei, vor Du irgendwas tust. Versuch mal "X509Anchors" als Kennwort.

Danke Wowbagger, guter Tipp. Greift leider auch nicht. Ja ist 10.5.
Entourage 2008 baut seit einiger Zeit seine Datenbank immer wieder neu auf und ich finde den Verursacher nicht. Auch nicht mit google .
„© looser@macbay.de“
0
looser
looser28.06.0922:51
Habe den Bund jetzt händisch gelöscht. System läuft, aber der Fehler bei Entourage bleibt. Werde wohl weitersuchen müssen. Merci.
„© looser@macbay.de“
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.

OK MacTechNews.de verwendet Cookies unter anderem für personalisierte Inhalte, Seitenanalyse und bei der Auslieferung von Google-Anzeigen. Dies war zwar schon immer so, auf Wunsch der EU muss nun jedoch explizit darauf hingewiesen werden. Durch Nutzung der Website erklären Sie sich damit einverstanden. Weitere Informationen