Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Netzwerke>Mac fordert falsche IP Adresse an, und bekommt sie!

Mac fordert falsche IP Adresse an, und bekommt sie!

MetallSnake
MetallSnake10.12.1111:22
Ich habe hier ein blödes Problem mit meinem Netzwerk.
Habe einen Router mit aktiviertem DHCP Server, dort ist die MAC meines Macs auf eine feste IP gemappt.
Der Mac fragt aber beim DHCP-Request eine andere IP an (habe ich per Wireshark geprüft) und bekommt die dann leider auch.

Woran liegt das nun dass der Rechner immer eine bestimmte IP anfragt? Und wieso bekomme ich die dann auch noch zugwiesen obwohl im DHCP Server doch eine andere IP für die MAC eingetragen ist?


Es handelt sich natürlich nicht um eine 169 Adresse, da gäb es dann nicht viel per Wireshark zu prüfen.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0

Kommentare

Nemo_G
Nemo_G10.12.1111:37
Mehrere DHCP-Server im Netzwerk und "Dein" DHCP-Server ist nur zweiter Sieger?

Wenn WLAN: Verbindet sich Dein Mac mit dem falschen Accesspoint?
0
MetallSnake
MetallSnake10.12.1111:39
Nein ein DHCP Server und Kabelgebunden
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
jogoto10.12.1111:53
Falsche MAC Adresse für den Mac im Router eingegeben? Ein Mac hat durchaus mehrere.
0
MetallSnake
MetallSnake10.12.1112:01
Ne habe schon die richtige eingetragen... und ja alle Kabel sind auch richtig drin.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
chill
chill10.12.1112:05
einfach diesen unsinn mit fest vergebenen ip und mac adressen sein lassen. nein, das ist nicht als scherz gemeint.
„"¿ssıəɥɔs ɹəp llos sɐʍ" :ʇƃɐs əsıəʍ ɹəp 'ßıəʍ sɐʍ ɹə sɐp ßıəʍ əƃnlʞ ɹəp“
0
Simoon
Simoon10.12.1112:20
MetallSnake
Woran liegt das nun dass der Rechner immer eine bestimmte IP anfragt? Und wieso bekomme ich die dann auch noch zugwiesen obwohl im DHCP Server doch eine andere IP für die MAC eingetragen ist?

Du hast nicht versehentlich "DHCP mit manueller Adresse" in den Netzwerkeinstellungen des Macs ausgewählt?
0
MetallSnake
MetallSnake10.12.1112:26
chill Haha guter Witz. Ist nur leider nicht Praktikabel immer wieder die Regeln fürs Port Forwarding etc. anzupassen.

Simoon Nein
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
jogoto10.12.1112:46
MetallSnake
@@chill Haha guter Witz. Ist nur leider nicht Praktikabel immer wieder die Regeln fürs Port Forwarding etc. anzupassen.

Wenn nicht ständig neue Geräte im Netz rum schwirren, bekommt der Mac doch eh immer dieselbe Adresse.
0
sunni10.12.1113:06
Zunächst mal, ein Netzwerkgerät fragt keine bestimmte IP-Adresse an. Ein Netzwerkgerät fragt im Netzwerk einen DHCP-Server und bekommt im besten Fall eine IP. Irgendeine von dem am schnellsten antwortenden DHCP-Server.

Du hast die MAC-Adresse deines Rechners in den Router eingetragen und lässt ihm darüber eine IP geben. Gut.

Von welchem DHCP-Server dein Mac nun eine IP-Adresse bekommt, kannst du dir im System Profiler auch anschauen: Systemprofiler Netzwerk Dein Anschluss (Ethernet, Wi-Fi)
Weil der Systemprofiler aber nicht immer die immer die volle Wahrheit sagt, kannst auch über das Terminal herausfinden, von wem die IP-Adresse gekommen ist. Der Eintrag 'siaddr' ist der DHCP-Server.
ipconfig getpacket <en0> / <en1>
(en0 für Ethernet; en1 für Wi-Fi)
0
chill
chill10.12.1113:06
Ist nur leider nicht Praktikabel immer wieder die Regeln fürs Port Forwarding etc. anzupassen

man kann die ports in den allermeisten routern auch IP übergreifend freigeben. echt
„"¿ssıəɥɔs ɹəp llos sɐʍ" :ʇƃɐs əsıəʍ ɹəp 'ßıəʍ sɐʍ ɹə sɐp ßıəʍ əƃnlʞ ɹəp“
0
Blubs
Blubs10.12.1113:19
Das ist doch eh nur ne Krücke. Wenn man ne feste IP will, trägt man die beim Mac in den Netzwerkeinstellungen ein und läßt das nicht den DHCP-Server machen. Das klappt immer und problemlos.
0
sierkb10.12.1114:36
Blubs
Wenn man ne feste IP will, trägt man die beim Mac in den Netzwerkeinstellungen ein und läßt das nicht den DHCP-Server machen. Das klappt immer und problemlos.

Kommt drauf an, wievielen Rechnern im lokalen Netz Du auf diese Weise eine feste IP zuordnen willst. Kann nervig und aufwendig sein bei mehreren Rechnern. Das an zentraler Stelle zu konfigurieren für das gesamte Netzwerk -- nämlich beim primären DHCP-Server -- ist durchaus sinnvoll. Pro angeschlossenem Rechner dann jeweils einen eigenen Abschnitt bekannter Clients in der /etc/dhcpd.conf eintragen, meinetwegen noch gruppiert, in dem fest zugewiesener Hostname (option host-name), MAC-Adresse (hardware ethernet) des Clients und fest zugewiesene IP (fixed-address) des Clients fest vorgegeben sind. Nicht bekannte Clients, die Teil des Netzwerkes werden können/sollen und zwischendurch mal Gast sind, können wie üblich, über einen festgelegten DHCP-Adress-Pool (range dynamic-bootp) bedient werden.

MetallSnake:

Hat Dein Client einen Hostnamen bei sich konfiguriert (Systemeinstellungen Freigaben Gerätename)? Ist in der Konfiguration Deines DHCP-Servers ein zur MAC-Adresse des Clients zugehöriger Hostname spezifiziert? Stimmen die beiden Hostnamen an diesen beiden Orten überein (sollten/müssen sie)?
0
MetallSnake
MetallSnake10.12.1116:40
sunni
Zunächst mal, ein Netzwerkgerät fragt keine bestimmte IP-Adresse an. Ein Netzwerkgerät fragt im Netzwerk einen DHCP-Server und bekommt im besten Fall eine IP. Irgendeine von dem am schnellsten antwortenden DHCP-Server.

Ja so sollte es sein, aber tatsächlich wird Discover und Offer übersprungen, der Mac sendet direkt DHCPRequest und der Router antwortet mit DHCPAck.
sunni

Weil der Systemprofiler aber nicht immer die immer die volle Wahrheit sagt, kannst auch über das Terminal herausfinden, von wem die IP-Adresse gekommen ist. Der Eintrag 'siaddr' ist der DHCP-Server.
ipconfig getpacket <en0> / <en1>
(en0 für Ethernet; en1 für Wi-Fi)

Da ist der korrekte Router angegeben.

sierkb
Hat Dein Client einen Hostnamen bei sich konfiguriert (Systemeinstellungen Freigaben Gerätename)? Ist in der Konfiguration Deines DHCP-Servers ein zur MAC-Adresse des Clients zugehöriger Hostname spezifiziert? Stimmen die beiden Hostnamen an diesen beiden Orten überein (sollten/müssen sie)?

Unter Freigaben ist der Standard Gerätename angegeben. Im Router habe ich aber keine Möglichkeit einen Hostnamen anzugeben.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
MetallSnake
MetallSnake10.12.1116:43
chill
Ist nur leider nicht Praktikabel immer wieder die Regeln fürs Port Forwarding etc. anzupassen

man kann die ports in den allermeisten routern auch IP übergreifend freigeben. echt

??? Du redest von der Firewall? Ich rede vom Port forwarding, das KANN gar nicht IP übergreifend funktionieren, sonst bräuchte man es ja nichtmal.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
ken-o-bi10.12.1117:40
MetallSchlange
Lies doch mal den Hinweis von Blubs! Trag Deine feste IP unter „Netzwerkeinstellungen“ im Aufklappmenü „Manuell“ an Deinem Macintosh manuell ein. Solang die nicht mit dem vom DHCP-Server vergebenen Bereich kollidiert, müsste ja alles passen. Ein Trick: Meist vergibt der DHCP IP-Adressen in der Reihenfolge wie sich die Geräte anmelden: .1, .2, .3 etc. Gib Deinem Mac eine Nummer aus dem Endbereich von IP-Adressen (beispielsweise .99) und Du solltest Ruhe haben.
0
MetallSnake
MetallSnake10.12.1119:08
Joa, so bin ich aktuell drin, aber das ist ja nur um das Problem zu umgehen, es soll aber schon über DHCP funktionieren!
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
Skywalker
Skywalker10.12.1119:19
Wäre mal interessant zu wissen, welchen Router du überhaupt verwendest.
0
Nemo_G
Nemo_G10.12.1120:26
Es wäre schon mal gut zu wissen,
  • welche Adressen Dein DHCP-Server generell vergibt
  • im DHCP-Server speziell hintelegte MAC-Adresse mit manuell zugeordneter IP
  • welche IP-Adresse Dein Mac an welchem LAN-Anschluss erhält
  • mehr als ein Netzwerkanschluss (LAN, WLAN) im Mac?
  • alle MAC-Adressen des Macs
Bitte alle Werte auslesen und hier dokumentieren, sonst stochert man nur mit einer Stange im Nebel herum!
0
o.wunder
o.wunder10.12.1121:43
chill
man kann die ports in den allermeisten routern auch IP übergreifend freigeben. echt
Port Forwarding ist nicht das Gleiche wie Port Freigabe. Für die Port Freigabe hast Du Recht, aber für das Port Forwarding (Weiterleitung) muss man eben die IP Adresse des Gerätes angeben zu denen Daten die über bestimmte Ports reinkommen, weitergeleitet werden sollen und dafür braucht man eine feste IP Adresse, geht nicht anders.

0
o.wunder
o.wunder10.12.1121:44
Vielleicht passt die Netzwerk Maske nicht?
0
MetallSnake
MetallSnake10.12.1122:58
o.wunder
Vielleicht passt die Netzwerk Maske nicht?

Die wird auch per DHCP übertragen und ist korrekt. (255.255.255.0)
Nemo_G
Es wäre schon mal gut zu wissen,
  • welche Adressen Dein DHCP-Server generell vergibt
  • im DHCP-Server speziell hintelegte MAC-Adresse mit manuell zugeordneter IP
  • welche IP-Adresse Dein Mac an welchem LAN-Anschluss erhält
  • mehr als ein Netzwerkanschluss (LAN, WLAN) im Mac?
  • alle MAC-Adressen des Macs
Bitte alle Werte auslesen und hier dokumentieren, sonst stochert man nur mit einer Stange im Nebel herum!


Die vergebenen Adressen sind 192.168.0.100 bis 200
hinterlegt ist meine MAC von en0 mit der ip 192.168.0.100
Er bekommt die 192.168.0.125 und ist an LAN 1 angeschlossen
Der Mac ist ein MBP 1,1 hat also en0, en1 und fw0
en1 und fw0 sind deaktiviert.
Skywalker
Wäre mal interessant zu wissen, welchen Router du überhaupt verwendest.

LevelOne WGR-6012 Firmware Version ist R0.29h0_1228
Auf dem Mac läuft Mac OS X 10.6.8
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
Hagbear
Hagbear11.12.1109:56
Ändere mal testweise den Bereich so, dass die .125 nicht mehr mit drin liegt und schau was dann passiert, oder sogar ein ganz anderen Bereich. Hatte auch schon mal ein ähnliches Problem, dort hat das Umstellen und wieder zurück geholfen.
0
o.wunder
o.wunder11.12.1110:19
ja wie Hagbear schon sagte und vielleicht nicht gerade die erste IP Nummer des Bereiches an den Rechner vergeben sondern erst ab der zweiten.
0
sierkb11.12.1110:51
Hagbear
Ändere mal testweise den Bereich so, dass die .125 nicht mehr mit drin liegt


Gib dem Router die 1, also 192.168.0.1. Als Erstem Gerät das von ihm betriebenen Netzes 192.168.0.0 ()ich baue gewohnheitsmäßig lieber auf einem 192.168.1.0-Netz auf. Nicht mittendrin. Und der variable Range geht dann los bei der 2 und geht bis 254 (die Adresse mit der Endziffer 255 ist die sog. Broadcast-Adresse, also gerichtet an alle Rechner dieses Netzes), also 192.168.0.2 - 192.168.0.254. Und wenn Du feste IPs einbauen willst, dann am logischsten vor dem variablen Teil einbauen, also feste IPs meinetwegen Endziffer 10 bis 100. Und ab 101 bis 254 kommt dann der variable Nummernbereich. Leicht zu merken. Und logisch.
0
Nemo_G
Nemo_G11.12.1112:27
Gib doch bitte noch mal Deine MAC-Adressen hier an
  • die im DHCP-Server hinterlegte(n)
  • ALLE von Deinen Netzwerkkarten (auch fw0)
Aktiviere mal probeweise en0 und en1 und hinterlege im DHCP-Server für beide feste IPs!
0
MetallSnake
MetallSnake11.12.1119:12
Hagbear
Ändere mal testweise den Bereich so, dass die .125 nicht mehr mit drin liegt und schau was dann passiert, oder sogar ein ganz anderen Bereich. Hatte auch schon mal ein ähnliches Problem, dort hat das Umstellen und wieder zurück geholfen.

Interessant, habe dann eine IP aus dem neuen Bereich bekommen. Aber wieder nicht die eigentlich vergebene.
o.wunder
ja wie Hagbear schon sagte und vielleicht nicht gerade die erste IP Nummer des Bereiches an den Rechner vergeben sondern erst ab der zweiten.

Hat leider auch nichts gebracht.
sierkb

Gib dem Router die 1, also 192.168.0.1. Als Erstem Gerät das von ihm betriebenen Netzes 192.168.0.0 ()ich baue gewohnheitsmäßig lieber auf einem 192.168.1.0-Netz auf. Nicht mittendrin.

Das war von anfang an so, dass der Router die 1 hat.
sierkb
Und wenn Du feste IPs einbauen willst, dann am logischsten vor dem variablen Teil einbauen, also feste IPs meinetwegen Endziffer 10 bis 100. Und ab 101 bis 254 kommt dann der variable Nummernbereich. Leicht zu merken. Und logisch.

Die festgeteilte IP außerhalb des Pools hat auch nichts gebracht.

War anfangs ja noch der Meinung, dass es sich um einen Bug in OS X handelt (man hat ja schon öfters mal was in der Richtung gelesen). Aber mittlerweile vermute ich eher dass der Router das Problem ist, was umso blöder wäre weils ja nicht unbedingt einer aus der Grabbelkiste ist.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
chb11.12.1119:25
Kann's vielleicht sein, dass du die MAC-Adresse in einem für den Router/DHCP-Server unbrauchbaren Format eingegeben hast und der DHCP-Server dann einfach keine Übereinstimmung erkennen kann?

00-12-34-....
vs.
00:12:34:....
vs.
001234....
0
MetallSnake
MetallSnake11.12.1119:44
Nein, er akzeptiert nur Bindestriche, in der Hilfe sind die mit Bindestrichen angegeben und auch wenn ich über das Menü einen Rechner hinzufüge ist die Adresse in dem Format.

Ich befürchte, dass der Router das gar nicht kann, und obwohl der Button "Festes Mapping"/"Fixed Mapping" heißt, es dort wirklich nur um Zugangskontrolle geht, ohne dass dies Auswirkung auf den DHCP Server hat. Eine alternative Firmware scheint es für das Gerät auch nicht zu geben, find ich jetzt echt bescheuert. Nie wieder LevelOne!
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
sierkb11.12.1120:18
MetallSnake:
Das war von anfang an so, dass der Router die 1 hat.

Und welches Netz ist da von vornherein voreingestellt? Wie ich lese, nicht das von Dir genommene 192.168.0.0-Netz, sondern das 192.168.1.0-Netz. Und er Router hat werkseitig voreingestellt die 192.168.1.1. Nur mal so am Rande bemerkt, um einer evtl. möglichen Fehlkonfigurationen Deinerseits auf die Schliche zu kommen, die von der Werkseinstellung abweicht und ggf. irgendwo was Unkorrektes eingetragen ist. Hast Du irgendwo sonst noch ein solches Netz laufen? Oder grenzt ein anderes 192.168.0.0-Netz oder 192.168.1.0-Netz an Dein Netz (per LAN/WLAN in der Wohnung oder im Haus), sodass sich da evtl. was überlappt und Daten-Pakete irrtümlicherweise vom einen ins andere Netz wandern können bzw. sich da irrtümlicherweise eine Seite angesprochen fühlt, die sich nicht angesprochen fühlen sollte?

Zudem
@all:

Handbücher zu dem Gerät:

LevelOne WGR-6012 Quick Installation Guide (PDF, 774.71 kB)
LevelOne WGR-6012 User Manual (PDF, 4.87MB)

Ich lese mir auch gerade mal das zugehörige Handbuch durch bzw. überfliege es mal. Wäre nett, wenn das noch jemand täte. Viele Augen sehen mehr als zwei.
0
MetallSnake
MetallSnake11.12.1120:41
Sorry, meinte damit dass ich es direkt beim einrichten so eingestellt habe. das 0er Netz kommt daher, dass vorher ein D-Link dort stand die standardmäßig das 0er Netz haben.
Ich habe sonst aber keine weiteren Netze.

Und wie gesagt gehe ich mittlerweile fest davon aus, dass der Router keine festen IPs per DHCP vergeben kann.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
sierkb11.12.1121:07
MetallSnake
Und wie gesagt gehe ich mittlerweile fest davon aus, dass der Router keine festen IPs per DHCP vergeben kann.

Wenn ich mir das User Manual zu Deinem Gerät so durchlese, geht das auf den ersten Blick vielleicht nicht, weil man da wohl nur einen Adress-Pool definieren kann, möglicherweise geht's aber doch: Kapitel 3.3.3.4 Internet Access Control MAC control im Bereich "Security Settings" (User Manual Seite 49ff).
Sprich: man kann einzelnen Clients, denen er zuvor eine IP zugewiesen hat aus dem Pool und die die er folglich erkannt hat, Zugriffsrechte definieren, die er auch behält. Und wie soll er Zugriffseinstellungen für einzelne Clients, deren MAC-Adresse, deren zugewiesene IP-Adresse er kennt, behalten, wenn er nicht unter der Haube genau sowas in seiner dhcpd-Konfiguration ablegt, wie ich obig geschildert habe: einzelne, fest zugewiesene Client-Konfigurationen mit fest zugeordneter MAC-Adresse und fest zugeordneter IP-Adresse (die zwar aus seinem Adress-Pool stammt, an dieser Stelle der Konfiguration für das betreffende Client-Gerät aber trotzdem fest zugeordnet ist und bleibt).
0
MetallSnake
MetallSnake12.12.1117:51
sierkb
Ja die MAC control ist genau das wo ich die IP zu MAC eingetragen habe. Es könnte natürlich sein, dass der Router davon ausgeht, dass die Clients die IP Manuell angeben wenn die schon ne feste haben sollen, oder von einem anderen DhCP Server bekommen.
Bescheuert aber für mich momentan die einzige Erklärung.
„Die Menschheit ist eine völlig außer Kontrolle geratene Primatenspezies.“
0
Blubs
Blubs12.12.1118:16
Was hindert Dich denn an einem lokalen Eintrag der IP?
Du hast doch sicherlich keine 800 Macs zu Hause, bei denen Du Privatadmin spielen musst?
Bei unter 10 Geräten ist das doch kein Problem.
0
o.wunder
o.wunder14.12.1103:18
Wenn der Router aus dem Pool immer die gleiche Adresse an den gleichen Rechner vergibt, dann ist das Problem doch gelöst und Du schreibst das Port-Forwarding einfach auf diese vergebene Adresse. Fall gelöst.

Geht natürlich nicht wenn der Router immer eine andere IP vergibt, was aber eher untypisch ist.
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.