Forum>Netzwerke>gleicher iMac erscheint 4 mal in Freigaben??

gleicher iMac erscheint 4 mal in Freigaben??

dode1963
dode196319.11.1309:19
Liebe Leute
Ich verstehe das nicht. Bei mir erscheint der gleiche iMac 4 mal in den Freigaben (siehe Bild). Der iMac hiess ursprünglich iMad Alu 1. Mit der Zeit erschien neben iMac Alu 1 auch iMac Alu 1(2) und später noch iMac Alu 1 (3). Wollte ich in Freigaben den Namen wieder auf iMac Alu 1 setzen, hiess es, es befindet sich bereits ein Mac mit diesem Namen im Netz. In der Hoffnung etwas Ordnung in die Sache zu bringen, änderte ich den Namen des iMacs auf iMac Alu Snow Leopard und startete alle Router neu. Nun habe ich den iMac 4 mal in Freigaben. Der iMac hängt an einer AirPort Extreme, an der noch weitere Macs angeschlossen sind. Für alle Macs dient eine externe USB Festplatte an dieser AirPort für das Time Machine Backup. Die AirPort selber ist teil eines grösseren Netzes, das über eine Fritzbox ans Internet angeschlossen ist. Die Macs im Netz haben unterschiedliche Betriebssysteme: Snow Leopard, Mountain Lion, Mavericks. Alle anderen Macs werden nur einmal angezeigt.

Irgend eine Idee, wie ich in Freigaben wieder die tatsächlich vorhandenen Geräte gelistet bekomme?
0

Kommentare

Marcel Bresink19.11.1309:46
Falls nicht wirklich mehrere Rechner den gleichen Namen tragen, deutet dieser Effekt üblicherweise darauf hin, dass ein Konfigurationsfehler im Netz vorliegt, der dazu führt, dass der iMac sich selbst als Spiegelbild im Netz sieht, aber nicht ermitteln kann, dass er das selbst ist.

Das könnte zum Beispiel eine versehentlich gebaute "Schleife" zwischen Ethernet und WLAN sein oder der Rechner verwendet dieselbe IP-Adresse für mehrere Anschlüsse, oder es gibt einen DHCP-Konflikt, etc. In sehr seltenen Fällen kann auch eine fehlerhaft arbeitende Netz-Software Bonjour so durcheinanderbringen, dass ein solches Problem auftritt.

Es kann mühsam sein, diesen Fehler zu finden. Ist die Airport Extreme vielleicht fälschlicherweise als Router konfiguriert und nicht als Bridge?
0
Marcel_75@work
Marcel_75@work19.11.1310:36
Für den Anfang (um das Problem weiter einzugrenzen) würde ich Dir mal folgendes empfehlen:

Die folgenden Befehle einzeln im Terminal ausführen (mit --get werden die derzeit gesetzten Werte ausgelesen) und die 3 Ergebnisse hier posten:

scutil --get ComputerName
scutil --get HostName
scutil --get LocalHostName

Per scutil --set würde ich Dir dann empfehlen, diese Werte neu zu setzen, z.B. so:

scutil --set ComputerName iMac-dode1963
scutil --set HostName iMac-dode1963.fritz.box
scutil --set LocalHostName iMac-dode1963

Außerdem würde ich möglichst allen Geräten feste IPs zuweisen, also z.B.:

Router (Fritz.Box): 192.168.178.1
Airport Extreme: 192.168.178.2
iMac: 192.168.178.3

u.s.w.

Den DHCP-Bereich der Fritzbox dann auf einen Bereich "weiter oben" umstellen, z.B.:

DHCP-Bereich: 192.168.178.200 bis 192.168.178.254

Außerdem überprüfen, dass wirklich nur ein Gerät im Netzwerk als DHCP-Server läuft, also z.B. nur die Fritz.Box (und nicht noch zusätzlich die Airport Extreme Station). Ein GAU sind oft mehrere DHCP-Server, die sich in die Quere kommen und die verrücktesten Sachen im Netz veranstalten ...
0
dode1963
dode196319.11.1321:47
Liebe Leute
Vielen Dank für die Hilfe. Ich habe einmal die AirPort abgehängt und durch einen Switch ersetzt. Alles neu gestartet. Sämtliche Nebennetze abgehängt, so dass nur noch drei Computer in einem Netz waren. Die Phantom-iMacs bleiben! AirPort ist auf Router aus (Bridge) Modus.
Mit den Terminbefehlen bekomme ich:
scutil --get ComputerName iMac-1 (den Namen habe ich vorher dem Computer auch via Freigabe gegeben)
scutil --get HostName not set (da stimmt vielleicht etwas nicht)
scutil --get LocalHostName iMac-1

Ich habe wie von Marcel_75@work empfohlen die Namen gesetzt. --get HostName gibt jetzt einen Wert aus.
IP manuel zuweisen löscht die Phantom-iMacs auch nicht.
Ob wir im Netz ein Gerät haben, dass als DHPC-Server läuft, kann ich nicht ausschliessen. Halte ich aber für eher unwahrscheinlich. Es ist nur diese eine iMac, der mehrfach gelistet wird. Alle anderen nicht. Liegt das Problem bei diesem iMac?
0
Marcel_75@work
Marcel_75@work19.11.1323:49
Mmh, nicht einfach, das aus der Ferne zu analysieren ...

Hättest Du noch Mac OS X 10.0 bzw. 10.1 im Einsatz (was mit Sicherheit nicht der Fall ist), wäre es hilfreich, das slp.regfile (SLP = Service Location Protocol) in /private/var zu löschen ... Aber das ist lange her.

Ich würde dem iMac in jedem Fall mal eine andere feste IP zuweisen (am besten eine, die von keinem anderen Gerät vorher benutzt wurde) und dann den DNS Cache löschen:

sudo dscacheutil -flushcache
sudo killall -HUP mDNSResponder

Danach würde ich mir mal die Voreinstellungsdatei des Bonjour-Services näher ansehen (zu finden in /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist).

Zugriffsrechte unter 10.9 sind folgende:

Owner root darf lesen und schreiben
Group wheel darf lesen
Everyone darf lesen


Gegebenenfalls die Zugriffsrechte mit dem Festplattendienstprogramm reparieren.

Dann den Bonjour-Dienst anhalten:

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

Danach diese plist mal umbenennen (also sozusagen als Backup sichern an anderer Stelle) und den Rechner dann 1x neu starten. Die plist müsste dadurch frisch neu angelegt werden.

Ok?
0
dom_beta20.11.1317:58
Hallo,

ich empfehle folgendes:

Klemm den Mac von Netz ab, WLAN & Co. deaktivieren.

Dann unter Systemeinstellungen > Freigaben den bevorzugten Namen eintragen.

Dann bitte alle Netzwerkgeräte ausschalten; also Stecker ziehen bei Switches, WLAN-Stationen und Co.

5 Minuten warten und in umgekehrter Reihenfolge wieder einschalten.

Dann dürfte sich das Problem von selbst erledigen.
„...“
0
dode1963
dode196320.11.1321:36
Marcel_75@work: Vielen Dank für die Tipps. Habe fast alles probiert. Für die Reparatur der Rechte hatte der iMac sehr lange gebraucht. Dennoch: Phantom iMacs sind immer noch. Die Sache mit dem Bonjour-Dienst muss ich noch probieren.

dom_beta: Vielen Danke. Werde ich auch einmal versuchen. Ich habe zwar schon zigmal alles neue gestartet, aber nie mehrere Minuten alles ausgeschaltet gelassen. Mal probieren. Mit "in umgekehrter Reihenfolge" meinst du: 1. iMac, 2. Switch, 3. Router oder 1. Router, 2. Switch, 3. iMac?
0
dom_beta20.11.1321:52
dode1963
Mit "in umgekehrter Reihenfolge" meinst du: 1. iMac, 2. Switch, 3. Router oder 1. Router, 2. Switch, 3. iMac?

Ausschalten:

1. alle Computer

2. alle sonstigen Netzwerkgeräte (WLAN, Switches, ...)

Einschalten

1. alle Netzwerkgeräte (WLAN, Switches, ...)

2. alle Computer (oder erst einmal 1 Computer)
„...“
0
dode1963
dode196321.11.1307:58
Danke dom_beta.
0
virk
virk21.11.1315:20
Vielleicht mal unter "Gehe zu" den "Gehe zum Ordner…"-Menüpunkt anwählen, dann "/volumes" eintippen und dann mal posten, was er anzeigt.
Wir hatten mal ein ähnliches Problem, nur ging das nicht um die Rechner, sondern um die volumes.
„Schön fand ich damals: Auf die Dauer hilft nur Power!“
0
dode1963
dode196321.11.1317:27
Ich habe nun alles Probiert inklusive alle Geräte längere Zeit ausschalten und gestaffelt starten. Auch das mit dem Bonjour-Dienst. Hat alles nichts gebracht. Die Phantom-iMacs sind auch dann in der Liste der Freigaben, wenn der iMac, der einmal so geheissen hat, ausgeschaltet ist.

virk: Das kommt dabei heraus:
0
dom_beta21.11.1317:47
ähem, hast du auch die Freigabedienste beendet?

Denn die verschlucken sich mal gerne und dann müssen sie beendet werden.

es sollte so aussehen.
„...“
0
Marcel_75@work
Marcel_75@work21.11.1318:25
Also wenn in der Seitenleiste des Finders alte Einträge auftauchen mit Rechnern, die so gar nicht mehr im Netz aktiv sind (also angeschaltet sind), deutet das ja eher auf ein Problem mit den Finder-Preferences hin, in diesem speziellen Fall:

com.apple.sidebarlists.plist

Bitte lege mal einen neuen Benutzer an und schaue, ob dort auch diese Geister-iMacs auftauchen.

Eventuell auch mal zusätzlich zur Sidebar-plist die vom Finder selbst weg hauen:

com.apple.finder.plist

In den Developer Previews von Mavericks gab es z.B. den bug, dass man einige Finder-Einstellungen erst einmal aus und wieder an (bzw. an und wieder aus) schalten musste, damit sie korrekt angelegt werden. Eventuell ist das ja Dein Problem?

Ist das System ein "frisch installiertes Mavericks" oder ein Mavericks, welches von 10.6/10.7/10.8 aus "drüber gebügelt" wurde?
0
virk
virk21.11.1318:26
Okay! Dann war das nicht der Fehler, den wir schon einmal hatten. Schade!
„Schön fand ich damals: Auf die Dauer hilft nur Power!“
0
dom_beta21.11.1318:32
Marcel_75@work
Ist das System ein "frisch installiertes Mavericks" oder ein Mavericks, welches von 10.6/10.7/10.8 aus "drüber gebügelt" wurde?

dode1963 verwendet Mac OS X 10.6.

Das erkenne ich am Bildschirmfoto.
„...“
0
dode1963
dode196322.11.1312:25
Ja, der iMac, der die Geister-iMac verursacht, hat OS X 10.6. Daneben haben wir noch Mac mit 10.8 und 10.9 im Netz, diverse iOS-Geräte, auch Android, Drucker, Repeater ......
Ich habe alle eure Tipps befolgt - mehrmals. Das Ergebnis ist immer das gleiche: Geister-iMacs im Finder, bei allen Macs, auch auf dem, der sie verursacht hat. Ich glaube, damit werde ich wohl leben müssen.

Dennoch: Vielen Dank an euch für die Hilfe.
0
dom_beta22.11.1314:22
Hast du denn wirklich alle Freigabedienste beendet?
„...“
0
dom_beta22.11.1316:05
Apropos, du kannst ja mal folgendes versuchen.

Wie gesagt, WLAN & Co. beim Mac deaktivieren, ebenso die Freigabedienste

Dann gehst du nach

Mac HD / Library / Preferences

und löscht den Ordner "SystemPreferences"

anschließend den Computer ausschalten NICHT neu starten!

So 5 Min. warten und wieder einschalten.
„...“
0
dode1963
dode196323.11.1314:01
Lieber dom_beta
Herzlichen Dank für deine Beiträge (ja, alle Freigabedienste beendet). Ich werde deinen letzten Lösungsvorschläge versuchen. Allerdings habe ich nicht viel Hoffnung. Die Geister-iMacs sind ja auch im Netz, wenn der "Verursacher" ganz von Netz getrennt und das Netz neu hochgefahren ist. Wie kann dann der Ordner "System Preferences" Probleme verursachen?
Gestern hatten wir einen Netzwerkspezialisten bei uns. Wir haben vier Netzwerke in vier verschiedenen Gebäuden, die miteinander vernetzt sind. Fast täglich fällt in einem Gebäude das Netz aus. Startet man es dort neu, funktioniert es dort wieder, dafür fällt in einem anderen Gebäude das Netz aus und so weiter. Ich habe ihm die Sache mit den Geister-iMacs gezeigt. Gross geäussert hat er sich nicht dazu. Eigentlich hat er nur die Stirn gerunzelt. Dann hat er sich ums andere Problem gekümmert. Er konnte keinen wirklichen Grund für die anderen Probleme finden. Er vermutet, dass der Switch im Hauptgebäude, von dem aus die Leitungen zu den anderen abgehen, zu "schwach" ist (ist unmanaged). Er empfiehlt uns einen managed Switch. Wir werden uns in den nächsten Tagen einen anschaffen und einrichten. Vielleicht hilft er auch bei den Geister-iMacs. Ich werde darüber berichten.
0
dom_beta23.11.1314:11
Hallo dode1963,

tja, wie gesagt, entweder wie von dir geschrieben, ein Hardwarefehler im Netzwerk, eventuell defekte Kabel, defekte Switches/etc. oder wie von mir geschrieben, dass der Fehler in diesem Ordner liegt.

Ich hatte mal einen ähnlichen Fehler


eigentlich sollte dieser Schritt den Fehler beheben.

Ach so, wenn du den Ordner gelöscht hast und den Computer wieder einschaltest, musst du bevor du irgendwelche Dienste & Co. aktivierst unter Systemeinstellungen > Freigabe wieder einen richtigen Computernamen eingeben.

Apropos, kann es sein, dass de Computername zu lang ist?

vgl.





MfG
„...“
0
dom_beta03.12.1321:55
Hallo,

und, wurde das Problem schon gelöst?

Würde mich auf eine Rückmeldung freuen.
„...“
0
dode1963
dode196304.12.1321:05
Lieber dom_beta

Nein, das Problem ist noch nicht gelöst. Ich hatte in letzter Zeit auch keine Zeit mehr, mich darum zu kümmern. Ich werde deinem Tipp sicher in den nächsten Tagen folgen und einen weiteren Versuch wagen. Dann berichte ich. Danke für deine Hinweise!
0
dode1963
dode196305.12.1316:32
Also dom_beta, hier, was ich gemacht und erreicht habe:

1. Router, AirPort und Switches im Hauptnetz ausgeschaltet.
2. In allen 5 Macs im Hauptnetz den Ordner Library/Preferences/SystemConfiguration gelöscht.
3. Alle Macs im Hauptnetz für mehrere Minuten ausgeschaltet.
4. Router, AirPort und Switches neu gestartet.
5. Alle 5 Macs im Hauptnetz vom Netz getrennt gestartet.
6. In allen Macs den Rechnername neu gesetzt.
7. Einen Mac nach dem anderen wieder ans Netz angeschlossen.

Bereits nach dem ersten Mac am Netz erschienen die Geister-iMacs wieder.

Die Namen der Macs sind sicher nicht zu lang.

Das Problem ist also noch nicht gelöst.

Aber:

Ich habe das Prozedere in verschiedenen Varianten durchgespielt. Beim ersten Versuch gingen die Macs gleich nach dem Neustart wieder ans Netz. Dabei ist mir aufgefallen, dass das System beim Neustart dem Rechner einen Namen gibt: "Mac4556-54651-sfg" oder so ähnlich. Dieser Name erscheint in den "Finder/Freigaben" der anderen Rechner, aber nicht in "Systemeinstellungen/Freigaben" des jeweiligen Computers. Dort steht nichts (=Feld ist leer). Setze ich einen Rechnername in "Systemeinstellungen/Freigaben" verschwindet der automatisch generierte Rechnername in Finder/Freigaben der anderen Rechner und der neu gesetzte Name erscheint. Das verhält sich also logisch. Beim iMac, von dem die Geister-iMacs in Finder/Freigaben aller Macs im Netz stammen, ist das aber anders. Dort erscheint der automatisch erzeugte Rechnername auch im eigenen Finder/Freigaben und verschwindet dort, wenn der Name in Systemeinstellungen/Freigaben neu gesetzt wird. Der neu gesetzte Name erscheint dann aber nicht im eigenen Finder/Freigabe. Irgendwie merkwürdig.
0
dom_beta05.12.1317:53
Hast du die Freigabedienste nicht beendet?
„...“
0
dom_beta05.12.1318:13
Korrektur.

dode1963
Ich habe das Prozedere in verschiedenen Varianten durchgespielt. Beim ersten Versuch gingen die Macs gleich nach dem Neustart wieder ans Netz. Dabei ist mir aufgefallen, dass das System beim Neustart dem Rechner einen Namen gibt: "Mac4556-54651-sfg" oder so ähnlich.

Ja, "Mac-irgendetwas" ist ein von OSX generierter Standardname.

Am besten wäre es gewesen, die Freigabedienste unter Systemeinstellungen > Freigaben zu beenden, bevor man daran was ändert.

Ach so ja, bevor du überhaupt an der Konfiguration irgendetwas änderst, trenne bitte deine Macs physikalisch vom Netz, also WLAN deaktivieren und beim LAN das Kabel herausziehen.
„...“
0
dom_beta05.12.1318:28
interessanter Artikel von Microsoft

„...“
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.