Forum>Entwickler>Unicode Zeichen macht Skripte unbrauchbar

Unicode Zeichen macht Skripte unbrauchbar

FabiLig25.01.2120:08
Moin zusammen,

seit einiger Zeit taucht immer wieder das Unicode Zeichen:

„\u00a0“ „NO-BREAK SPACE“

in meinen Skripten und beim tippen auf der Kommandozeile auf (Apple Terminal).

Gefühlt werden manche Leerzeichen zu diesem Zeichen und entsprechend können Befehle nicht ausgeführt werden oder Dateiumlenkungen funktionieren nicht usw.

Ich habe keine Ahnung wie es dazu kommt und konnte keine Regelmäßigkeit feststellen. Auszutreten scheint es seit BigSur, aber auch auf mittels ssh verbundenen Servern (Linux).
Das Phänomen hat auch noch ein Freund ebenfalls mit Macbook.

Evtl. hat einer von euch ja eine Idee...


System:

MacOS 11.1
MacBook Air
Apple Terminal
Build-in Keyboard
0

Kommentare

Dirk!26.01.2108:48
Passiert das vielleicht, wenn man beim Drücken der Leerzeichentaste Shift oder Alternate noch nicht losgelassen hat?

Oder hast Du ein MacBook Air mit Butterfly Keyboard und eine dieser beiden Tasten „klemmt“.
+2
germansnowman26.01.2109:06
Es scheint tatsächlich Option-Space zu sein. Hier ein Tip, wie man das ändern kann:
+3
void
void26.01.2110:30
Jap das Problem habe ich auch oft in der Shell, meistens weil ich die Option-Taste für das Pipe-Symbol noch gedrückt halte und dadurch das nachfolgende Space kaputt mache:

% echo "foo" | wc -c
zsh: command not found:  wc
„Developer of the Day 11. Februar 2013“
+1
FabiLig26.01.2113:53
Hallo zusammen,

das Problem lies sich entsprechend der verlinkten Lösung beheben und ich konnte über diese unsägliche Tastenkombination auch das Problem reproduzieren....

wie void schon geschrieben hat, ist es oft nach der Pipe aufgetaucht und ergibt jetzt entsprechend Sinn (nachher ist man ja auch immer schlauer).

Vielen Dank ihr habt es mir erspart über alles was ich tippe ein entsprechendes sed-skript laufen zu lassen.

Beste Grüße
0
MikeMuc26.01.2113:59
„die Lösung“ sorgt aber doch dafür, das die Änderung in allen Programmen vorgenommen wird? Das wäre zB bei Indesignusern tödlich
Besser ist das, wenn man doch eine Ersetzung Programmspezifische vornimmt. Das geht, sofern nicht mit Bordmitteln, zB mit BetterTouchTool.
0
winfel26.01.2114:00
void

zsh: command not found:  wc

Ist ja auch doof, wenn man das WC nicht findet (Sorry!)
FabiLig
[...] ich konnte über diese unsägliche Tastenkombination auch das Problem reproduzieren....

Naja unsäglich. Es gibt ja nicht nur Scriptschreiber und Konsolenliebhaber. Wahrscheinlich ist der Anteil bei den Mac-Nutzern sogar relativ gering. Ich habe jetzt gelernt, wie man ein Nonbreaking-Space erzeugen kann. Sehr praktisch. Vielen Dank dafür!
0

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.