IOS6.1 Safari spielt keine HTML5 Videos mehr ab...

fluppy
Wirklich seltsam, Videos werden plötzlich nicht mehr abgespielt auf meiner Testseite. Habe eine alte Version der Seite wiederhergestellt bei der die Videos funktionierten. Geht trotzdem nicht mehr.

Der Video-Tag feuert irgendwie kein "canplay"-Event, soweit ich das beurteilen kann. Leider kann ich auch nicht debuggen, da nur OSX 10.6.8. Echt blöd!

Kennt jemand ein ähnliches Problem oder weiss jemand einen IOS Browser, der auch noch eine Debug-Console hat?

Kommentare

fluppy
Das gibt es ja nicht!

Apple hat autoplay in html5 videos entfernt in IOS 6.1, entweder ein Bugoder ein Feature!! So ein Schrott! Unfassbar.

Testvideo
http://flowplayer.blacktrash.org/test/videotag-autoplay.html

https://github.com/flowplayer/flowplayer/issues/238
fluppy
Ok wens interessiert: Apple hat seit IOS 4.2 autoplay in HTML5 Video-Tags deaktiviert (wäre toll, wenn es bei WIFI-Verbindung aktiviert wäre!).

In IOS 6.0 war ein Bug, der Autoplay wieder aktivierte. Das wurde mit IOS 6.1 behoben.

So richtig toll finde ich das nicht.
Gerry
Geht auch nicht mit OS X. Zumindest bei mir nicht.
Muss man einen anderen Browser nehmen.
In IOS 6.0 war ein Bug, der Autoplay wieder aktivierte. Das wurde mit IOS 6.1 behoben.
Na super… hab mich schon gefreut.
MacRudi
Wie sieht es mit Webkit aus? Geht es da noch oder schon wieder?
„Entdecke die Möglichkeiten“
fluppy
Nee, man muss leider bei der Programmierung mit einplanen, dass IOS-Browser immer ein touch- oder click-Event auf das HTML5-Video erwarten, solange bleibt die Videofläche schwarz.

d.h. wie in meinem Fall, eine Webseite mit Hintergrund-Vollbildvideo, hat eine riesige schwarze Fläche, bis der User sie anklickt.

Meiner Meinung nach völlig bescheuert, oder nur sinnvoll, wenn keine WLAN-Verbindung vorhanden und das Video eine bestimmte Grösse überschreitet. Oder eine Option in den Safari-Einstellungen dafür... Aber so weit denken die bei Apple leider nicht. Die Firma Apple glaubt an ihre Sonderwege, weil sie sich um Kompatibilität nicht schert,sich als Monopolist fühlt....
fluppy
Gerry
Geht auch nicht mit OS X. Zumindest bei mir nicht.
Muss man einen anderen Browser nehmen.
Wie was? Welche Safari-Version? Bist Du sicher? Bei meinen Safaris und Webkits unter OSX geht das Autoplay. Welches OSX?
MacRudi
In Safari 6.0.3 unter 10.7.5 geht das Autoplay von http://flowplayer.blacktrash.org/test/videotag-autoplay.html

Kannst Du das Abspielen nicht mit JavaScript anstoßen?
„Entdecke die Möglichkeiten“
fluppy
Ah gut zu wissen, habe nämlich nur Snow Leopard / Safari 5.13. Der Gerry hatte mir schon Angst gemacht

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.

Ihre ersten Erfahrungen mit OS X Yosemite?

  • Hervorragend, ein perfektes und zuverlässiges Update29,4%
  • Ein gutes und weitgehend zuverlässiges Update, bin zufrieden41,5%
  • Tendenziell zufrieden12,9%
  • Bin mir noch unschlüssig8,0%
  • Tendenziell unzufrieden4,2%
  • Ein schlechtes und weitgehend unzuverlässiges Update, bin unzufrieden1,3%
  • Bin entsetzt, Yosemite ist totaler Murks2,7%
673 Stimmen20.10.14 - 22.10.14
8643