Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Software>Magic Mouse wird als Mighty Mouse erkannt

Magic Mouse wird als Mighty Mouse erkannt

Multimediawespe06.12.1020:42
Hallo, musst heute was zwecks Mausbeschleunigung im Terminal ändern, seitdem wird meine Magic Mouse als Mighty Mouse erkennt, dazu ist die Geschwindigkeit komplett anders und das Scrollen funktioniert nicht mehr.
Wie kann ich den Terminal komplett zurücksetzen, genau so, wie er war, als ich den Mac bekommen habe?

Ich habe schon versucht die datei com.apple.terminal.plist zu löschen, aber die existiert überhaupt nicht...
0

Kommentare

Multimediawespe06.12.1021:04
Okay, ich hab in der falschen Library gesucht, die Datei existiert doch. Das Löschen hat aber nichts gebracht.
Übrigens sind auch alle zusätzlichen Programme gelöscht, die irgendetwas mit der Maus zu tun haben... ich hab keine Ahnung, was ich jetzt noch machen soll.

Oder wie kann ich den Maustreiber neu installieren?
0
Mowgli06.12.1021:18
Ich kann dir glaub ich net wirklich weiter helfen, aber währst du mal so lieb und würdest mehr Infos geben, was du genau im Terminal gemacht hast. Also was genau der Auslöser war. Sonst stochern die Anderen doch recht arg im Brühschlamm...
0
Mowgli06.12.1021:20
Ok gleich mal nen neuen Post aufmachen... ok vergiss meinen Einwand... Ich bin verwirrt.
0
Multimediawespe06.12.1022:09
Müsste etwas in der Art von

defaults write .GlobalPreferences com.apple.mouse.scaling -1

gewesen sein, weiß es aber nicht mehr genau... habs ins Terminal eingegeben und dann geschlossen, weil die Mausbeschleunigung immer noch da war.
Ich hab auch mal danach gegooglet, da hatte jemand GENAU das gleiche Problem, es wurde aber keine Lösung gefunden...
0
_mäuschen
_mäuschen06.12.1022:49

Nach diesem Befehl müsstest Du Neustarten.

0
Multimediawespe06.12.1023:40
Ist ja im Prinzip egal, da ich ja com.apple.terminal.plist gelöscht habe.
Ich befürchte, dass die einzige Lösung eine Neuinstallation des Maustreibers ist. Die Frage ist nur, wie ich das mache...
falls es keine andere Lösung gibt.
0
kawi
kawi06.12.1023:47
Du hast "irgendwas" ins Terminal eingegeben, weisst aber nicht mehr was und wir sollen nun raten oder besser wissen was du dir da verstellt hast? Und was genau soll das löschen der Einstellungsdatei für das Programm Terminal bringen wenn du doch was an den Mauseinstellungen geändert hast?
com.apple.terminal.plist enthält nämlich NICHTS anderes als die Voreinstellungen zum Programm Terminal. Und hat NICHTS damit zu tun was du mit dem Terminal an deinem System anrichtest.

0
chill
chill06.12.1023:55
Tja ... Wenn man keine Ahnung hat, lieber mal sein lassen!

"ich hab da irgendwas im Terminal eingegeben ... "

OmG
„"¿ssıəɥɔs ɹəp llos sɐʍ" :ʇƃɐs əsıəʍ ɹəp 'ßıəʍ sɐʍ ɹə sɐp ßıəʍ əƃnlʞ ɹəp“
0
bernds07.12.1005:38
Multimediawespe
Ist ja im Prinzip egal, da ich ja com.apple.terminal.plist gelöscht habe.

Da steht aber nicht drinne,was du geändert hast sondern nur die Fenstergrösse vom Terminal und ähnliches
0
Multimediawespe07.12.1018:37
Da steht aber nicht drinne,was du geändert hast sondern nur die Fenstergrösse vom Terminal und ähnliches
Okay, das wusste ich nicht.
Tja ... Wenn man keine Ahnung hat, lieber mal sein lassen!
Gerade, weil ich keine Ahnung davon hab, habe ich im Internet gesucht und da stand, dass ich das ins Terminal eingeben muss, damit die Mausbeschleunigung eliminiert wird.

Aber anstatt mir Vorwürfe zu machen, wäre es nett, wenn ich wenigstens versuchen würdet, mir zu helfen. Aber kenn man von MTN leider nicht anders...

Hab aber mittlerweile herausgefunden, was ich eingegeben habe. Waren ein paar Sachen, weil alle nicht den gewünschten Effekt brachten.

defaults write .GlobalPreferences com.apple.mouse.scaling -X
defaults write -g com.apple.mouse.scaling X
0
Multimediawespe07.12.1023:16
Oder kann ich - das würde das Problem relativ einfach lösen - einfach OS X neuinstallieren, während aber alle Daten auf dem Mac bleiben?
0
TiBooX
TiBooX07.12.1023:21
Multimediawespe
Oder kann ich - das würde das Problem relativ einfach lösen - einfach OS X neuinstallieren, während aber alle Daten auf dem Mac bleiben?

ja, ist aber auch die Holzhammer Methode
Switcher ? (Antwort obsolet)
„People who are really serious about software should make their own hardware [A. Kay]“
0
daidai
daidai07.12.1023:27
Gabs nicht mal eine Installations cd mit der Mighty Mouse? Kann mich irgendwie erinnern, dass eine solche damals beim Kauf der Maus dabei war. Zumindest am Anfang. Hab leider selber keine mehr.
„Wie wir die Arbeit anschauen, so schaut uns die Arbeit wieder an.“
0
Multimediawespe07.12.1023:39
Die Maus war beim iMac dabei. Hab 2 CDs: Die Max OS X Installationsdisc & die "Applications Install DVD".
0
Esäk
Esäk08.12.1000:00
Wehe es steht irgendwo: "clean the disk"…
„Die Todesstrafe gehört auch in Hessen abgeschafft!“
0
_mäuschen
_mäuschen08.12.1000:18
_mäuschen

Nach diesem Befehl müsstest Du Neustarten.



                                               Multimediawespe

Das sag ich immer noch.

Oder danach wenigstens einmal Aus- und wieder Einloggen.

0
Böser Keks08.12.1000:31
Es ist möglich die Datei in der du gefummelt hast auszulesen mit

defaults read .GlobalPreferences

wenn du den Befehl so eingegeben hast wie er oben steht, dann hast du dort mit "X" einen nicht gültigen Wert für mouse.scaling eingetragen. Findest du entweder in der Datei oder mit

defaults read .GlobalPreferences com.apple.mouse.scaling

mit

defaults write .GlobalPreferences com.apple.mouse.scaling 1

solltest du einen normalen Wert einstellen können.
0
rene204
rene20408.12.1004:57
_mäuschen
_mäuschen

Nach diesem Befehl müsstest Du Neustarten.



                                               Multimediawespe

Das sag ich immer noch.

Oder danach wenigstens einmal Aus- und wieder Einloggen.

Tja, liebes _mäuschen...
es scheint wieder einmal niemand auf Deine guten Tipps und Ratschläge zu hören....

wirklich schade, da Du fast jedem hier schon "aus der Patsche" geholfen hast...
Ich bedanke mich bei Dir für Deine Hilfen und wünsche Dir eine gute Zeit und frohe Feiertage...
„Gelassenheit und Gesundheit.. ist das wichtigste...“
0
waxworx
waxworx08.12.1008:38
BTW:

Keiner ist auf die Idee gekommen, dass sich das Terminal Befehle merkt???
Im Userhome gibt's doch 'ne .bashrc oder .sh_history oder .bash_history oder .history
Da stehen die letzten Befehle drin die man ausgeführt hat.

Oder einfach mal
history
im Terminal eintippen


Info zu History
„Ironie im Internet ist unangebracht.“
0
tjost
tjost08.12.1008:51
Hey ich habe seit ewigkeiten das gleiche Problem. Ich probier das heute mal aus.
0
LordLasch08.12.1010:21
waxworx
Oder einfach mal
history
im Terminal eintippen

Pfeil nach oben reicht doch auch
0
Zetaline
Zetaline08.12.1010:36
Welcher Wert kommt denn wenn du im Terminal folgendes eintippst?**

defaults read -g com.apple.mouse.scaling X

Übrigens wird bei mir als Wert immer 0.5 angegeben egal ob ich das X gegen Y, Z, F, oder ganz weglasse.



Wenn ich
defaults read .GlobalPreferences

eingebe habe ich folgende Werte für Maus und Scrollrad:
"com.apple.mouse.scaling" = "0.5";
"com.apple.scrollwheel.scaling" = "0.6875";



**Ich vermute mal "-X" oder?

Das einzige was du machen solltest ist denke ich:
defaults write -g com.apple.mouse.scaling 0.5
defaults write .GlobalPreferences com.apple.mouse.scaling 0.5

…und wie schon _mäuschen schrieb, einen Neustart zu machen.

Wenn der Mac immer noch denkt es wäre eine Mighty Mouse statt Macgic Mouse angeschlossen.
Vieleicht hilft es den Kernel Extensions Cache neuanlegen lassen.
„Auf der Verpackung stand: Erfordert IBM kompatiblen PC mit Windows oder besser. Also entschied ich mich für Mac + OS X = ♥“
0
Multimediawespe08.12.1016:37
Nach diesem Befehl müsstest Du Neustarten.
In der Zwischenzeit habe ich schon mehrfach neugestartet.
mit

defaults write .GlobalPreferences com.apple.mouse.scaling 1

solltest du einen normalen Wert einstellen können.
X steht hier nur für irgendeine Zahl, die man an diese Stelle setzen kann. Ich hab aber gerade mit deinem Befehl herausgefunden, dass der Wert auf 3 stand. Ein Verringern auf 1 löste das Problem nicht.
Welcher Wert kommt denn wenn du im Terminal folgendes eintippst?
Wie gesagt : 3. Ich denke mal, weil ich nicht X geschrieben habe, sondern halt irgendeine Zahl (offenbar 3) dort eingesetzt habe.
Das einzige was du machen solltest ist denke ich: ...
Hab ich gemacht, hilft aber leider auch nicht.


Ich hab jetzt übrigens mal in die History geschaut. Siehe Anhang (Markierten Bereich im Terminal nicht beachten). "killmouseaccel" ist ein Programm, was die Mausbeschleunigung deaktiviert. Komisch, dass das im Terminal erwähnt ist, denn ich bin mir sicher, dass ich dies NICHT ins Terminal eingetippt habe!

Ist es denn im Prinzip nicht leichter, OS X einfach neu zu installieren? Die Daten gehen dabei ja angeblich nicht verloren, dann bräuchte ich einfach nur etwas Zeit, die ich momentan habe.
0
Multimediawespe10.12.1013:17
Na toll, die Neuninstallation von OS X hat auch nichts gebracht. Was soll ich denn jetzt machen?
Meint ihr, bei einer anderen Magic Mouse wird das Problem nicht auftauchen? Den ganzen iMac einschicken will ich nämlich nur ungern...
0
Multimediawespe10.12.1013:19
Na super, noch ein Problem: Bei der Neuinstallation ist das Terminal nicht neu installiert worden, die history zeigt noch das gleiche an, was ja nach einer Neuinstallation unmöglich sein müsste.
Soll ich mal das Terminal löschen und dann neuinstallieren?
0
_mäuschen
_mäuschen10.12.1013:26

Die History steht ja in

/Users/MariusGerz/.bash_history


Diese Datei müsstest Du löschen.

0
Multimediawespe10.12.1013:45
Okay, aber dann ist doch nur die History gelöscht, oder? Ich muss ja im Prinzip den "Inhalt" der History löschen, also die einzelnen Befehle rückgängig machen.
Aber ich probiers mal.
0
Zetaline
Zetaline10.12.1016:41
Multimediawespe

Ist vielleicht ein 'Benutzer' spezifisches Problem.

Lege mal einen anderen 'Benutzer' an, und schau ob das Problem somit gelöst ist.

Von meinem Verständnis her, wird, wenn man Mac OS X neuinstalliert mit 'Archivieren und installieren', alle systemübergreifenden Sachen neuinstalliert und alte aussortiert. Jedoch, da du natürlich deinen alten Benutzer Account übernommen hast, wurden somit auch die "Benutzer" spezifischen Änderungen in Form von Voreinstellungen (im Preferences Ordner etc.) übertragen.

Da du die Terminal Befehle ohne su bzw. sudo ausführen konntest sind deine "Terminal Hacks"vielleicht wirklich nur für den jetzt angemeldeten Benutzer gültig.
Normalerweise kann ja auch jeder Benutzer eine andere Mausgeschwindigkeit etc. einstellen.
„Auf der Verpackung stand: Erfordert IBM kompatiblen PC mit Windows oder besser. Also entschied ich mich für Mac + OS X = ♥“
0
X-Jo10.12.1018:11
Multimediawespe
Okay, aber dann ist doch nur die History gelöscht, oder? Ich muss ja im Prinzip den "Inhalt" der History löschen, also die einzelnen Befehle rückgängig machen.
Die einzelnen Befehle kannst Du nicht durch „irgendwas“ löschen rückgängig machen. Rückgängig machen geht meist nur, wenn man die gleichen Befehle mit anderen Parametern ausführt.

Bei mir sind die Mauseinstellungen in ~/Library/Prefernces/.GlobalPreferences.plist (also im Benutzerordner), nicht in /Library/Prefernces/.GlobalPreferences.plist (also im „System“). Deshalb bringt auch (wie Zetaline ausgeführt hat) das Neuinstallieren nichts.
Bei mir sehen die Mauseinstellungen so aus:
0
X-Jo10.12.1018:25
In Unix-Systemen sind Dateien, deren Namen mit einem Punkt beginnt, versteckt (zu Recht, wie Du siehst ). Um diese sichtbar zu machen gibt's verschiedene Wege. Ich empfehle, das Programm TinkerTool zu laden (), dort bei „Finder“ „Versteckte und Systemdateien anzeigen“ aktivieren, dann (unten im TinkerTool-Fenster) „Finder neu starten“.

Dann in ~/Library/Preferences (also in Deinem Benutzerordner) die jetzt sichtbare Datei .GlobalPreferences.plist in den Papierkorb werfen, dann Neustart (evtl. reicht auch ab- und wieder anmelden).

Dadurch sollten die „Werkseinstellungen“ wieder da sein. Viel Erfolg!
0
Multimediawespe11.12.1011:19
Lege mal einen anderen 'Benutzer' an, und schau ob das Problem somit gelöst ist.
Leider nicht...
Dadurch sollten die „Werkseinstellungen“ wieder da sein.
Leider auch nicht, es hat sich nichts verändert. So langsam glaube ich, dass mit dem Terminal überhaupt nichts zu tun hat und die Maus jetzt durch Zufall falsch erkannt wird. Vielleicht sollte ich den Mac doch einschicken...
0
_mäuschen
_mäuschen11.12.1011:44

Hast Du USB Overdrive installiert?

Wenn ja: deInstall!



Oder siehe http://support.apple.com/kb/TS3048

0
Multimediawespe11.12.1012:12
Hast Du USB Overdrive installiert?
Nein.

Apples Support hilft mir auch nicht weiter.
0
Multimediawespe12.12.1020:13
Ich hab jetzt OS X komplett neu aufgespielt und vorher den Inhalt der Partition gelöscht Immerhin klappt es jetzt wieder
0
X-Jo12.12.1020:33
... und zukünftig Eingaben ins Terminal nur nach Rücksprache mit dem MTN-Forum.
0
Multimediawespe12.12.1021:00
Alles klar
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.