Forum>Netzwerke>Linux 10Gbit Probleme

Linux 10Gbit Probleme

iPhone4s13.04.2116:28
Hallo Zusammen,

Ich habe mir einen Server von Supermicro hergenommen und habe mir auf CentOS 7 einen SMB server installiert. Unter 1Gbit Verbindungen habe ich kein Problem, allerdings wenn ich auf 10Gbit hochgehe bricht die Verbindung bei last nach einiger Zeit immer ab. Was könnte hier das Problem sein?

FACTS:
txquelen ist auf 10000
direct Verbindung von server zu client


LG und danke für eure Hilfe
0

Kommentare

Jaguar1
Jaguar113.04.2116:40
Kabel!?
„Die Menschen sind nicht immer was sie scheinen, aber selten etwas besseres.“
0
iPhone4s13.04.2116:48
Habe bereits drei verschiedene probiert. Alle original verpackt.
0
Peter Eckel13.04.2117:08
iPhone4s
Habe bereits drei verschiedene probiert. Alle original verpackt.
Was für Kabel? Wie lang? Einzeln verlegt oder im Bündel mit anderen?

Es ist eine unglaubliche Menge Schrott am Markt. "Der große Fluß" z.B. verkauft Dir ungehemmt U/UTP-Kabel mit ungeschirmten Steckern als Cat 6 (wollte ich auch nicht glauben, machen sie aber). Vielleicht geht 10 GE mit denen ... über ein paar Zentimeter. Ich würde es nicht versuchen.

Kurz: "Originalverpackt" kann auch "Originalverpackter Schrott" heißen
„Ceterum censeo liberum facierum esse delendum.“
+2
awk13.04.2117:13
... allerdings wenn ich auf 10Gbit hochgehe bricht die Verbindung bei last nach einiger Zeit immer ab ...

Das klingt nach einem Treiberproblem.
0
mikeboss
mikeboss13.04.2117:28
was hat der SUPERMICRO und der client fuer eine 10Gb NIC verbaut (hersteller/chip)? wie sieht es mit der temperatur aus (unter last)? die dinger werden gerne mal ganz schoen heiss...
0
iPhone4s15.04.2108:20
Also temperatur intern im Gehäuse sind mit 30 bis max 40 Grad angegeben. Treiber ist noch ein guter Punkt, dass ich testen muss.

Ich habe folgende Netzwerkkarte: https://geizhals.at/supermicro-aoc-stg-i4t-a1711988.html. Diese verwendet den Intel 710 Chip. Treiber hab ich noch nicht aktualisiert sondern, die Standardtreiber von CentOS 7 genommen.

Bezüglich des Kabels: Es liegt einzeln ist ca 50cm lang und ja originalverpackt kann auch Schrott sein, jedoch habe ich im Beruf bereits solche Kabel schon getestet mit 10Gbit Verbindungen.

LG und Danke für eure Hilfe.
+1
Martek15.04.2109:56
Spontan hätte ich jetzt auch ein Temperaturproblem angenommen, aber genau kann man es so natürlich nicht sagen. Gibt es vielleicht irgendwo im /var/log einen Eintrag der was sagt?
0
pcp15.04.2122:17
Bandbreite mit iPerf oder mit ner Datei vom Datenträger getestet?
„0.o“
0
dudax
dudax16.04.2107:16
CentOS basiert auf Red Hat Enterprise Linux (RHEL) - somit basiert CentOS 7 auf RHEL 7.

Laut Red Hat ist für den Chipsatz Intel XL710 ein Treiber-Update erforderlich
+1
iPhone4s16.04.2120:55
Iperf zeigt 10Gbit an, dass habe ich bereits getestet.
0
iPhone4s16.04.2120:56
Nein /var/log/messages schreibt nichts bzw ist nichts derartiges vorhanden
0
pcp17.04.2118:10
Datenträger beidseitig des Tests (ohne iPerf) sind SSDs?
„0.o“
0
iPhone4s20.04.2108:55
Nein es handelt sich um ein HW RAID. Controller ist noch ein Adaptec 8885Q mit WD Enterprise Platten.
0
pcp20.04.2118:39
Hast Du mal gemessen, was der Raid/Plattenstapel 'sustained', also dauerhaft liefert? Und was er auf der anderen Seite dauerhaft wegschreiben kann?
Die 10 GBit am Netz sind pi mal Daumen 1300 Megabyte die Sekunde; der Controller 'kann' theoretische 12 GBits, die Platten vermutlich jede einzelne um die 200 Megabyte die Sekunde.
„0.o“
0
djjupp
djjupp20.04.2118:47
Ich hatte auch die Probleme, versuch mal mit meiner smb.conf

[global]
min protocol = SMB2
fruit:veto_appledouble = no
fruit:posix_rename = yes
fruit:zero_file_id = yes
fruit:wipe_intentionally_left_blank_rfork = yes
fruit:delete_empty_adfiles = yes

realm=*
vfs objects = fruit streams_xattr
ea support = yes
fruit:model = MacPro
fruit:advertise_fullsync = true
fruit:aapl = yes
fruit:encoding = native
fruit:locking = none
fruit:metadata = stream
fruit:resource = file
max protocol=smb3
workgroup = speed.de !ANPASSEN
server string = %h server (Samba, Ubuntu)
dns proxy = yes
interfaces = enp65s0 !ANPASSEN
log file = /var/log/samba/log.%m
security = user
username map = /etc/samba/smbusers
encrypt passwords = true
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
map to guest = bad user
case sensitive = yes
strict sync = no
preserve case = yes
short preserve case = yes
short preserve case = yes
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE TCP_KEEPIDLE=30 TCP_KEEPCNT=3 TCP_KEEPINTVL=3 SO_RCVBUF=131072 SO_SNDBUF=131072
veto files = /._*/.DS_Store/
„Besser heut wie morgen
0
v3nom
v3nom20.04.2119:30
CPU? SMB ist ziemlich single threaded.
0

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.