Forum>Software>Ext. Start-SSD wird nicht in „Startvolumen” angezeigt

Ext. Start-SSD wird nicht in „Startvolumen” angezeigt

Roobert
Roobert07.08.1913:45
Hi Leute,
im Anschluss an diese für mich gelöste Frage zu einer Komplettmigration () taucht nun dieses kleinere Problem auf (habe es vor 15 Stunden in den Apple communities gepostet und bisher keine Antwort – großes Danke an alle mactechnews-Weisen). Also:

Mein „alter” iMac (27'', mid 2011, HS) wurde kürzlich mit [alt-cmd-R] und einem TM-Backup mit den Daten des MacBooks (Sierra) meiner Frau bestückt (sie bekommt meinen ehem. Hauptrechner) und er soll vorerst ein Abbild des MBs sein. Soweit so gut, funktionierte, der iMac hat nun das frisch installierte HS und alle Progs und Daten meiner Frau.

Danach habe ich mit SuperDuper (toller Support von Dave Nanian!) die interne iMac-HD auf eine externe Samsung T5 geclont (weil wir 2 Wohnsitze mit je einem Rechner haben und als Hauptlaufwerk eine ext. SSD extrem praktisch ist. Backups erfolgen auf die interne HD, zur Erklärung.

Auch das funktioniert. Ich kann mit [alt] beim booten auswählen, von welcher Platte der iMac bootet und tut es auch in beiden Fällen. ABER die externe SSD scheint in den „Startvolumen”-Einstellungen nicht auf, nur die interne HD. Somit würde meine Frau immer mit [alt] booten müssen, das würde ich ihr gerne ersparen.

Habt Ihr Ideen, Tipps, wie ich die SSD als mögliches Startvolumen in die Einstellungen bekomme?
Erste Hilfe, PRAM, Neustarts, alles schon probiert. Die SSD wird auch im Finder normal angezeigt.

Merci again
Roobert
0

Kommentare

Zikade
Zikade07.08.1913:58
Hast du mal die Schritte von durchgetestet?
+2
Roobert
Roobert07.08.1914:04
Ja, jetzt, wobei es eigentlich am Thema vorbeigeht, die SSD funktioniert ja als Boot-Volume, wird nur nicht in den Startvolume-Einstellungen angezeigt.
+1
Zikade
Zikade07.08.1915:12
Ach, lesen bildet.
Ist auf beiden Platten, der internen und der externen die gleiche OS Version drauf? Ich hatte das mal mit einer internen auf High Sierra und der externen auf Mojave - von der externen konnte ich kein Startvolume auswählen, nur von der internen.
0
MikeMuc07.08.1915:34
Ich finde trotzdem den letzten Absatz bei bombich interessant und könnte mir vorstellen, das das vielleicht doch die Ursache sein könnte, warum "Das (externe) Startvolumes in der Systemeinstellung Startvolume nicht angezeigt wird.Wenn Superduper da beim klonen was vergessen hat...
Würde ich einfach mal probieren mit
sudo bless --folder "/Volumes/xxx/System/Library/CoreServices"
Und nicht vergessen, die 3 x durch den Namen deiner externen Platte zu ersetzen.
+1
Roobert
Roobert07.08.1916:57
Zikade: Ja, sind beide identisch
MikeMuc: Dein sudo-Zitat weicht von dem im Link ab:
sudo bless --folder "/Volumes/Backup/System/Library/CoreServices", was gilt?

PS: Gibt es als 1. Schritt evtl. einen sudo Befehl, der feststellt, ob das bless-en nötig ist? Nicht, dass ich mir da was zerschieße ... bin am Mac sehr bewandert (seit 1986 Mac Plus), aber null in UNIX etc.
0
Meddten
Meddten07.08.1917:32
Wenn du Mikes Beitrag durchliest, insbesondere der letzte Satz würdest du merken das es keine Abweichung gibt.
+2
Roobert
Roobert07.08.1917:42
Aha, danke! Ich hielt "Backup" für einen weiteren Befehlsteil, aber das ist die HD. Alles klar.
Das "PS" bleibt aufrecht habe gerade erstmals in sudo etc gestöbert und scheue das ...
0
MikeMuc07.08.1918:02
Roobert
Aha, danke! Ich hielt "Backup" für einen weiteren Befehlsteil, aber das ist die HD. Alles klar.
Das "PS" bleibt aufrecht habe gerade erstmals in sudo etc gestöbert und scheue das ...
Und genau deshalb hab ich Backup durch xxx ersetzt damit genau das nicht passiert das da jemand Backup stehen läßt

Schlechtes tut der Befehl nicht, also einfach machen und schauen, ob er hilft. ein nicht passiert auch nix schlimmes.
0
Roobert
Roobert07.08.1918:22
Habs gemacht, musste PW eingeben, dann war nix, keine Anzeige oder sonstwas. Nur die allg Eingabeaufforderung. Dann Neustart ganz brav von der SSD keine SSD in der Startvolumensauswahl, obwohl er von selbiger gebootet ist.
Dann zur Kontrolle ein Neustart von der Internen: SSD steht (auch) am Desktop aber wieder nicht in der Startauswahl.
Soll ich mal die Apple Hotline bemühen?
0
Roobert
Roobert07.08.1918:26
Ha! Ich seh gerade im Festplattendienstprogramm, dass bei der Internen steht "Eigentümer: Aktiv" und bei der SSD "Deaktiviert". Bringt uns das weiter?
+1
ahs07.08.1918:52
Zitat von

https://support.apple.com/de-de/HT202796

Auf Option-ROM-Firmware überprüfen
Wenn Sie den Startup Manager verwenden und Ihr Startvolume nicht angezeigt wird, drücken Sie Wahltaste-Umschalttaste-Befehlstaste-Punkt. Falls das funktioniert, verwenden Sie diese Methode jedes Mal, wenn Sie vom Gerät oder von einem damit verbundenen Startvolume starten möchten.
Zur Verbesserung der Systemsicherheit zeigen Mac-Computer mit aktueller Software Geräte mit Option-ROM-Firmware erst an, wenn Sie diese Tasten im Startup Manager drücken, um die Firmware zu laden. Auf Mac-Modellen von Anfang 2015 oder älter können Sie diese Sicherheitsfunktion deaktivieren, damit die Option-ROM-Firmware automatisch geladen wird. Dies entfernt einen wichtigen Schutz vor möglichem unbefugtem Zugriff auf Ihren Mac durch andere Personen, die physisch auf das Gerät zugreifen können.
Öffnen Sie die App "Terminal", die sich im Ordner "Dienstprogramme" des Ordners "Programme" befindet.
Geben Sie sudo nvram enable-legacy-orom-behavior=1 ein, und drücken Sie anschließend die Eingabetaste.
Sie können diesen Befehl durch Eingabe von sudo nvram -d enable-legacy-orom-behavior rückgängig machen.

Hat bei meinem MacPro 2013 geholfen...
+1
Roobert
Roobert07.08.1919:29
Danke ahs, nur steht da ganz oben: Wenn Startupmanager ... und nicht angezeigt wird. Es wird eh angezeigt, ich kann über alt zw. Interner und SSD wechseln. Die Anzeige fehlt nur in Einstellungen - Startvolumen.
Oder meinst Du, wenn ich den unten genannten sudo Befehl durchführe, erreiche ich genau diese Anzeige?

Momentan verwundert mich, warum die SSD mit "Eigentümer deaktiviert" angezeigt wird, s. 1 rauf.
0
ahs07.08.1920:12
Mit "alt" beim Systemstart ging es auch bei mir. Mein Problem war, dass nach einem Neustart nie das in den Systemeinstellungen ausgewählte Startlaufwerk benutzt wurde, das eben keine originale Apple SSD ist. Der MacPro hat es einfach ignoriert.

Allerdings ist dein iMac (wie mein MacPro) von vor 2015. Ggf. hat die T5 eine Option-ROM-Firmware. Zudem ist der Terminalbefehl jederzeit reversibel. Kaputtmachen kann man also eigentlich nichts...

Wenn man so will, handelt es sich hier leider nur um das sog. (gefährliche) "Halbwissen". Böse Zungen würden ggf. sagen, dass er (also ich) keine Ahnung hat... Sorry
0
Roobert
Roobert07.08.1920:38
Hm, wenn das noch jemand bestätigt, dass "sudo nvram enable-legacy-orom-behavior=1" harmlos ist und hilfreich sein könnte, probiere ich es gern aus.
Wobei mir gerade auffällt, dass in dem sudo-Befehl kein Laufwerk angegeben wird ...

Zur Info: Ich habe 3 Jahre lang diesen iMac immer von einer T1 gebootet, ging von Anfang an. Ob die neuere T5 den Unterschied macht?
0
Roobert
Roobert07.08.1921:02
Kleine Korrektur, schlecht ausgedrückt: Booten kann ich mittels "alt" sowieso von der T5, sie wird nur nicht in den Startvolumen-Einstellungen angezeigt, thats the problem. Die T1 damals ist auch korrekt angzeigt worden.
0
almdudi
almdudi07.08.1921:45
Roobert
Wobei mir gerade auffällt, dass in dem sudo-Befehl kein Laufwerk angegeben wird ...
Ohne echtes Wissen: der Befehl spricht ja von einem Verhalten des Rechners (behavior), das im NVRAM geändert und gespeichert werden soll. Insofern ist es nicht sonderlich seltsam, daß er sich nicht auf einzelne Laufwerke bezieht.
+1
semibold07.08.1921:52
Was ist denn im Infofenster der externen Festplatte eingestellt? Vielleicht hilft es bereits, das Häkchen dort zu entfernen.
0
Roobert
Roobert07.08.1922:03
Ok, hab mich getraut (wie von @ahs um 18:52 geraten), Neustart, alles wie gehabt. SSD wird im "alt"-Manager angezeigt, aber dann nicht in den Starvolumen-Einstellungen.
Noch immer auffällig: "Eigentümer = deaktivert" lt. Festplattendienstprogramm.
0
MikeMuc07.08.1922:10
Der Haken bei Eigentümer ignorieren muß auf jeden Fall weg, egal wie. Sonst wird das nix
0
Roobert
Roobert07.08.1922:14
Ok, der Haken ist jetzt weg, nach Neustart (von der Internen) es gibt einen Teilerfolg: In der Startvolumenauswahl taucht die SSD wieder nicht auf, aber lt. DienstplattenFP ist nun deren "Eigentümer aktiviert"!!!
0
Roobert
Roobert07.08.1922:35
Habe noch einen Unterschied zu Mojave am neuen iMac (wo das alles 1A funkt) entdeckt: Im Info-Feld ist "geteilter Ordner" bei der T1 angeklickt, bei der T5 am alten iMac aber nicht. Habe den Haken gesetzt, Infofeld geschlossen, wieder aufgemacht, und der Haken war weg ... sagt uns das was?
0
larsvonhier
larsvonhier07.08.1922:40
Gab es nicht auch eine Möglichkeit, nach dem Start in den Boot-Selektor die dortig getroffene (temporäre) Auswahl permanent zu machen? Irgendwas mit Shift+Return nach dem Anwählen des ext. Laufwerks, oder Mausklick mit Shift oder Control? Habe das nie verwendet, nur gelesen, aber das könnte hier helfen. Weiß jemand die Kombination?
+1
virk
virk08.08.1917:48
@Roobert: Ich habe/hatte bei einem macmini late 2014 ein ähnliches "Problem" wie Du. Ich habe keine Lösung gefunden. Siehe, wenn Du Lust hast
„Schön fand ich damals: Auf die Dauer hilft nur Power!“
0
Marcel Bresink08.08.1918:57
Roobert
Danach habe ich mit SuperDuper (toller Support von Dave Nanian!) die interne iMac-HD auf eine externe Samsung T5 geclont

Welches Partitionsschema hat die Platte? Befindet sich das System auf 1 HFS+-Volume oder auf 4 APFS-Volumes?

Möglicherweise wurde durch das Klonen eine sehr ungewöhnliche Kombination aus Partitionsschema und Formatierung angelegt, bei der macOS "sich nicht sicher ist", ob die Firmware des Mac das tatsächlich booten kann. Die Firmware scheint das hier offensichtlich zu können, aber die Startvolume-Einstellung ist vorsichtig und bietet keine Volumes an, die bestimmte Randbedingungen nicht erfüllen.

Wie @larsvonhier andeutet, kann man beim Anklicken der richtigen Platte im Startup Manager auch die ctrl-Taste festhalten, dann speichert die Firmware (und nicht macOS) das gewünschte Startvolume ab.
0
Roobert
Roobert08.08.1919:12
Marcel: Ich habe die SSD auf "Mac OS ext. journaled" (ohne Groß/klein) formatiert, glaube, es war auch von APFS die Rede, kann mich aber nicht genau erinnern. Cmd-I und das Festplattendp sagen nichts darüber aus, die "Informationen" im Pic schauen für mich ok aus ...? Im Moment des Screenshots war die SSD nicht das Bootlaufwerk.
0
clear12.08.1923:50
Vielleicht könnte ein frisches drüber-bügeln des system-installers helfen...

Und lass dabei den internet-schlauch angesteckt, damit der installer evt. benötigtes firmware-update laden kann
0
Roobert
Roobert13.08.1900:03
clear: Das ist eine gute, eig. naheliegende Idee! Werde ich probieren, danke.
Mit „Internet-Schlauch” meinst Du das Ethernetkabel?
0
clear13.08.1906:39
Ja.... lass das lan-kabel eingesteckt

Was ausserdem komisch ist, dass die ssd als solche nicht gelistet wird unter „solid state“...
-1
Marcel Bresink13.08.1908:32
Roobert
Marcel: Ich habe die SSD auf "Mac OS ext. journaled" (ohne Groß/klein) formatiert, glaube, es war auch von APFS die Rede, kann mich aber nicht genau erinnern. Cmd-I und das Festplattendp sagen nichts darüber aus,

Auf dem Bild wird leider nur das Volume angezeigt, nicht die Festplatte. Das Partitionsschema wäre wichtig. Aktiviere "Darstellung > Alle Geräte einblenden" und wähle die Platte "Samsung Portable SSD T5 Media" aus. Welche Partitionstabelle verwendet wird, ist dann direkt rechts in der Übersicht zu sehen.
clear
Was ausserdem komisch ist, dass die ssd als solche nicht gelistet wird unter „solid state“...

Das ist normal, da macOS über einen USB-Anschluss hinweg den Typ der Platte nicht ermitteln kann.
+1
Roobert
Roobert13.08.1911:43
Bei der FP wird im 1. Fenster „Partitionstabelle = Master Boot Record” angezeigt und im Pic die „Informationen”:
Bootfähig ist sie bewiesenermaßen.

Vielleicht sollte ich wirklich wie von @clean vorgeschlagen, das HS noch mal drüberbügeln.
Mit meinem neuen Hauptrechner (iMac 2019 + Mojave), den ich mit einer ext. T1 boote, musste ich das nach der Migration vom (jenem) alten auf den neuen Mac auch machen. Vorher stürzte er alle paar Stunden ab und zeigte in EtreCheck jede Menge „failed” launch demons an. Seither läuft er wie am Schnürchen.
0
clear13.08.1911:58
Master Boot MBR wäre nicht korrekt, sollte GUID sein

Starte mit der externen SSD, klon die Daten auf die interne "Backup"-Platte des iMac (und stell sicher, dass diese schon GUID ist), starte von der internen Platte, formatiere die externe mit GUID und klon die Backup wieder auf die externe.

Beachte auch, dass die Platte(n) korrekt formatiert ist/sind (APFS / HFS+, je nach System und Festplattenart)
Kann sonst Troubles geben bei Updates etc, wenn momentan HFS+ ist, das System aber damals auf APF installiert/formatiert wurde. Selber schon erlebt
+1
Marcel Bresink13.08.1912:02
Roobert
Bei der FP wird im 1. Fenster „Partitionstabelle = Master Boot Record” angezeigt

Damit dürfte der Fehler gefunden sein. Die Festplatte hat ein Partitionsschema, das eigentlich für macOS nicht akzeptabel ist. Auch wenn die Firmware vieler Macs trotzdem von der Platte starten kann, wird die Platte vom Punkt "Startvolume" nicht als gültig angesehen.

Du musst die Platte mit dem richtigen Partitionsschema "GUID" komplett löschen und dann den Inhalt wieder neu klonen. Das kann man auch ohne fremde Software mit dem Festplattendienstprogramm (Punkt "Wiederherstellen") machen.
+2
clear13.08.1912:36
An alle downvoter: sucht euch ein anständiges hobby oder beteiligt euch mit eurem wissen...

Und falls keines vorhanden ist:
+1
clear13.08.1912:55
Über "alt" beim booten wird der EFI-Bootmanager gestartet, da dieser auch Windows-Partitionen anzeigen kann (Bootcamp z.B.), taucht dort die SSD-MBR-Partition auf. Anscheinend hat nachher macOS keine Probleme zum booten.

Über das "Startvolume" taucht die SSD nicht auf, weil macOS diese aufgrund der MBR-Partitionstabelle nicht als korrektes Startvolume akzeptiert.
+1
Roobert
Roobert13.08.1913:14
Marcel und Clear: Danke, das dürfte es sein. Die Interne ist eh auf GUID formatiert. Und mit dem Hin- und Herklonen bin ich mittlerweile schon recht vertraut. Werde berichten.
0
Roobert
Roobert13.08.1918:43
Hurrah! Heureka! Done.
Danke an alle Mitdenker, insb. zuletzt Clear und Marcel. Ich hatte die SSD ursprünglich schlicht falsch formatiert.
Beweisfoto anbei:

Mission completed.
0

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.

OK MacTechNews.de verwendet Cookies unter anderem für personalisierte Inhalte, Seitenanalyse und bei der Auslieferung von Google-Anzeigen. Dies war zwar schon immer so, auf Wunsch der EU muss nun jedoch explizit darauf hingewiesen werden. Durch Nutzung der Website erklären Sie sich damit einverstanden. Weitere Informationen