Forum>Software>Websites verlieren Sättigung beim Scrollen

Websites verlieren Sättigung beim Scrollen

void
void17.06.0913:52
Hallo,

Ich habe ein seeeehr sonderbares Problem mit Safari4:
Gelegentlich fällt Safari in einen merkwürdigen Zustand, in welchem zwar alles einwandfrei funktioniert und auch scharf angezeigt wird, jedoch sämtliche Farben _langsam_ (als wäre animiert) verloren gehen, sobald man scrollt.
Aktualisiert sich ein Bereich der Seite (animiertes Werbebanner zb), so ist dieser wieder in voller Sättigung da, der Rest bleibt grau. Andere Events, die ebenfalls ein "repaint" auslösen (zb das draggen eines anderen Fensters über Safari) lassen die angezeigte Seite wieder in voller Sättigung erstrahlen.
Neue Tabs unterliegen diesem Problem dann ebenfalls, starte ich den Browser jedoch neu, ist das Phänomen verschwunden. Ich weiß noch nicht, wie es sich reproduzieren lässt...

Einen Hardwarefehler kann ich ausschließen, da sämtliche anderen Programme sich normal verhalten. (MBP von Anfang 2009, betrieben mit der 9400m)

Kennt jmd das Problem?

--

Im Bild erkennt man schön, dass die Bilder in den Newsmeldungen und die Links in Grautönen erscheinen, während die sich Werbebanner aufgrund des Blinkens in ihrem vollen Farbraum präsentieren können. [Bild kommt gleich, irgendwie funktioniert der Upload nicht]
„Developer of the Day 11. Februar 2013“
0

Kommentare

_mäuschen
_mäuschen17.06.0914:01

Zugriffsrechte reparieren!

0
void
void17.06.0914:04
_mäuschen
Zugriffsrechte reparieren!

is das prob bekannt? - k mache ich gleich (aber was ist das für eine begründung??)

hier endlich der screenshot
„Developer of the Day 11. Februar 2013“
0
pfa17.06.0914:31
was hat denn das mit den zugriffsrechten zu tun?
0
void
void17.06.0914:36
das frag ich mich auch... aber man habs mal gemacht (obs erfolg hatte kann man ja schwer sagen, da ich nicht weiß, wie man das prob reproduziert).

vlt muss safari auf eine bibliothek zugreifen, welche dafür sorgt, dass die farben erhalten bleiben.. sonst wird automatisch alles grau. und die bib war nicht lesbar..?
„Developer of the Day 11. Februar 2013“
0
_mäuschen
_mäuschen17.06.0914:48
void
das frag ich mich auch... aber man habs mal gemacht (obs erfolg hatte kann man ja schwer sagen, da ich nicht weiß, wie man das prob reproduziert).

Schneller Benutzerwechsel sollte das Problem "auslösen".


Ev. hilft es (wiederum) DMProxy zu starten.

0
void
void17.06.0914:52
_mäuschen
void
das frag ich mich auch... aber man habs mal gemacht (obs erfolg hatte kann man ja schwer sagen, da ich nicht weiß, wie man das prob reproduziert).

Schneller Benutzerwechsel sollte das Problem "auslösen".


Ev. hilft es (wiederum) DMProxy zu starten.

Tatsache, der Benutzerwechsel ist schuld. Habe grade auf Admin und zurück gewechselt und jetzt ist alles wieder grau in grau. Dann werde ich nun mal den macworld-artikel lesen

Das Problem ist scheinbar bekannt und ich kann davon ausgehen, dass in naher Zukunft ein Patch erscheint? (dumme Frage ich weiß... nur Apple weiß, ob das nachgebessert wird)
Rechtereparatur hat es übrigens _nicht_ behoben.
„Developer of the Day 11. Februar 2013“
0
pfa17.06.0914:52
ich hab ein ähnliches problem mit aperture, ein restart der applikation behebt das problem.
ist leider auch nicht reproduzierbar...

0
void
void17.06.0915:08
Fast user switching scheint ein Teil der Ursache zu sein (in der Mittagspause locke ich meinen Account immer, indem ich per fus auf den Loginscreen wechsel). Danach war mein Safari verbuggt.
Die im von _mäuschen verlinkten Artikel erwähnten Farbkalibrierungsprofile scheinen auch am Problem beteiligt zu sein. Ich kam dann auf die Idee, meinen externen Monitor (per miniDP/DVI angeschlossen) mal ab- und wieder anzuschließen. Dabei wurde scheinbar das Profil resettet und die Farben in Safari warn wieder da. Scheinbar wird hierdurch die im Artikel erwähnte DMProxy ausgeführt.

Aber eine Frage bleibt: Warum ist nur Safari (bzw Aperture?) betroffen und der Rest des Bildschirms zeigt sämtliche Farben wunderbar an? Das sind dochwohl nicht die einzigen Programme, welche CoreGraphics (zu diesem Framework gehört o.g. DMProxy) nutzen oder?
„Developer of the Day 11. Februar 2013“
0
pfa17.06.0916:32
auch ich habe einen externen monitor der ein eigens für den monitor erstelltes farbprofil verwendet.
wenn ich mich recht erinnere habe letztens vor dem "problem" ein aperture plug-in installiert, welches ja kurzzeitig administrator-rechte benötigt. prinzipiell scheint dies mit dem im artikel beschriebenen bug im zusammenhang zu stehen.

allerdings bin ich mir nicht sicher ob die installationsberechtigung als root einem (fast)user switch gleich kommt...

0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.

OK MacTechNews.de verwendet Cookies unter anderem für personalisierte Inhalte, Seitenanalyse und bei der Auslieferung von Google-Anzeigen. Dies war zwar schon immer so, auf Wunsch der EU muss nun jedoch explizit darauf hingewiesen werden. Durch Nutzung der Website erklären Sie sich damit einverstanden. Weitere Informationen