Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Software>“Dieser Mac kann nicht für Datenmigration verwendet werden“

“Dieser Mac kann nicht für Datenmigration verwendet werden“

hix
hix19.10.2120:54
Hallo,
nach der vorgestrigen Wiederherstellung bzw. dem sog. Clean Install macht mein iMac (24", M1, Big Sur Version 11.6) Probleme.

Vorab sei gesagt, alle Backups wurden stets mit Time-Machine auf die externe SSD (SanDisk Extreme 900) gemacht, dort wurde ein Admin- und ein Benutzeraccount abgespeichert. Die alltäglichen Arbeiten absolviere ich stets über den Benutzeraccount (… und auch sonst), also ohne die Administratorrechte.

Leider hat irgendwas vorgestern Abend diesen Benutzeraccount teilweise "zerschossen“ – z.B. waren verschiedene auf dem Schreibtisch abgelegte Ordner und Dateien auf einmal weg.

Da ich dafür keine Erklärung hatte und abends nicht lange in einschlägigen Foren nach Rat fragen wollte, hatte ich mich kurzerhand entschieden, dann eben mit Hilfe des Wiederherstellungsprogramms das Betriebssystem einfach neu aufzuspielen, um anschließend die beiden auf der externen SSD gespeicherten Accounts wieder erneut zu migrieren.

Nach dem o.g. Prozedere (incl. der obligatorisch abgefragten 2-Faktor-Autorisierung mittels meiner Apple-ID) war der Admin-Account wohl wieder vollständig da, nur der Benutzeraccount ließ sich nicht installieren, weder mit der App 'Migrationsassistent' (siehe Screenshot) noch über die Systemeinstellung 'Benutzer und Gruppen' (zwei Benutzer-Passwörter habe ich dabei verwendet – zuerst freilich das von mir notierte, vorläufig vergebene Passwort und dann versuchsweise das bisher übliche eigene Passwort – keines wurde akzeptiert.

Ich hatte den Clean-Install sogar zweimal wiederholt, aber leider nur mit dem selben Ergebnis.

Nun muss ich gezwungenermaßen zunächst mal auf dem Admin-Account arbeiten, was ich aber allein schon aus Sicherheitsgründen nur sehr ungern tue.

Obendrein "merkt" sich der wiederinstallierte Admin-Account z.B. nicht alle Kurzbefehle, die ich über die Systemeinstellung 'Tastatur' eingegeben habe. Da stimmt also was mit der jetzigen Konfiguration auch des Admin-Accounts nicht.

Kennt bitte jemand eine passende Notlösung?

0

Kommentare

hix
hix20.10.2100:56
Ich weiss, das ist viel Holz. Andererseits frage ich mich ja schon mittlerweile, ob Apples Rechtevergaben "ihre Kinder fressen".
+2
oliver
oliver20.10.2107:51
Möglicherweise hast Du mit einer neueren Systemversion die TimeMachine-Sicherungen angelegt, als Du beim frischen Aufspielen des Systems auf den Mac installiert hast?

Leg doch mal einen Benutzer an, starte die Systemaktualisierung, bis keine Updates mehr angezeigt werden und versuche dann, via Migrationsassistent die TimeMacahine-Backups zurückzuspielen.
„multiple exclamation marks are a sure sign of a diseased mind. -- terry pratchett“
+5
Marcel_75@work
Marcel_75@work20.10.2108:21
Hallo,

ich kenne das von Dir beschriebene Problem, es ist aus meiner Sicht ein (schwerwiegender) bug, der aber nur ab und zu auftaucht.

Es betrifft wenn dann ausschließlich Standard-Accounts (ohne administrative Rechte) und zeigt sich im von Dir beschriebenen Phänomen: Das temporär generierte Migrations-Kennwort des Standard-Accounts wird nicht korrekt erkannt!

Aber es gibt zum Glück einen funktionierenden workaround:

Dazu machst Du den Standard-Account im Migrations-Assistenten vor dem Start der eigentlichen Migration zu einem Admin-Account.
Denn auf diesem Wege wird Dir dann auch erlaubt, gleich das 'echte' Kennwort dieses Accounts für die Migration zu benutzen.

Nach abgeschlossener Migration kannst Du diesem Admin-Account dann auch wieder die Standard-Rechte zuweisen. Logge Dich aber ruhig erst einmal 1x ein und schaue, ob alles da ist.

Und dann ausloggen, mit Deinem 'richtigen' Admin einloggen und die Admin-Rechte des zweiten Users wieder entziehen, damit er wieder wie gewohnt ein Standard-Account wird.

PS: Und was oliver schreibt, ist eventuell auch noch zu bedenken - installiere auf dem Rechner ein frisches 11.6 mit allen!!! Updates, am besten gleich mit einem temporären Admin-User mit einer UID (User ID), die nicht in Konflikt steht mit den beiden bisherigen Accounts. Vermutlich also UID 503, da Deine bisherigen User wahrscheinlich die User IDs 501 und 502 haben werden.
Diesen temporären 'Migrations' Admin-Account kannst Du dann am Ende auch wieder entfernen.
+5
Marcel Bresink20.10.2108:34
hix
hatte ich mich kurzerhand entschieden, dann eben mit Hilfe des Wiederherstellungsprogramms das Betriebssystem einfach neu aufzuspielen

Das ergibt keinen Sinn. Wenn Benutzerdateien verschwinden, haben doch Dateien des Betriebssystems nichts damit zu tun. Zum anderen ist Big Sur auf einem Nur-Lese-Volume gespeichert und vierfach gegen Änderungen gesichert. Ein "Neuaufspielen" hat deshalb keinerlei Wirkung.

hix
nur der Benutzeraccount ließ sich nicht installieren, weder mit der App 'Migrationsassistent' (siehe Screenshot) noch über die Systemeinstellung 'Benutzer und Gruppen'

Das hört sich so an, als hättest Du bereits Accounts angelegt und dann erst die Migration gestartet. Das ist die falsche Vorgehensweise. Die Migration muss stattfinden, bevor das System irgendwelche Accounts eingerichtet hat, d.h. noch während des ersten Hochfahrens kurz vor dem Ende der Neuinstallation. Nur das garantiert, dass die gleichen Accounts mit den gleichen Rechten und Kennworten wieder eingerichtet werden. Das darf nicht manuell gemacht werden.

Die Fehlermeldung besagt, dass Du wahrscheinlich einen Konflikt zwischen den Benutzer-Accounts des "Preboot"-Betriebssystems (das die SSD entschlüsselt) und den Benutzer-Accounts von macOS ausgelöst hast.
+2
hix
hix21.10.2117:35
Vielen Dank für Eure Antworten.
Marcel_75@work, ich habe den vorgeschlagenen workaround absolviert. Mit dem Ergebnis, dass ich jetzt wieder Zugang zu meinem Standardaccount habe, mit allen Dokumenten usw.
Nur wurde der Standart-Account leider nicht als Admin konfiguriert/migriert und der Admin-Account akzeptiert das – vor der Migration – eingegebene Passwort nicht.
Bisher habe ich fünf- oder sechsmal eine Neuinstallation versucht und laut Festplattendienstprogramm stapeln sich bereits die "Macintosh HD - Data" (Screenshot).
Wenn das ein "Bug" ist, wie Du vermutest, dann ein sehr beunruhigender.
0
hix
hix21.10.2117:42
Ach ja, ich fand im Forum der Apple Support Community einen Thread von einem User, der wohl ein ähnliches Problem hatte, der Post ist vom 6. April 2021 . Die Antwort war jedoch ungeeignet und auch ich habe gestern dort die Schilderung meines Problems gepostet … bisher ohne Reaktion.
0
Marcel_75@work
Marcel_75@work22.10.2108:37
Dein Screenshot lässt vermuten, dass Du leider nicht die interne Platte 'blank geputzt' hast.

1) Bevor Du Big Sur frisch auf dem Rechner installierst, musst Du das interne Laufwerk natürlich 1x komplett blank machen.

Dazu am besten von einem externen Big Sur Install-Stick starten, dann per Disk Utility alle Volumes einblenden und da dann schauen, dass das Volume an oberster Stelle am besten erst einmal FAT-formatiert wird und danach dann wieder ein APFS-Volume mit GUID wird.

2) Erst jetzt Big Sur installieren und Admin-User temp501, temp502 und temp503 einrichten.

Dann mit dem temporären Admin-User temp503 einloggen und temp501 sowie temp502 wieder löschen (per Systemeinstellung entfernen).

3) Als temp503-Admin jetzt alle Big Sur Updates installieren und dann den Migrations-Assistenten starten.

4) Erst jetzt die Backup-Platte anschließen und dann siehe oben mein erstes Posting hier.

PS: Und die Umstellung deines Standard-Accounts (aus dem Backup) auf einen Admin-Account erfolgt vor dem Start der eigentlichen Migration innerhalb des Migrations-Assistenten, damit das 'echte' Kennwort statt eines generierten benutzt werden kann. Der bleibt dann auch Admin, bis Du ihm diese Rechte wieder entziehst.

Falls das nicht so ist, hast Du Dich an irgend einer Stelle leider nicht an die Anleitung gehalten oder aber ich habe vergessen, noch einen weiteren Punkt zu erwähnen/erläutern …
+1
Marcel Bresink22.10.2108:49
hix
Bisher habe ich fünf- oder sechsmal eine Neuinstallation versucht und laut Festplattendienstprogramm stapeln sich bereits die "Macintosh HD - Data" (Screenshot).
Wenn das ein "Bug" ist, wie Du vermutest, dann ein sehr beunruhigender.

Da ist nirgendwo ein Bug. Das Problem ist, dass Du bisher überhaupt keine echte Neuinstallation durchgeführt hast. Du hast Big Sur einfach noch 5 Mal zusätzlich auf Deinem Rechner installiert. Da das System "weiß", dass eine Neuinstallation der Betriebssystemdaten komplett sinnlos ist, wurden dabei die Volumes so optimiert, dass die Systemdateien nur in einem (1) Exemplar vorhanden sind, und alle veränderlichen Daten in 6 Exemplaren.

Wie schon erwähnt, hast Du dabei einen Konflikt der Benutzer-Accounts zwischen diesen 6 Systeminstallationen und dem Preboot-Betriebssystem verursacht, das dafür verantwortlich ist, vor dem Start von macOS den Schlüssel für die Entschlüsselung der SSD zu verwalten.

Richtig wäre:
1. Im Wiederherstellungsmodus starten.
2. Im Festplattendienstprogramm alle sichtbaren Volumes, bzw. deren Volume-Gruppe löschen.
3. macOS neu installieren.
4. Direkt am Ende der Installation, noch bevor das System zum ersten Mal normal läuft, bestätigen, dass eine Migration durchgeführt werden soll.
5. Alle Daten über den Migrationsassistenten von der Time Machine-Sicherung zurückspielen lassen.
+7
Marcel Bresink22.10.2108:56
Marcel_75@work
1) Bevor Du Big Sur frisch auf dem Rechner installierst, musst Du das interne Laufwerk natürlich 1x komplett blank machen.

Das ist auf einem M1-Mac nicht nötig. Das Wiederherstellungssystem darf bestehen bleiben. (Zur Sicherheit gibt es übrigens noch ein zweites Wiederherstellungssystem auf einer virtuellen SSD.)
Marcel_75@work
2) Erst jetzt Big Sur installieren und Admin-User temp501, temp502 und temp503 einrichten.

Nein, das ist viel zu umständlich und kann neue Probleme auslösen. Es darf überhaupt kein Benutzer eingerichtet werden. Um die alten Benutzer wiederherzustellen, bestätigt man einfach die Migration am Ende der Installationsphase.
+4
Marcel_75@work
Marcel_75@work22.10.2111:16
Marcel Bresink:

Du hast recht, man kann es natürlich erst einmal ohne extra temp503-Admin versuchen, sollte aber gleich darauf achten, einen Standard-User temporär zum Admin zu machen, denn so wird man nicht zur Generierung eines temporären Migrations-Kennworts für den Standard-Benutzer gezwungen.
-2
Marcel Bresink22.10.2111:21
Marcel_75@work
sollte aber gleich darauf achten, einen Standard-User temporär zum Admin zu machen, denn so wird man nicht zur Generierung eines temporären Migrations-Kennworts für den Standard-Benutzer gezwungen.

NEIN!

Nochmal: Es ist ein Fehler, überhaupt einen Benutzer anzulegen. Das System muss migriert werden, bevor nach Benutzer-Accounts gefragt wird.
+5
Marcel_75@work
Marcel_75@work22.10.2111:31
Marcel Bresink: Ganz ehrlich, aber das ist Quatsch, und es wird durch "schreien" (NEIN) und ein 'wütend' Smiley auch nicht besser …

Wenn man darauf achtet, dass es ein extra User mit einer individuellen UID ist, der diese Datenmigration übernimmt, dann ist das absolut kein Problem - so handhabe ich das bei problematischen Migrationen bereits seit Jahren und es gab dabei kein einziges mal irgend eine Art von Problem.

Und meine Empfehlung hast Du nebenbei bemerkt offensichtlich auch nicht richtig verstanden bzw. missinterpretiert: Bei der von mir beschriebenen Vorgehensweise wird kein neuer Nutzer angelegt!

Sondern man ändert einen zu migrierenden Standard-Benutzer innerhalb des Migrations-Assistenten zum Admin, damit man kein temporäres Migrations-Kennwort für diesen nutzen muss (denn genau damit gibt es ab und an Probleme).
-3
albertyy22.10.2119:17
... ganz entspannt ihr beiden Marcels !

Ihr seit BEIDE Super !!

Ganz tolle Statement gebt ihr hier ab, bzw. Hilfestellungen.
Toll,Toll, Toll !
ein schönes WE
0
tix
tix23.10.2122:34
Hallo,

vorab nebenbei, der Diskussion-Eröffner "hix" bin eigentlich ich, nix, weil mir für eine Weile nur der Admin-Account (s.o.) zur Verfügung stand und das im Standard-Account gespeicherte Passwort leider nicht zugänglich war.

Die lebhafte Diskussion zwischen Marcel_75@work und Marcel Bresink habe ich mit großem Interesse verfolgt, viele Dank nochmal für Eure rege Beteiligung und die Ratschläge.

"Gemacht" hab ich bis jetzt – aus Zeitgründen – noch nix zur Behebung des Problems. Bei nächster Gelegenheit werde ich allerdings Deine vorgeschlagene Prozedur, Marcel Bresink, versuchen (und das Apple Support Community-Forum hat immer noch nicht geantwortet …).

Eine Frage hätte ich noch: Welche Volumen (Festplattendienstprogramm im Wiederherstellungsmodus) könnte-müßte ich denn löschen, damit eine reibungslose Aufspielung des neuen Betriebssystems Big Sur 11.6 gelingt?
0
hix
hix23.10.2122:43
tix
Hallo,

vorab nebenbei, der Diskussion-Eröffner "hix" bin eigentlich ich, nix, weil mir für eine Weile nur der Admin-Account (s.o.) zur Verfügung stand und das im Standard-Account gespeicherte Passwort leider nicht zugänglich war.

Die lebhafte Diskussion zwischen Marcel_75@work und Marcel Bresink habe ich mit großem Interesse verfolgt, viele Dank nochmal für Eure rege Beteiligung und die Ratschläge.

"Gemacht" hab ich bis jetzt – aus Zeitgründen – noch nix zur Behebung des Problems. Bei nächster Gelegenheit werde ich allerdings Deine vorgeschlagene Prozedur, Marcel Bresink, versuchen (und das Apple Support Community-Forum hat immer noch nicht geantwortet …).

Eine Frage hätte ich noch: Welche Volumen (Festplattendienstprogramm im Wiederherstellungsmodus) könnte-müßte ich denn löschen, damit eine reibungslose Aufspielung des neuen Betriebssystems Big Sur 11.6 gelingt?

Was tix sagt, stimmt. (Ich bin ich.)
0
hix
hix21.11.2114:19
Marcel Bresink
Wie schon erwähnt, hast Du dabei einen Konflikt der Benutzer-Accounts zwischen diesen 6 Systeminstallationen und dem Preboot-Betriebssystem verursacht, das dafür verantwortlich ist, vor dem Start von macOS den Schlüssel für die Entschlüsselung der SSD zu verwalten.
Zunächst konnte ich Marcel Bresinks Hinweis nicht verstehen. Und vielen Dank im Nachhinein! Denn erst nachdem ich wiederholt Fotos der Arbeitsschritte im Wiederherstellungsmodus gemacht hatte, dämmerte mir, wo ich "falsch abgebogen" war:
Ich hatte nämlich die "Aktivierungssperre" aus Gedankenlosigkeit aktiviert, dann dies wieder vergessen und so gingen die folgenden Blockaden damit einher.
Zunächst also mußte ich (im Wiederherstellungsmodus) den "Mac aktivieren", um ungehindert mit dem, was ich vorhatte (s.o.) fortzufahren.
Wie so oft, saß hier das Problem eher vor dem Rechner. Andererseits sind entsprechende Hilfestellungen rar oder ich hatte sie nicht gefunden.
+3

Kommentieren

Sie müssen sich einloggen, um sich an einer Diskussion beteiligen zu können.