Push-Nachrichten von MacTechNews.de
Würden Sie gerne aktuelle Nachrichten aus der Apple-Welt direkt über Push-Nachrichten erhalten?
Forum>Software>Parallels Desktop 4

Parallels Desktop 4

dirac18.11.0817:27
Hallo,

seit dem Update auf Parallels Desktop 4 beobachte ich ein seltsames Verhalten.
Meine VMs liegen alle auf einer externen Platte die ich halt immer dann anschliesse, wenn ich eine davon starten will. Der Ordner ist auch als default in Parallels eingerichtet und das ganze klappt soweit auch ganz gut.
Seit dem Update auf Version 4 scheint Parallels beim Start von OSX aber zu checken, ob es alle bekannten VMs findet. Wenn die Platte angeschlossen ist, geht das auch gut. Ist die Platte aber nicht angeschlossen, legt Parallels den Ordner wo die Platte normalerweise gemountet wird einfach an. Wenn die Platte dann wirklich angeschlossen wird, wird in /Volumes ein weiterer Ordner mit dem Zusatz ' 1' angelegt und die Platte dort gemountet. Leider findet Parallels dann natürlich keine einzige VM mehr.
Lösung ist es die Platte einfach auszuwerfen, den Ordner, den Parallels angelegt hat zu löschen und die Platte wieder anzuschliessen. So wirklich praktikabel ist das aber auf Dauer sicher nicht und deshalb bin ich auf der Suche nach einer Lösung - Parallels soll halt einfach den Ordner nicht anlegen. Ich starte es ja noch nicht mal selbst!!!

Hat jemand eine Idee?

Gruß
Christian
0

Kommentare

dirac19.11.0807:56
Fällt denn niemandem eine Lösung dafür ein?
0
RAMses3005
RAMses300519.11.0808:08
Dasselbe Problem hatte ich mit meiner Musik-Sammlung auf einer Netzfestplatte. Ist diese nicht gemountet beim Starten von iTunes, dann stellt iTunes beim Importieren immer auf die lokalen Ordner um. Wenn ich dann aber iTunes schließe, die Platte mounte und dann wieder iTunes öffne ist alles beim Alten. Die Pfade stimmen wieder.

So ähnlich sollte es bei Dir auch funktionieren mit Parallels. War das bei Parallels 3 anders als jetzt mit der Version 4 ?
0
dirac19.11.0808:18
Bei Parallels 3 ist das auch passiert wenn ich es gestartet habe und die Platte nicht angeschlossen war.
Problem bei Version 4 ist ja, das das ganze schon auftritt ohne das ich Parallels starte.
Ist halt schon lästig ständig den angelegten Ordner löschen zu müssen ...
0
Dirk B.
Dirk B.19.11.0808:24
... lohnt sich das Update denn? Ich nutze die 3er-Version nur, um zwei Programme (Quicken und die Software zum GPS Tracker) starten zu können.

Danke und viele Grüße. Dirk
0
dirac19.11.0808:40
Abgesehen von diesem Problem läuft es bei mir bisher einwandfrei und allein schon die Möglichkeit der VM beide Prozessorkerne zur Verfügung stellen zu können, war für mich Grund genug für das Update.
0
Albert 2Stein19.11.0809:08
dirac
...allein schon die Möglichkeit der VM beide Prozessorkerne zur Verfügung stellen zu können, war für mich Grund genug für das Update.

Da hätte ich eine Frage zu:
Es gibt in Parallels 4 ja die Möglichkeit, die Anzahl der CPUs einzustellen. So wie ich das verstehe, stellt man dort aber die Anzahl der physikalisch tatsächlich vorhandenen CPUs ein. Wo hast Du die Anzahl der zu verwendenden Kerne eingestellt? Ich konnte das nämlich nicht finden.

Vielen Dank vorab für einen Tipp.

0
dirac19.11.0809:16
Da mein MacBook Pro ja nur eine CPU mit zwei Kernen hat und ich in den Optionen bei "Numbers of CPUs" zwischen 1 und 2 wählen kann, gehe ich mal ganz stark davon aus das man einer VM die zu verwendenden Kerne zuteilt.
0
Albert 2Stein19.11.0809:26
dirac

Ah, okay, verstehe. Du meinst, dass Parallels die beiden Kerne als eigenständige CPUs erkennt. Das könnte sein und würde auch erklären, warum bei mir am MBP in diesem Auswahlfeld 1 oder 2 CPUs (und nicht z.B. 4) angezeigt werden.

Werde das mal testen und sehen, ob ein Performance-Unterschied zu erkennen ist.
Vielen Dank.

Vielleicht hat auch jemand hier einen Mac mit mehr Kernen und kann sagen, ob diese dann dort auch als CPUs angezeigt werden (z.B. einen MacPro mit 2 CPUs und 4 Kernen, dann müssten in diesem Parallels Auswahlfeld demnach 4 CPUs angezeigt werden).
0
dirac19.11.0809:36
Für das Betriebssystem oder irgendeine Applikation sollte es eigentlich vollkommen transparent sein, ob es sich dabei um zwei (oder) getrennte CPUs oder lediglich mehrere Kerne handelt. Auf einem aktuellem MacPro mit zwei Prozessoren mit jeweils 4 Kernen sollte Parallels hier also bis zu 8 Prozessoren zur Auswahl anbieten.

Ich kann im Moment nur sagen, das eine VM bei zwei zu verwendenden CPUs in der Aktivitätsanzeige fast 200% Last erzeugen kann und bei einer (eingstellten) CPU bie knapp über 100% Schluss ist. Wie stark sich die Performance in der VM ändert, kann ich momentan nicht sagen, da ich die VMs zur Zeit nur zu Supportzwecken brauche ...
0
Peter_19.11.0809:43
ich kann hier auf einem MacPro 8 Proz. auswählen, wobei die Proz. 5 - 8 mit einem Sternchen versehen sind. Werden also z.B. 8 ausgewählt, erscheint der Hinweis "experimentell", was auch immer das bedeuten mag.
0
Albert 2Stein19.11.0809:51
Peter_
ich kann hier auf einem MacPro 8 Proz. auswählen, wobei die Proz. 5 - 8 mit einem Sternchen versehen sind. Werden also z.B. 8 ausgewählt, erscheint der Hinweis "experimentell", was auch immer das bedeuten mag.

Danke, das bestätigt also dirac's Vermutung, super.
0
dirac19.11.0810:32
Hat eigentlich noch irgendwer eine Idee wie ich Parallels davon abhalte einen Ordner unter /Volumes anzulegen wenn die externe Festplatte, die es dort sucht, nicht angeschlossen ist?
0
Peter_19.11.0810:50
dirac, ich kann das hier nicht bestätigen. Habe Parallels auch auf einem Macbook laufen, die VM auf einer externen HD. Bei mir erscheint nirgends irgendein Ordner. Wenn die HD nicht angeschlossen ist, bringt Parallels beim Start die Meldung
"Die Virtual Machine steht nicht zur Verfügung..."
Wo genau tauchen diese Ordner bei dir auf?
0
dirac19.11.0810:57
Der Ordner wird direkt im Verzeichnis /Volumes angelegt.

Also mal zur Übersicht:
  • Der Standardordner für VMs ist /Volumes/Tera/VM
  • Die externe Platte sollte unter /Volumes/Tera gemountet werden
  • Parallels versucht auf den Ordner /Volumes/Tera/VM zuzugreifen und legt ihn an, wenn er nicht existiert
  • Die externe Platte wird dann unter "/Volumes/Tera 1" gemountet und Parallels findet die VMs logischerweise immer noch nicht

Zum Schluß habe ich also einen leeren Ordner /Volumes/Tera/VM und eine unter /Volumes/Tera 1 gemountete externe Festplatte.
Wenn ich die Platte dann auswerfe, den Ordner /Volumes/Tera lösche und die Platte wieder einbinde, funktioniert wieder alles.
0
Peter_19.11.0811:05
...und der Kommentar beim Start ohne angeschlossene HD?
0
dirac19.11.0811:08
In der Liste der bekannten VMs sind alle ausgegraut.
Die genaue Meldung muss ich bis heute Abend wohl schuldig bleiben, da ich in der Arbeit bin und der Mac daheim steht.
0
Peter_19.11.0811:17
bin gespannt. bis dahin.
schönen Tag.
0
dirac19.11.0819:42
So, hier sind Screenshots von Parallels und aus dem Terminal.

Außerdem mal ein Auszug aus der parallels.log

19:26:18.534 F /disp:153/          Parallels VM Directory /Volumes/Tera/VM does not exists. Will create a new directory
19:26:18.534 F /CAuth:153/          stat64() has returned error: No such file or directory, /Volumes/Tera
19:26:18.534 F /CAuth:153/          stat64() has returned error: No such file or directory, /Volumes/Tera
19:26:18.535 F /CAuth:153/          stat64() has returned error: No such file or directory, /Volumes/Tera/VM
19:26:18.535 F /CAuth:153/          stat64() has returned error: No such file or directory, /Volumes/Tera/VM
19:26:18.536 F /disp:153/          Parallels VM Directory /Volumes/Tera/VM successfully created.
0
dirac19.11.0819:47
Hier sieht man mal den "aktuellen" Ablauf. Ist aber halt nicht der Weisheit letzter Schluss.
0
sir_wagner19.11.0820:13
Kannst du das letzte Bild nochmal größer veröffentlichen?
0
dirac19.11.0820:35
Ich bin mir zwar nicht sicher ob das jetzt eher ein Scherz war, aber bitte ...
0
dirac19.11.0820:39
Ganz toll, gerade eben habe ich meinen Rechner neu gestartet (sogar mit angeschlossener externer Platte) und schon wieder habe ich die zwei Ordner unter /Volumes und in parallels.log steht der Eintrag von oben. Was bitte schön startet Parallels denn alles im Hintergrund und treibt dann solchen Schabernak?!!?!?
0
dirac20.11.0809:46
Hallo,

Nachdem ich gestern dann ja noch ein paar Infos nachgeliefert habe, findet sich vielleicht heute eine Lösung ...

Gruß
Christian
0
teorema67
teorema6720.11.0812:06
dirac
Wenn die Platte dann wirklich angeschlossen wird, wird in /Volumes ein weiterer Ordner mit dem Zusatz ' 1' angelegt und die Platte dort gemountet. Leider findet Parallels dann natürlich keine einzige VM mehr.
PD habe ich nicht.

Bei iTunes funktioniert das mit der Lib auf der ext. Platte auch nur, wenn ich ein Alias des "iTunes Music" Ordners der ext. Platte in den iTunes Ordner der Home Directory lege, ansonsten legt iTunes immer einen neuen "iTunes Music" an und findet den auf der ext. Platte nicht. Vielleicht hilft das bei PD ja auch.
„Ich möchte nicht, dass jemand vor mir Katzenbilder ins Internet stellt (Glenn Quagmire)“
0
dirac20.11.0812:36
Danke für den Tipp, das werde ich heute Abend mal probieren.
Vielleicht reicht es dann ja sogar die Einstellung für den Default-Ordner einfach auf einen Ordner auf der internen Platte umzustellen und die VMs dann halt per Doppelklick aus dem Finder zu starten ...

Mal schauen, ob was davon hilft.
0
dirac20.11.0820:18
Nach dem Tipp mit dem Alias habe ich vorhin mal ein paar Sachen ausprobiert und habe jetzt eine für mich akzeptable Lösung gefunden. Ob das von Dauer ist, muss sich natürlich noch zeigen, aber im Moment sieht es ganz gut aus.
Hier eine kurze Erklärung:
Ich habe als neuen Default-Ordner einfach ein Verzeichnis in meinem Benutzerordner angelegt. Das sollte somit immer zu finden sein und Parallels somit nicht auf die Idee kommen irgendwelche Verzeichnisse anzulegen.
Um meine ganzen VMs trotzdem bequem nutzen zu können habe ich sie per Softlink (im Terminal per ln -s SOURCE - geht vllt. auch einfacher im Finder per Alias aber die Unix-Shell ist mir schon von berufswegen alles andere als fremd ) in das neue Verzeichnis eingebunden.
Wenn jetzt Parallels gestartet wird ohne das die externe Platte angeschlossen ist, werden die VMs einfach ausgegraut. Wird die Platte dann angeschlossen, ändert sich sofort der Status und die VMs können ganz normal verwendet werden.

Einzeiger Haken ist jetzt halt, das ich beim Anlegen einer neuen VM darauf achten muss sie nicht im Default-Ordner sondern auf der externen Platte zu erstellen und dann einen neuen Softlink anzulegen. Damit kann ich leben!!!

Viellleicht stößt ja mal noch irgendwer anders auf dieses Problem und kann sich dann so behelfen.
Auf jeden Fall vielen Dank für die Denkanstöße und Lösungsvorschläge!

Gruß
Christian
0
Laphroaig
Laphroaig21.11.0818:52
Ich finde, dass das Parallels 4 Icon eine ziemliche große Bruchlandung ist. Vorher wars doch schon nett, was haben die bloss. Geht das nur mir so?
0

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.