Nach Neuinstallation von ML fehlt die Wiederherstellungspartition

Ute M.
Guten Morgen,
wie der Titel schon besagt fehlt die Wiederherstellungspartition. Ich habe eine neue SSD-Platte in meinem MBP, darauf ein frisches ML. Da habe ich dann mein TM-Backup gezogen.
Alles läuft super, dann ist mir aber in den Systemeinstellungen aufgefallen, dass die Mac-Suche nicht mehr funktioniert. da gab es dann den Hinweis.
Hat jemand eine Idee?

Kommentare

Sagrido
Ja, das ist leider so.
Time Machine stellt leider nicht die Recovery-Partition wieder her.
Finde ich auch ätzend.

Lösung:
Auf leere SSD Mountain Lion frisch installieren (entweder über Internet-Recovery-Modus des Macs, oder von einer externen Platte booten, wo schon OS X drauf ist und dann den Installier aus'm App Store starten).

Danach frisches System booten und alles vom Migrations-Assistenten importieren lassen (ist sogar die sauberere Methode, wenn man evtl. mal Probleme in den Systemeinstellungen hatte).

Zum jetzigen Zeitpunkt könntest Du auch einfach den Mountain Lion-Installer aus dem App Store laden und einfach drüber installieren.
Danach haste wieder eine Recovery-Partition.




Übrigens:
Wenn man eine Macintosh HD mit Recovery-Partition hat und dann von einer externen Recovery-Partition (oder der Internet-Recovery) startet, und dann per Time Machine das System auf die Macintosh HD wiederherstellt, löscht Time Machine sogar die Macintosh HD UND die Recovery Partition und stellt dann das Backup auf einer neu formatierten Macintosh HD wieder her, wobei ebenfalls am Ende eine entsprechende Recovery Partition fehlt.

Will man also mal zwischendurch sein System von einem Backup wiederherstellen, tut man immer gut daran, von der internen Recovery-Partition zu starten, um Time Machine Wiederherstellung auszuführen. Time Machine kann dann jedenfalls nicht die Recovery-Partition einfach löschen, von der es selbst gerade ausgeführt wird.



Abgesehen davon finde ich, Apple sollte längst OS X mal die Funktion spendieren, bei einer fehlenden Recovery-Partition einen Knopf zu bieten, wo die Partition kurzerhand erstellt wird.
Ich meine, sogar bei Time Machine-Volumes kriegt Apple es hin, kurzerhand auch noch ein Recovery-System drauf zu schreiben.
Dann sollte meiner Meinung nach es auch möglich sein, dass wenn ein Nutzer Find my Mac oder FileVault 2 aktivieren will, nicht eine Fehler-Meldung, sondern ein Fenster kommen sollte, das anbietet, eben die benötigte fehlende Partition zu erstellen.
Vielleicht hat Apple ja in Mavericks mal dran gedacht… Bis jetzt sieht Mavericks ja so aus, als würde es genau auf viele kleine Details wie dieses Rücksicht nehmen (und dabei sieht es immer noch nach OS X aus - nicht wie dieses potthässliche iOS 7)
Boss
Bei der Installation, wie war die SSD angeschlossen?
ExMacRabbitPro
Lade dir CArbonCopyCloner. das Tool kam die Rettungspartition nachträglich anlegen. Unverständlich warum das Festplattendienstprogramm dies nicht eingebaut hat....
„"Every Gun That Is Made, Every Warship Launched, Every Rocket Fired, Signifies - In The Final Sense - A THEFT From Those Who Hunger And Are Not Fed, Those Who Are Cold And Are Not Clothed." - Dwight D. Eisenhower.“
Sagrido
ExMacRabbitPro: Das kann CCC nur, wenn es eine Quelle für die Recovery-Partition hat.
Ich würde wie gesagt jetzt den Mountain Lion Installier drüber bügeln.
Boss
CCC kann diese Partition erst nutzen, wenn sie gemounted ist, hab unten ein Bild.
Recovery HD wird nur einmal angelegt, heißt wenn sie auf der HD ist, wird sie nicht nochmal auf SSD angelegt.
was sagt denn

diskutil list

?
„...“
Ute M.
super, vielen vielen Dank für die (mal wieder) vielen hilfreichen Tipps.
werde ich morgen gleich mal drüber installieren.
Sonnige Grüße
Ute M.
so, ML noch mal neu installiert, alles ok super.

Ich dachte schon, jetzt ist alles ok, aber es gibt leider ein neues Problem: Mail stürzt immer unmittelbar nach dem Öffnen ab, es gibt auch keinen Hinweis darüber wie sonst üblich, wenn ein Programm sich vorzeitig beendet.
Ich habe daraufhin probiert: sicherer Systemstart, ML noch mal neu installiert, Combo-Update, Rechte repariert .... leider alles unverändert.
Hätte vielleicht noch mal jemand eine Idee?
mistamilla
Lösche die Dateien, die mit "Envelope Index..." beginnen, aus "DeinUser/Library/Mail/V2/MailData". Danach "importiert" Mail die Nachrichten neu.
„ITZA GOOTZIE“
Ute M.
Hallo Mistamilla,
danke für den Hinweis, aber das war es leider nicht. Programm stürzt nach dem Import wieder sofort ab.
Ich probiere gerade mal den Weg über einen 2. Nutzer. Damit scheint es zu funktionieren ...
Hätte vielleicht noch jemand eine Idee?
_mäuschen
mail preference plist
Ute M.
Hallo Mäuschen,
danke für den Hinweis.
Aber, ich finde die benannte Datei leider nicht ...
ich schicke mal ein Foto von den Prefs, wo ich die Plist-Datei vermutet habe ....
oder, wo müsste die sein ??
Weiter oben bei "com.apple... " ?
Sagrido
Hast Du das Face2Face PLugin bei Mail installiert?
Du solltest Dir dann mal die neue Version ziehen.

Wahrscheinlich war Dein System auf 10.8.3 (oder früher), hast es nun wiederhergestellt,
und hast mit dem Installieren von Mountain Lion aus dem App Store natürlich ein 10.8.4 drüber gebügelt - Das Mail aus 10.8.4 crasht beim Start, wenn man das veraltete Face2Face-Plugin drin hat.
Ute M.
danke für die Antworten.

Plugin habe ich nicht installiert.

Unter den Prefs "weiter oben" habe ich lediglich gefunden:
(und das ist es vermutlich nicht ....)
camaso
Mail braucht im Ordner "Containers" einen korrekten Link zum Mail-Ordner in den Preferences. Der "Containers" liegt auch in den Preferences. Leider habe ich hier zuhause noch SL, drum kann ich Dir den genauen Pfad nicht nennen. Schau mal nach, ob der Link korrekt drin ist.
„Es gibt Menschen, die bei starkem Wind Mauern bauen. Andere setzen Segel.“
.lockfile?

Sieht eher nach 10.7.x aus
„...“
Ute M.
noch mal danke für die Antworten.
Ich nutze 10.8.4
Containers habe ich gefunden, allerdings direkt in der Library und nicht in den Prefs ....
camaso
Ute M.
noch mal danke für die Antworten.
Ich nutze 10.8.4
Containers habe ich gefunden, allerdings direkt in der Library und nicht in den Prefs ....
Stimmt, sorry. Hab das nur aus dem Gedächtnis geschrieben und mich wohl geirrt.
Ist der Link innerhalb des "Data"-Ordners zum "Mail"-Ordner korrekt vorhanden oder ist er weiss? Wenn weiss, kannst Du ihn löschen und neu anlegen.
„Es gibt Menschen, die bei starkem Wind Mauern bauen. Andere setzen Segel.“
Ute M.
st der Link innerhalb des "Data"-Ordners zum "Mail"-Ordner korrekt vorhanden oder ist er weiss? Wenn weiss, kannst Du ihn löschen und neu anlegen.

.. sorry, ich bin hier nur mit (gefährlichem) Halbwissen unterwegs.
So sieht der Ordner aus, ist gefüllt:
camaso
Genau, dann Library und dann Mail (hoffentlich, sonst bitte wieder Bild posten)
„Es gibt Menschen, die bei starkem Wind Mauern bauen. Andere setzen Segel.“
camaso
Sodele, hab nachgeschaut. So muss das aussehen:
„Es gibt Menschen, die bei starkem Wind Mauern bauen. Andere setzen Segel.“
Ute M.
Hallo Camaso,
weiter danke für Deine Hilfen.
Ich habe jetzt nachsehen können, es sieht bei mir genauso aus.
Das ist offenbar nicht der Fehler.
Wenn ich Mail öffne, dann erscheint das Fenster für ca 3 Sekunden und schließt dann wieder. Das Programm ist damit abgestürzt, ein Hinweisfenster erscheint aber nicht.
Wie schon gesagt gibt es unter dem 2. Nutzer das Problem nicht....
camaso
Hmmm....
Jetzt wird's aufwendiger. Verschiebe mal testeshalber den Mail-Ordner aus der Library auf den Desktop, desgleichen die com.apple.mail.plist sowie den Ordner com.apple.mail aus den Containers. Startet Mail dann "jungfräulich"? Dann scheinen Deine Mail-Daten beschädigt zu sein. Nun könntest die Accounts neu einrichten und dann die Mails Ordner für Ordner importieren. Der Ordner, der blockiert, wird dann genauer untersucht, ev. Mail für Mail importieren.
Mehr Ideen habe ich leider nicht. Viel Erfolg!
„Es gibt Menschen, die bei starkem Wind Mauern bauen. Andere setzen Segel.“

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.

Ihre ersten Erfahrungen mit OS X Yosemite?

  • Hervorragend, ein perfektes und zuverlässiges Update27,3%
  • Ein gutes und weitgehend zuverlässiges Update, bin zufrieden39,7%
  • Tendenziell zufrieden14,1%
  • Bin mir noch unschlüssig8,8%
  • Tendenziell unzufrieden4,8%
  • Ein schlechtes und weitgehend unzuverlässiges Update, bin unzufrieden1,6%
  • Bin entsetzt, Yosemite ist totaler Murks3,6%
995 Stimmen20.10.14 - 30.10.14
8813