Dateien auf dem Server auch ohne Endung erreichbar

Hallo,

ich habe heute gesehen, daß auf "meinem" Server Dateien auch ohne Endung erreichbar sind.
Weiß jemand, wie man das abschalten kann?
„Hagen Rether 2014: https://www.youtube.com/watch?v=U19ij63Qa24“

Kommentare

silver2k
Wieso sollten Dateien ohne Endungen auch nicht erreichbar sein?
Pass doch einfach die Zugriffsrechte für die Dateien an.
Missverständnis.

Die Eingabe von www.domain.tld/directory/file0001.htm und www.domain.tld/directory/file0001 bewirkt dasselbe.

Es wird file0001.htm aufgerufen. Ich möchte aber, daß der korrekte Name angegeben werden muß, mit Ausnahme von Dateien, die mit index anfangen
„Hagen Rether 2014: https://www.youtube.com/watch?v=U19ij63Qa24“
buck
Entweder ist das in der Serverkonfigurationsdatei (wahrscheinlich Apache https.conf) oder in der .htaccess-Datei (rewrite) in Deiner Domain so eingestellt. Schau mal nach und ändere ggf. die Werte dafür.

Bei Dateien, die mit index anfangen sollte das dann auch nicht gehen. Da reicht es normalerweise www.domain.tld/directory/ aufzurufen wenn Du www.domain.tld/directory/index.htm willst.
also eine https.conf gibt es hier nicht; und meiner .htaccess steht derartiges nicht drin.
„Hagen Rether 2014: https://www.youtube.com/watch?v=U19ij63Qa24“
silver2k
Hast du mal deinen Browsercache etc. geleert? Könnte mir vorstellen das da eventuell die Autovervollständigung von bereits besuchten Seiten dazwischen funkt.
Ja, das hat allerdings keinerlei Einfluss, dies habe ich mit verschiedenen Browsern getestet.

Ich habe im Internet etwas gelesen, daß nannte sich mod_rewrite (o.ä.). Damit könnte man das einstellen, nur das Problem ist, ich versteh die englischsprachige Dokumentation nicht bzw. es scheint sehr PHP bezogen zu sein. Kann leider kein PHP, es müßte auch mit der .htaccess gehen.
„Hagen Rether 2014: https://www.youtube.com/watch?v=U19ij63Qa24“
buck
mod_rewrite wäre normalerweise in der .htaccess-Datei mir "rewrite ......" eingetragen.

Es könnte aber auch global in der httpd.conf (Autokorrektur hatte fälschlicherweise https draus gemacht) eingetragen sein. Die Datei findest Du nicht auf deiner Webseite. Die ist (je nach Serversoftware unterschiedlich) an anderen Orten. Da wirst Du wohl nicht rankommen.

Wende Dich doch erstmal an den Betreiber Deines Servers. Der sollte Dir da weiter helfen können.
Aha, ich habe die Lösung gefunden. Sie ist ganz simpel.

Options -MultiViews
„Hagen Rether 2014: https://www.youtube.com/watch?v=U19ij63Qa24“
PS: Hier die Erklärung
.htaccess Options MultiViews

Bei "Options MultiViews" wird dem Server mitgeteilt, nach alternativen Inhalten zu suchen und auszuwählen, die am besten den übermittelten Bedingungen des anfragenden Clients bzw. Browser entsprechen. Wird z.B. nur http://www.domain.tld/sitemap übergeben, kann nach "sitemap.xml, sitemap.html, sitemap/ Directory" oder anderen Inhalten / Dateien gesucht werden. Der Benutzer bekommt nichts von der Verarbeitung mit, denn dies wird serverseitig ermittelt. Dies lässt sich mit "+MultiViews" aktivieren und mit "-MultiViews" deaktivieren.

# Abschalten der Bedingung
Options -MultiViews

# Aktivieren der Bedingung
Options +MultiViews

„Hagen Rether 2014: https://www.youtube.com/watch?v=U19ij63Qa24“

Kommentieren

Diese Diskussion ist bereits mehr als 3 Monate alt und kann daher nicht mehr kommentiert werden.

Wie sind Ihre ersten Erfahrungen mit iOS 8?

  • Alles läuft bestens, ich bemerke deutliche Verbesserungen14,5%
  • Alles läuft bestens, ich bemerke geringfügige Verbesserungen31,0%
  • Keine Probleme, aber auch keine spürbaren Verbesserungen26,4%
  • Bin eher nicht so überzeugt9,8%
  • Bin unzufrieden mit iOS 84,5%
  • Ich kann/will nicht auf iOS 8 umsteigen13,7%
881 Stimmen18.09.14 - 02.10.14
8233